Can't login anymore, "Login Failed"

Since my last restart I can no longer login to my Plasma desktop. I don’t get a password error or such, but a “Login Failed”. I don’t know what I have broken, but it must be something. Has anyone seen this and is there a fix possible? Or is the only fix to do a full clean re-install?

Can you login via tty? With Ctrl+Alt+F2 for example? (on laptops you also need to press fn key)

I would think it should be fixable.

We just have troubleshoot it to find the cause. There are lots of things that could cause this to happen. One common cause is if you break the permissions on your home directory.

I agree with @Tasia91, the first thing to do is to press ctrl-alt-f2 and try logging into a TTY. First try with your normal account, if that doesn’t work, try with the root account.

Thanks! I will try this asap, though I just got called into a spontaneous meeting… :frowning: So could be an hour or two.

My normal account is the root account. E.G. I only have one account.

However, I just tried logging in with TTY and there is says “Login Incorrect”. However, I am 100% sure I’m typing the correct password. Could it somehow accidently have been changed?

The thing I was playing around with yesterday was making my own theme and I did delete a few theme files that I had uninstalled by still had files left in the theme folders.

keyboard layout changed? may caused be something you try before…

You mean you login as “root” everyday? If not, I think there would be a root account even if you have never used it.

Try logging into the TTY as root using your normal password.

1 Like

i would say you choose to use the same password for user and root on install, so you have a root account and a user account, but both using the same password.

1 Like

True! Sorry didn’t actually think about that. Will give it a go now. :slight_smile:

I managed to login into TTY with root and my password. So must be something user specific then. With my normal user account. Can I somehow update my password in this TTY

Of course, just type

passwd atbios

Replace atbios with your username

Hmm. I updated my password, but I still get login failed. And when I do it with the user in TTY I still get “login incorrect”.

I did restart the laptop after changing password.

If you login to the TTY as root, what do these show, does you user own all the files/directories?

ls -l /home
ls -la /home/atbios

By the first command I got

drwx------ 34 atbios atbios 4096 29. May 20:49 atbios

By the second a got a long list with different texts like:

drwx ------ 34
drwxr -x--- 2
And so on

All expect one says atbios.

The only expection is the one below that says root.

drwxr-xr-x 3

You didn’t say what that one is, so it is hard to say if it matters but it is somewhat non-standard that root would own files in your home directory.

Unless you have a reason for having root owned files in your home directory, I would chown the whole thing back to your user.

chown -R atbios:atbios /home/atbios


The answer for ls -l /home says atbios.

For the other command with la I get a long list.

The one that says root says

drwxr-xr-x 3 root root 4096 17. May 16.13 ..

For the rest of all results I get atbios as the owner. (Desktop, documents, one with just one ., etc.)

That one is OK. .. refers to the parent directory.

I would try creating a new user and see if you can login with it to test.

useradd -m -G wheel atbios2
passwd atbios2

I created a new user like you suggested and with the new user I managed to login without any issues.

So…basically something in your home directory is broken.

EDIT: Or your shell is set wrong, we should check that.

Actually it seems that my original user is deleted.

When I go into system settings there is no other user there except for the new one I created. And all folders in the other user profile is not to be found (e.g. the NextCloud folder is gone and I cant even find it when I search). I mean I figured I wouldnt see them, but all other files and folders seems to be completly gone.