Can't install network printer

I just recently converted from Manjaro to Endauvour, and like it so much. But I got a problem and cannot find a way to solve it, so, please, help.

I’m trying to install department Toshiba eStudio 3510 network printer. I’m in Gnome DE, and using GUI installer for this, “add new printer” → search network printer … Printer is found, and default drivers are loaded. But it returns an error ‘server-error-internal-error’

In Manjaro I’m adding this printer to the list, and then manually changing the default driver to the proper one (the printer has a department code, so, I am adapting it too). But I cannot even add the printer.

Could you please help me, or give me a link to the terminal installation procedure for the online printer?

Thanks in advance!

Welcome to the forum! :smile:

I’m not familiar with Toshiba printers, so you may need more than the stuff below to get it working.

Don’t know if this helps, but you can see some Toshiba printer drivers with command

yay -Ss toshiba

If you need any of them, you can install it with command

yay -S "some-package-name"

Thank you very much, I appreciate the community of Endeavour, it is impressive.

I believe that it is not a problem of the driver, as I have a PPD file with Linux driver for Toshiba, which worked fine on Manjaro. It seems that it is CUPS problem, but I have not enough knowledge to understand why and where.

I will try at home to install HP printer, and shall report if the same problem persists.

Thank you.

try the Troubleshooting: Network printer not reachable: part from the printing wiki @manuel posting already.

Could be an issue with the local DNS resolution.

Be sure to

sudo systemctl status cups.service 

If it isn’t up and running, try

sudo systemctl enable cups.service
sudo systemctl start cups.service

Once cups is up and running, if it still doesn’t work we can try installing via cups. In a browser window, enter the following in the URL entry.

localhost:631

I have never had any luck using the printer installer in Gnome. So I just do it in CUPS itself.
That is where you would enter the PPD file.

Pudge

1 Like

or install system-config-printer GUI :wink:

1 Like

For a lot of users, that would be a good call.
For me, I have installed printers from the CUPS Server (localhost:631) so many times that I could almost do it in my sleep.

Besides, if I installed system-config-printer, I would receive the “Bloat” calls.

Pudge

2 Likes

I checked it with my home printer (HP), and I got the same “server-error-internal-error” message.

I have tried then installing it via localhost:631. It worked fine.

So, it appears, I have a problem exactly with GUI system-config-printer. I do not know though what is the problem, but at least the problem with printer setting up seems to be resolved. I just need to test it with our department printer.

Thank you so much for the help.

sure you were using it? or using the printer setting from GNOME settings GUI?

Yes, sure, because I run system-config-printer from Terminal.

But Gnome installer for Printers was giving the error too.

I printed test page with HP home printer installed via “localhost:631”. I’ll try it tomorrow with our department printer.

It appears that I finally got it. I had a problem with hostname resolution by Avahi. I was able to install printers by localhost:631, but they were not printing, giving back the error of “failed to connect”.

As suggested in Avahi Arch Linux page, I modified …/etc/msswitch.conf by adding “mdns_minimal [NOTFOUND=return]” to host line. Afterwards, I was able to connect to printers.

However, funny enough, department printer still wasn’t printing. Somehow, the department code for printing, set up in localhost:631 was not reckognized. After editing the options of the department printer in system-config-printer, it started (finally!!!) to print.

Offtopic: Wow, I am so proud of myself, and so grateful to Endeavour OS and this community! I’ve switched to Linux few years ago, starting from Ubuntu. Then it was Linux Mint, then Manjaro. And finally, Endeavour OS, and I never felt so much of the confidence and control on the things happening on my computer. Once again - many thanks and kudos to Endeavour OS community!

Troubleshooting: Network printer not reachable:

as I suggested already before :wink: