Can't get wireless adapter working on new install

New install of EOS. I’ve updated the system post install, so everything should be up-to-date(?). But I cannot get my wireless card to work.

Information from inxi -Na:

Network:

Device-1: Broadcom BCM4360 802.11ac Dual Band Wireless Network Adapter
vendor: ASUSTeK driver: wl v: kernel modules: bcma pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 14e4:43a0 class-ID: 0280

Device-2: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 05:00.0
chip-ID: 10ec:8125 class-ID: 0200

The “Device-1” (the BCM4360) adapter is the problem one that I can’t get working (it’s the wireless PCI card). (Device-2 is the ethernet port and that works fine).

I’ve tried reinstalling the broadcom-wl-dkms package. I’ve tried installing the broadcom-wl package instead. I’ve restarted the Network Manager service. I’m really not sure what else to do.

In case you have no better advice #11

It should be working with broadcom-wl-dkms

I have the same in my system.

Device-2: Broadcom BCM4360 802.11ac Dual Band Wireless Network Adapter
    driver: wl v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 25:00.0 chip-ID: 14e4:43a0 class-ID: 0280
[ricklinux@rick-ms7c37 ~]$ pacman -Qi broadcom-wl-dkms
Name            : broadcom-wl-dkms
Version         : 6.30.223.271-36
Description     : Broadcom 802.11 Linux STA wireless driver
Architecture    : x86_64
URL             : https://www.broadcom.com/site-search?filters[pages][content_type][type]=and&filters[pages][content_type][values][]=Downloads&page=1&per_page=10&q=802.11%20linux%20sta%20wireless%20driver
Licenses        : custom
Groups          : None
Provides        : None
Depends On      : dkms
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : broadcom-wl
Replaces        : None
Installed Size  : 7.62 MiB
Packager        : Jan Alexander Steffens (heftig) <heftig@archlinux.org>
Build Date      : Sun 11 Dec 2022 07:37:13 PM
Install Date    : Sat 16 Mar 2024 07:55:30 PM
Install Reason  : Explicitly installed
Install Script  : Yes
Validated By    : Signature

[ricklinux@rick-ms7c37 ~]$ 

Edit: lsmod should show

Screenshot_20240528_142313

Edit: As @eso has provided a link to blacklist other modules but you shouldn’t have to. I haven’t on mine.

Edit: Not sure if you rebooted after installing broadcom-wl-dkms :thinking:

Thanks. Yes, I had seen that page @eso linked to and had tried the solution there (to no avail).

I get the same outputs as you when I run all those commands. It’s just that the adapter simply does seem to be running/working/?. nmcli doesn’t list it there and I see no wireless networks.

What does this show

systemctl status NetworkManager

NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; preset: disabled)
     Active: active (running) since Tue 2024-05-28 11:30:56 PDT; 7min ago
       Docs: man:NetworkManager(8)
   Main PID: 857 (NetworkManager)
      Tasks: 4 (limit: 18842)
     Memory: 8.4M (peak: 9.9M)
        CPU: 197ms
     CGroup: /system.slice/NetworkManager.service
             └─857 /usr/bin/NetworkManager --no-daemon

May 28 11:31:01 desktop NetworkManager[857]: <info>  [1716921061.3885] device (enp5s0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
May 28 11:31:01 desktop NetworkManager[857]: <info>  [1716921061.3896] device (enp5s0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
May 28 11:31:01 desktop NetworkManager[857]: <info>  [1716921061.3896] device (enp5s0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
May 28 11:31:01 desktop NetworkManager[857]: <info>  [1716921061.3897] manager: NetworkManager state is now CONNECTED_SITE
May 28 11:31:01 desktop NetworkManager[857]: <info>  [1716921061.3898] device (enp5s0): Activation: successful, device activated.
May 28 11:31:01 desktop NetworkManager[857]: <info>  [1716921061.3901] manager: startup complete
May 28 11:31:02 desktop NetworkManager[857]: <info>  [1716921062.8932] manager: NetworkManager state is now CONNECTED_GLOBAL
May 28 11:31:03 desktop NetworkManager[857]: <info>  [1716921063.3645] agent-manager: agent[7c8f311516dc2587,:1.41/org.kde.plasma.networkmanagement/1000]: agent registered
May 28 11:31:08 desktop NetworkManager[857]: <info>  [1716921068.2944] audit: op="statistics" interface="enp5s0" ifindex=2 args="2000" pid=1201 uid=1000 result="success"
May 28 11:36:44 desktop NetworkManager[857]: <info>  [1716921404.2723] audit: op="statistics" interface="enp5s0" ifindex=2 args="2000" pid=1201 uid=1000 result="success"

enp5s0 is the ethernet adapter, not the wireless one.

Have you tried

sudo rmmod b43
sudo rmmod ssb
sudo modprobe wl

When I run sudo rmmod b43 and same for ssb, it says those modules aren’t currently loaded (I noticed that when I manually installed the broadcom-wl-dkms it seemed to automatically run remove those modules). Running sudo modprobe wl seems to…do nothing? I run it, but then it just shows the cursor as if it’s waiting to do something.

Try rebooting.

Was about to edit my comment, but I have rebooted many times.

Have you done anything else messing around trying to get it working? You may have to blacklist the other modules as per the wiki 5.3

https://wiki.archlinux.org/title/broadcom_wireless#Device_with_broadcom-wl_driver_not_working/showing

Do you have the network icon in the tray? Is WiFi turned on? Left click on the network icon.

I have tried blacklisting all the modules in @eso link above:

blacklist b43
blacklist b43legacy
blacklist bcm43xx
blacklist bcma
blacklist brcm80211
blacklist brcmfmac
blacklist brcmsmac
blacklist ssb

I have the network icon in the tray. When I click it, there is no option to enable/disable wifi. The only thing shown in that window is the wired connection.

Other messing around? I’ve done a bunch of searching and while there’s actually a decent amount of similar/same issues, it seems to be older posts and the solution was to always just install the broadcom-wl driver and/or blacklist modules.

Okay? Question then? What is your hardware exactly? inxi -Faz | eos-sendlog
Post the url.

Edit: Are you dual booting with Windows also?

Check also

systemctl status wpa_supplicant

Edit: It shouldn’t be active.

Url is https://0x0.st/XNb0.txt

Yes, I’m dual booting (Windows and EOS are on separate drives).

Output of systemctl status wpa_supplicant:

pa_supplicant.service - WPA supplicant
     Loaded: loaded (/usr/lib/systemd/system/wpa_supplicant.service; disabled; preset: disabled)
     Active: inactive (dead)
1 Like

In Windows do you have the fast startup under Windows power management disabled?

@IsolatedRaking
I also noticed your UEFI Bios version is the very first. There are 18 newer versions since. You may want to look at each and update to the latest if it allows bypassing all of the others. Normally it’s okay unless it say’s otherwise as most newer Bios versions contain all the updates from previous versions.

Teaches me to make assumptions apparently. I did not have it disabled. I disabled it and rebooted into EOS, but still no wireless networks.

I’m not sure what to suggest now? :thinking: You could first try shutting down and unplug the tower for 2 minutes and then press the power button for 30 seconds. Then plug it back in and start up the computer. It should just automatically work. Broadcom is one of the better chips. Are you using systemd-boot? I’m just wondering if this is a dkms issue where it’s not building the kernel module properly? Sometimes things go awry. Maybe try uninstalling broadcom-wl-dkms version and reboot. Then reinstall the broadcom-wl-dkms again and reboot.

Right now this is the only suggestions i have because I’m not sure why it’s not working unless Windows put the hardware to sleep. Mostly this happens on motherboards that have the WiFi bult onto the board. :thinking: