Can't get my games to run correctly + Lutris

We use Arch btw! :laughing:

1 Like

top kek


Your config seams to work well ^^ my 2080TI didn’t seam to have much of an issue ^^

Also reading your guide I have created your .sh scrips (going to give it a go your best I can)
I think I understand how to do this so far :laughing:
But can I ignore the parts about steam since I don’t use it ? or can’t I use proton without it :S

…Can’t imagine the problems mmo games are going to cause me and GOG galaxy as you need it to play No mans sky online :face_with_monocle:

1 Like

Sure, not parts but specifically whole section 3. Steam

@keybreak a little confused about a part of your guide I am following.

I downloaded the Engines and I guess I should extract them so they are in a basic folder ?
The playonlinux files extracted to a uncompressed folder which I can’t extract again even though it is a tar.gz file.

Second problem I am having is I copied your edits for Crysis and you use 5.11-staging so I guess I should use 6.13.1-staging sine that is what I have installed ?
For the you say copy it to my setup directory which Im guessing means where the .exe is located… well I ran it from there but it didn’t do anything :confused:

You don’t have to guess, it’s all written with dir structure shown in there

All engines comes from internet in form of whatever compressed archive format they choose, you need to extract them for example like that here:


so that inside 5.0-proton dir you’d have that kind of structure:

├── bin
├── include
├── lib
└── share

Yes, you should use whatever Engine you want to use…I assume you mean

Should be pretty self-explanatory, there are options:


You change SETUP= to whatever your .exe name is, ENGINE= to whatever engine you want to use with it, set your NAME= to whatever prefix name you’ve chosen on previous step with, for example you’ve created:


Means you need to set:

1 Like

It will also be quite beneficial to look into these scripts that were kindly provided by @keybreak, and inspect the commands they run. While having it all encapsulated in a couple of scripts is awfully nice and convenient, it does not serve the goal of understanding what is actually going on.

Sorry should have explained it better ><

I put all the files in the correct location that part I got, what I meant was when I extract the tar.gz files do they all need to have the same structure for example :
~/.PlayOnLinux/wine/linux-amd64/lutris-ge-6.12 has the structure you listed.
~/.PlayOnLinux/wine/linux-amd64/tkg-staging however has a usr folder before you get to bin -include etc.

As for the other issue that was just my own fault for being tired, ENGINE meaning the engines I put in the amd64 folder. god I am dumb but error corrected and its working as it should.

@Kresimir I did give the a read but I know 0% about script so please correct if I am misunderstanding something
SETUP obviously use this .exe file to begin while NAME, ENGINE and ARCH are the variables for the script bellow it, so with my Crysis setup
WINE="${WINE_ROOT}/wine/linux-${ARCH}/${ENGINE}" changes to

The rest of it… I no idea sad but honest.

1 Like

Only what’s inside that usr directory is useful to you, the rest can be discarded. The directory structure must be exactly as @keybreak said. So just copy the contents of that usr directory.


Oh i see, yes they need to have similar structure, so in case of tkg you should rename usr dir to let’s say 6.12-staging-tkg and copy it there, so in the end it should look like that:

├── bin
├── include
├── lib
├── lib32
└── share

Rest of stuff from extracted tkg you just ignore, important part is engine itself with all those bin etc dirs, which is in usr for that case


Well my progress is slow but getting there, engines are in correct places, Crysis is installed, installed the extra stuff and I got Lutris configures as instructed.

Sadly the game is stuttering like it did before… I checked to make sure the stuff from tricks did install which they are.

Have you enabled dxvk in Lutris? :slight_smile:

Yes runner options show DXVK/VKD3D is enabled with DXVK Version V1.9.1L

Weird…it shouldn’t, here are my settings in Lutris:


Maybe try to enable Esync?

Yep same as mine and I enabled Esync
I don’t suppose it is because the wineprefix is in a different location to where the game is installed ?
In game option is have this
Executable /drives/Games/Crysis/Bin64/Crysis.exe
Arguments -dx10
Wine prefix ~/.PlayOnLinux/wineprefix/Crysis

Of course not :slight_smile:

Here are mine:

Huh well I searched the Crysis wineprefix again just to be sure the .dll and everything from the is indeed present which they are so it can’t be that.

only thing I can think of its that the engine I picked doesn’t like Crysis :confused:

Well it may be, sometimes there are regressions in Wine, so that’s why i’ve written in guide it’s a good idea to use portable engines and stay on whatever works good for given game :slight_smile:

Just for the reference try same as mine 5.19-staging from POL, see if it helps…

Downloaded and extracted PlayOnLinux-wine-5.19-staging-linux-amd64.tar.gz and put it into my ENGINES folder…but didn’t do anything. game did not even load, the play button just turned to stop for a few seconds before going back to play.

1 Like

oh wow :laughing:
There must be something else…i have no idea what, but that’s not normal.

I’ve just tried - it loads fine for me