Can't enter system after updates

problem is documented here -

Can you share the output of inxi -Fxxxz?

You can boot off a live iso if you need to. Also, is there any chance you have a Kepler Nvidia GPU?

inxi -Fxxxz
System:    Kernel: 5.15.2-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0 Console: tty 2 DM: LightDM 1.30.0
           Distro: EndeavourOS base: Arch Linux
Machine:   Type: Laptop System: Acer product: Nitro AN515-55 v: V1.10 serial: <filter>
           Mobo: CML model: Stonic_CMS v: V1.10 serial: <filter> UEFI: Insyde v: 1.10 date: 11/19/2020
Battery:   ID-1: BAT1 charge: 55.5 Wh (100.0%) condition: 55.5/57.5 Wh (96.6%) volts: 17.4 min: 15.4 model: LGC AP18E8M
           type: Li-ion serial: <filter> status: Full
CPU:       Info: Quad Core model: Intel Core i5-10300H bits: 64 type: MT MCP arch: Comet Lake rev: 2 cache: L2: 8 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 40009
           Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 2637 3: 1856 4: 1463 5: 912 6: 800 7: 800 8: 1085
Graphics:  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Acer Incorporated ALI driver: i915 v: kernel bus-ID: 00:02.0
           chip-ID: 8086:9bc4 class-ID: 0300
           Device-2: NVIDIA TU117M vendor: Acer Incorporated ALI driver: nvidia v: 495.44 bus-ID: 01:00.0 chip-ID: 10de:1f99
           class-ID: 0300
           Device-3: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 1-5:2 chip-ID: 0408:a061 class-ID: 0e02
           Display: server: driver: loaded: nvidia tty: 240x67
           Message: Advanced graphics data unavailable in console. Try -G --display
Audio:     Device-1: Intel Comet Lake PCH cAVS vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
           chip-ID: 8086:06c8 class-ID: 0403
           Device-2: NVIDIA vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10fa
           class-ID: 0403
           Sound Server-1: ALSA v: k5.15.2-arch1-1 running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: no
           Sound Server-4: PipeWire v: 0.3.40 running: no
Network:   Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:06f0
           class-ID: 0280
           IF: wlan0 state: up mac: <filter>
           Device-2: Realtek vendor: Acer Incorporated ALI driver: r8168 v: 8.049.02-NAPI port: 3000 bus-ID: 07:00.0
           chip-ID: 10ec:2600 class-ID: 0200
           IF: enp7s0 state: down mac: <filter>
Bluetooth: Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:3 chip-ID: 8087:0026 class-ID: e001
           Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
Drives:    Local Storage: total: 238.47 GiB used: 52.39 GiB (22.0%)
           ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN530 SDBPNPZ-256G-1014 size: 238.47 GiB speed: 31.6 Gb/s
           lanes: 4 type: SSD serial: <filter> rev: 21103900 temp: 33.9 C scheme: GPT
Partition: ID-1: / size: 233.17 GiB used: 52.39 GiB (22.5%) fs: ext4 dev: /dev/nvme0n1p2
           ID-2: /boot/efi size: 511 MiB used: 296 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1
Swap:      Alert: No swap data was found.
Sensors:   System Temperatures: cpu: 38.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 187 Uptime: 15m wakeups: 1 Memory: 7.6 GiB used: 560.6 MiB (7.2%) Init: systemd v: 249 Compilers:
           gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1043 Shell: Bash (login) v: 5.1.8 running-in: tty 2 inxi: 3.3.07

the gpu is a geforce gtx 1660

any solutions? I need the pc back up fast, there was quite a bit of customization that I won’t be able to redo in time

I am probably not the best person to help you with this one. Hybrid Nvidia laptops aren’t really my specialty. I can tell you two things:

  • This shouldn’t require reinstalling
  • There are others here with the experience to help you out

You may have to wait for one of them to see this topic and/or be awake. Much of Europe is probably asleep already.

1 Like

Well according to that reddit post the nvidia495 driver does not support your nvidia card and you should install 470 which is now legacy and can be found on the AUR.

  • First go an check on nvidia webpage which driver is supported for your card on linux (I don’t know your specific card, NVIDIA TU117M). If it is only the 470, there was a recent update on the arch repo to 495 which you seem to have upgraded to.

  • Secondly, I would chroot into live iso and backup your data if there is anything important before proceeding…

  • On top of our EOS forum page you can find the pinned post and instructions of what to do:

If you need to run 470xx, then you need to remove first nvidia495, you can do so via tty, then install nvidia470xx, then reboot.

To change to 470xx from AUR on new legacy cards you will need to uninstall the main ones and build/install the 470xx versions from AUR:

sudo pacman -R nvidia-dkms nvidia-utils nvidia-settings
yay -S nvidia-470xx-dkms nvidia-470xx-utils nvidia-470xx-settings

Edit: if you run optimus-manager since you have a hybrid card, you may want to remove it before playing with nvidia drivers, and install again, or skip altogether. I do not use optimus, the nvidia card switches on when I connect external screen, which is satisfying for my use…

The command with remove 495 drivers and installing 470 drivers then rebooting didn’t change the result.

what is the result? with no more information, it is difficult to help…

the result was as described previous (as described by the word “same”) with the os going through the boot menu, showing a few messages that are usually shown on startup, and then a forever white line in the upper left corner blinking, with my only ways out being power off or ctrl+alt+f2 into terminal.

Ok, I have two separate suggestions if you are willing to try.

  1. did you try booting into lts kernel? you could try booting either in lts or the recent kernel. If their are not installed, we can easily do that in tty.

  2. Remove first AUR nivida packages you just installed via yay -R packagename, and try something similar to my recent observation.

in your case, just use the pacman nvidia-installer-dkms -n to remove any nvidia drivrs and then try to see if you can at least boot into your system via nouveau driver. We can probably work from there, either I or another community member can help .

Is it GTX1660 Ti? I can see on the nvidia site that it should support driver 495. Check here:

https: //

If that is the case you can try the method I linked above. It worked for me, i.e. remove nvidia and install nouveau and then install the nvidia-dkms and nvidia-settings packages. I did not need to install anything else.

what do you mean by boot into kernel? I’ve already stated that I’ve used ctrl+alt+f2 to enter a terminal.

also - I ran sudo nvidia-installer-dkms -n and got the same result. I’m beginning to think the problem is unrelated to the gpu

It’s not a 1660 ti, it’s just a 1660. If it not being listed on the site means anything feel free to say so.

You could try to replace lighdm with for example sddm.

any other suggestions? I’m just about ready copy the essential files and reinstall

Due to the lack of successful solutions, it’s likely come to reinstalling.

Just be aware, if it is caused by an update, it could happen again after the reinstall.