Can't boot live USB iso nor other distros

Hello to all,
I have been struggling for some time to install a Linux distribution on my second NVME SSD but without success. The Endeavour live USB literally blocks as soon as it boots. However, I tried to switch to something else (Opensuse Tumbleweed), the installation goes all the way through but when it comes to booting on it when the grub is displayed I get exactly the same result.

Does anyone know what this is about?

I’m currently using an RX 7900xtx, is it possible that the problem come from there ?

Probably yes, maybe wait until kernel 6.1 is out and try again.

The latest firmware is required in order to boot on the 7900 series cards. There are some other issues with mesa that causes flickering and losing the cursor. One can get around that with some work and some knowledge & skills. I created a test ISO that works. But there are a number of things you would need to do after to overcome the flickering and cursor issues. It’s not just a matter of the 6.1 kernel. The card works on Windows. If you pm me i can provide you more information if you like.

Edit: Here is the post from another user that has it working