Can't boot into Linux after installing Windows

I use Linux (EndeavourOS specifically) and I have grub enabled, I installed Windows 10 on a different ssd drive, after installing, When I boot into my Linux drive it boots me into Windows and don’t show me the grub boot menu.

Windows overrode the bootloader. That is why it is easier to first install Windows and then Linux, if you want dual-boot.

Nothing tragic though. See if this helps:

1 Like

I reinstalled EndeavourOS (there is nothing much in it so i had no problem doing that) but the same problem happened, I did enabled grub

Maybe check BIOS or EFI if the boot order changed

Here’s a picture in case if i did something wrong
Adata is where EndeavourOS is installed

It’s on a separate SSD as you said, right? The easiest thing I’ve found is to physically remove the second SSD when you install. Since Windows overrode the Linux bootloader, you may have to reinstall that as well.
That’s the most foolproof way I’ve found to install a dual boot, dual drive set up. No issues and no conflicts because at time of install, there’s only ever 1 target drive available.


Which of the options in the Boot Options Priorities is the Linux and which one the Windows drive?

The #1 should be the one with GRUB on it.

Yes, The first option is the one with grub

So from what I can understand is:
1- remove the drive that has windows installed
2- install Endeavour
3- boot Endeavor and after that I insert windows’s drive
Is that what do you mean exactly?

Yeah. Don’t hot swap unless your hardware is specifically capable of it. But once you have EOS installed and booted, you shutdown and install the windows drive again. Then use the function keeps to select the boot drive. For my HPs it’s F9, for my Lenovo it’s F12.

I tried it and it worked :).
Thank you!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.