Canon printer (WiFi) and Firewalld


I have a problem connecting to my printer (Canon MB2750) and the firewalld daemon running.
When I disable the firewall, I can connect to the printer for printing and scanning.
After enabling the firewalld I cannot contect to the printer.

I enabled the following serviced: dhcp, dns, ipp, ipp-client, mdns, samba, sane, ssh.

Which services or ports do I need to open?


Never setup a Canon, but I remember from the wiki to use mdns you need to change your zone to home:

Thanks for the tips. I tried them but I still cannot use the printer when the firewalld service is running.
When I disable the firewalld daemon I can use the printer and scanner.

I’m still testing which port or service I need to enable for printing/scanner with an active firewall.

Did you go through the process and check for network printer. Is firewall blocking mdns? It’s all in the wiki.

I’ve enabled mdns, ipp, ipp-client, sane, etc. I modified /etc/nsswitch.conf. I use the home zone. I checked all points, I will ceck again, to be sure I haven’t overseen something.
Nothing changed. As soon as the firewall service is running, I cannot see the printer.
Wenn the service is disable, I can use the printer.

It sounds like you did this but just to clarify: did you enable mdns in the actual firewall? It should be set in a permanent configuration in the home zone.


Did you check that avahi is running?

systemctl status avahi-daemon

Did you also change the file?

Then, edit the file /etc/nsswitch.conf and change the hosts line to include mdns_minimal [NOTFOUND=return] before resolve and dns:

Yes I did

systemctl status avahi-daemon
● avahi-daemon.service - Avahi mDNS/DNS-SD Stack
Loaded: loaded (/usr/lib/systemd/system/avahi-daemon.service; enabled; preset: disabled)
Active: active (running) since Wed 2023-09-13 18:48:08 CEST; 21min ago
TriggeredBy: ● avahi-daemon.socket
Main PID: 608 (avahi-daemon)
Status: “avahi-daemon 0.8 starting up.”
Tasks: 2 (limit: 17737)
Memory: 1.4M
CPU: 325ms
CGroup: /system

Changes in file /etc/nsswitch.conf
hosts: mymachines mdns_minimal [NOTFOUND=return] resolve [!UNAVAIL=return] files myhostname dns
networks: files

Did you install drivers from the AUR?

Edit: Just want to know how you added the printer?

I did install the CNIJFILTER2 (AUR) that is recomanded for this printer.

Then how did you go about adding the printer? Through cups?


yes (no firewall service running)
The printer was recognized with CUPS setup

Was it ipp?

yes (it was also listed bei ippfind)

If it works with firewall disabled and you set everything as per the wiki i don’t understand why it’s not working?

There also is a couple of other packages that support that printer. Here is one of them.

Edit: This one above would be my first choice and the other one supposedly also supports it is this one.

Edit: The first one definitely has the MB2750 listed and I’m just going by what I have read.

Thanks for your support and ideas. This “problem” has to do with the firewall, something is blocking the printer. I didn’t get behind the magic yet :wink:

The next days I will test the other driver pakage. But I’m still not sure if it is the driver or a port/service I fortgot to open.

This other package is a full driver so maybe you need more than just CNIJFILTER2. :man_shrugging:

The CNIJFILTER2 driver is the one you’ll find on the CANON website (driver version 5.4)…
But I’ll keep on testing, I would prefer the firewall running.