Canon printer (WiFi) and Firewalld

Yes. I use usb to printer so i don’t run into this issue. :wink:

I installed the USB printer, too. To have a possibility to print and scan.
Nethertheless I’ll keep on trying

I am stuck by the same issue.
Situation:
Epson Driverless installed via KDE printer dialog. Everything runs fione as long as the firewalld is stopped. I have all the stuff done (nssswitch, avahi done, home zone in firewall, mdns allowed - so everything mentioned in discovery is done) and yet: To be able to print I have to disable firewalld. Well, I guess I will disable the firewall again…

Ignore my post above - don’t know why, but I was again in zome public, not in home. Everything looks fine for me, sorry.

@Marvin42
Have you also set in home in the firewall?

Yes, I did

“nssswitch” what does this mean?

I think the OP means editing /etc/nsswitch.conf
Also make use of local hostname resolution (mdns) you need to change firewalld from public to home (zone change).

I’m using WLAN (zone home) my ethernet connection (not used) is on zone public.
@milkytwix which services and ports did you allow?

I found some tipps here:
https://openprinting.github.io/cups/doc/firewalls.html
I setup the ports as mentioned here. I works

For the scanner add TCP/UDP 8612

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.