Canon IR-ADV 4225 Network Printer

I have installed cups and guten print as per wiki. Through Printing settings, I have added ir-adv4225. However, it is not printing because of secure printing. (printer account management). In debian distro i have downloaded 64 bit linux driver from https://asia.canon/en/support/imageRUNNER%20ADVANCE%204225/model.

After unpacking the tar.gz, I have got debian 64 bit package file (.deb) and installed the same. Later, i have enabled printer management accounting (secure function) by running cnjplp2 in terminal. Through I have activated department function( saved the departmental Id and password.). In EoS how to enable the same. Is it possible to install driver from https://asia.canon/en/support/0100924010/12.
Please help me Sir.

deb/rpm packages are not native to Arch based - and by inheritance EndeavourOS.

First of all install cups and some additional helpful packages

sudo pacman -Syu cups cups-pdf cups-pk-helper ghostscript gsfonts gutenprint system-config-printer

I don’t know it this is a MFC - if so add in the scanner packages needed e.g.

sudo pacman -Syu simple-scan

Enable and start the cups service

sudo systemctl enable --now org.cups.cupsd

Extract the tar - locate the ppd file for my printer model - and extract those files.

Create a folder to hold the ppd files

sudo mkdir -p /usr/share/ppd/Canon

And copy the extracted ppd files to above folder

sudo cp ~/unpacked-folder/*.ppd /usr/share/ppd/Canon

Then launch

system-config-printer

Unlock and add the printer - if you are in luck - this works just following the guide.

2 Likes
1 Like

While giving printing, printer is responding. I feel job accounting problem. cngplp2 also not responding in the terminal. localhost:631 shows my network connected to specific ip and installed ppd. However, no print output.

Here on the Arch site is some info about these IR printers.

Maybe look at this. It is for IR printer but doesn’t say your model.

I have almost installed everything. However, unable to print. How to remove foomatic driver from EoS. In order to set job accounting cngplp2 command getting following error
cngplp2
get printer failed.
[ramachandran@Ramesh ~]$

Sir, see i cannot go beyond certain level. That’s the problem.

Did you have a look at the wiki?

I have gone through the wiki. It seems that job accounting is culprit. in debain based distro, i used to set job accounting through cngplp2. However, not working in EoS. This is my office network printer cum photostat machine. I know your constraints in this regard.

I don’t know what job accounting is? I don’t have this hardware so it’s difficult. I wish i could help more. The foomatic has a lot of packages installed. Here is the command to check what is installed.

[ricklinux@eos-plasma ~]$ pacman -Qs foomatic
local/foomatic-db 3:20200822-1
    Foomatic - The collected knowledge about printers, drivers, and driver options in XML files, used by foomatic-db-engine to generate PPD files.
local/foomatic-db-engine 4:20200206-1
    Foomatic - Foomatic's database engine generates PPD files from the data in Foomatic's XML database. It also contains scripts to directly generate print queues and handle jobs.
local/foomatic-db-gutenprint-ppds 5.3.3-2
    simplified prebuilt ppd files
local/foomatic-db-nonfree 3:20200822-1
    Foomatic - database extension consisting of manufacturer-supplied PPD files released under non-free licenses
local/foomatic-db-nonfree-ppds 3:20200822-1
    Foomatic - non-free PPDs from printer manufacturers
local/foomatic-db-ppds 3:20200822-1
    Foomatic - PPDs from printer manufacturers
[ricklinux@eos-plasma ~]$ 

Have you tried to install the linux driver from canon? You have to extract it after you download it and then use the shell script to install it. Not sure if this works like i say i don’t have the hardware.

Not sure if this is correct?
bash install.sh

Job account is every department have one id and password. In windows, it will ask id and password while giving print. However, it is permanently saved in property of printer property through cngplp2.

This is where i got the driver.

This is driver is applicable to all UFR II/UFRII LT. https://asia.canon/en/support/imageRUNNER%20ADVANCE%204225/model . Only issue is now some minor issue like job accounting, filter etc. Upon my google some issue in Arch linux whiile configuring Canon network printer etc… In order to figure out only you people can do it.

I feel once again reinstall EOS and get your assistance through remote desktop access. Is it possible.

Are you able to access the printer through cups?

localhost:631

The user name is root and your password.

yes sir. While giving print, led also blinking in the printer. Printer is directly connected to static ip address.

So the printer works? You just can’t set up job accounting? I have been looking at it to try to understand it. This is on a Debian system but is similar how to set up job accounting. Maybe this helps?

I feel it is old method. Now with new driver provided by Canon. It is more simple. In my easyos (build from debian binary) , just installed 64 bit debisn package and set job accounting through cngplp2 command. Got printout. In EOS I have tried lot of options, still not able to print