Cannot use PipeWire Screen/Window capture in OBS after updating to Plasma 6

I still can use obs-vkcapture but it doesn’t work for general desktop use.
I have also noticed that taskbar thumbnails break after a bit of use, might be they use pipewire for showing thumbnails as well.
Any ideas about it, maybe someone has similar issues?

I have to add that it has worked before on Plasma 5 Wayland session.

1 Like

you are now on wayland instead of X11 session in case…

I am aware about that but it worked before on Plasma 5 Wayland session. I am sure that I was on Wayland because I have severe issues with xorg.

Start OBS in the terminal and look for error messages.

Here is the output:
I don’t see anything suspicious aside from VAAPI but I think those are normal.

Ok, you only said “it doesn’t work”. What doesn’t work? I assume you use screen or application capture (the log looks like it). Does a popup ask for a desktop to share when you use Screen Capture (PipeWire), do you have any preview at all?

When I try to select a window, there are previews without thumbnails. When anything is selected there is only black screen.

But you see your physical screens too, right? E.g. here’s mine at the bottom (in my case with a working thumbnail):

Maybe something is up with pipewire (that would also explain the missing thumbnails). What packages do you see at pacman -Qs pipewire?

Do you use flatpak/flathub? As a quick sanity check it is worthwhile to test their obs package if possible.

I have the same thumbnail on every device, if I try to select window then there is only app icon instead of a thumbnail.
I do not use flatpaks.

Pacman output:

That’s unfortunate. From the log it seems you use some 3rd party plugins and it would be nice to see if obs still fails in a vanilla configuration. This is also the official Arch “obs-studio” package, not one from the AUR?

That looks mainly OK, except that wireplumber should be at 0.5. Maybe update to be sure and give it another try.

I am using git build. Just tried official package with removed vkcapture but the issue remains.

There was also the websocket extension, which I believe isn’t a default on Linux(?). But whatever, it sounded it worked for you in the past, and I personally haven’t heard of or experienced any new problems. VA-API should work for you too, but I don’t think that should affect at least seeing a pipewire portal preview.

With that I would probably escalate it as a bug to kde or obs - maybe by extend Arch, pipewire or mesa. Obs is probably the best option (maybe informal in their discord or the github bugtracker). But afaik obs considers flatpak their only official™ release, and they could suggest testing that. :sweat:

Sounds tiresome but I will try checking flatpak later on, then.
Also Websocket is a stuff from git build that is not yet released into stable so it is not an extension.

Seems to not be the problem with OBS as for a bit after reboot the pipewire capture works fine but then OBS breaks with apps’ thumbnail previews and I don’t even see anything in logs.

After some more updates it seems OBS just crashes whatever is responsible for screen capture taking kde live thumbnails with it on start. Nothing out of ordinary in journalctl so I have no idea.