Cannot mount partitions to permanent mount point through fstab

Whenever I add my partition with their uuid to the fstab file and reboot it shows time out for all the partitions along with dependency failed after starting arch line.

2 Likes

Can you show us your fstab then, please?

Hi and welcome toendeavour-os and the forum.

The output of this command could be helpful as well:

sudo blkid -o list

Posted photos because cannot boot into DE without removing fstab lines.

First, don’t mount partitions into your home directory.
Mount them to e.g. /mnt and symlink them to your home.

3 Likes

Worked before on all the other distros that I tried. What creates the problem here?

I don’t know, do not have much experience with ntfs…

However it is bad practice to mount partitions to your user’s home.
For example, it could be that at early boot, your home isn’t mounted yet (or not decrypted yet, in case of encryption), and thus the partitions cannot be mounted to your home either.
(That’s just an assumption, mind.)

Is it possible to mount them manually? For example:

sudo mount -t ntfs-3g /dev/sda1 /home/igneel/Random

Or at /mnt/Random:

sudo mkdir /mnt/Random
sudo mount -t ntfs-3g /dev/sda1 /mnt/Random
1 Like

Yes manual mounting works. I can mount them via dolphin.

Then you are making typos.

Personally I use systemd mount units - with a complementary automount unit for network shares.

Think of a mount - and please don’t use /mnt or your home.

If it is a games partition - think /data/games

Now create a new file - and this is important - it must be named so it reference your chosen mount point - in my example /data/games so the file will be data-games.mount.

A shortcut to get the partition’s UUID into the file without fuzz is to use lsblk and then pipe the result into the file - then you don’t have to worry about the validity of the UUID.

Replace sdy1 with the actual partition from your system

lsblk -no UUID /dev/sdy1 > ~/data-games.mount

Now edit the file with your favorite editor - something like this

[Unit]
Description=Mount games partition

[Mount]
What=/dev/disk/by-uuid/your-uuid
Where=/data/games

[Install]
WantedBy=multi-user.target

Save the file and close the editor.

Now copy the file to etc

sudo cp ~/data-games.mount /etc/systemd/system

Now change owner on the file

sudo chown root:root /etc/systemd/system/data-games.mount

Enable and start the mount

sudo systemctl enable --now data-games.mount

List

ls /data/games
1 Like

Great write up!
I am curious about a couple of things.

I make /media for mounting other devices, but what is/are the reason/s for not using /mnt?
And would systemd mount function for NTFS partitions as well?

Great

Really just a personal preference - but the famous FHS mentions the usage of /mnt for temporary mounts.

I understand this as any arbitrary application should be able to rely on an existing empty folder for a temporary mount - and this would not be the case if /mnt is occupied.

It also prevents conflicts - permission issues - you don’t want to change permissions on /mnt.

And yes - you can mount anything using systemd.

I have created a couple of documents on the subject - one of which is a couple of examples.

Thanks so much for taking your time and explain! I appreciate it. I understand better now the implications of mounting a device at /mnt. What I actually had in mind was to creating other mountpoints in /mnt, like /mnt/Data or /mnt/Games etc. I should have been more clear before. :blush:

systemjournalctl - xb output

This command gives unknown column.
lsblk -no /dev/sdy1 > ~/data-games.mount

forgot UUID

lsblk -no UUID /dev/sdy1 > ~/data-games.mount

It sounds like NTFS module isn’t available at boot time (especially if you’re able to mount it manually post boot). Anyone know if it’s in the arch initramfs?

1 Like

Still says unknown column. I used the partitions uuid.

The command lsblk -no UUID /dev/sdy1 as written will output the UUID of the partition with the path /dev/sdy1.

For convenience I added a pipe so instead of writing to the console it writes to the named file.

lsblk -no UUID /dev/sdy1 > ~/data-games.mount

When you edit the mount - you don’t need the type - you can comment this as your partition is ntfs.

Probably relevant as well: https://wiki.archlinux.org/index.php/NTFS-3G#Configuring