Cannot get Xorg to start after past days updates

I noticed the SDDM greeter won’t appear after an update a few days ago. I get two lines of text that appear when booting, not related to X. I have a less than a week old backup if all fails. I admit I’m impatient and willing to take risks so I have the testing repos enabled, not sure if that is the cause of the issue. As for the backup, the problem will likely persist when I update again if it impacts stable channels. Said segmentation fault at address 0x337. Caught signal 11. Running Xorg -configure results in the same error as sudo startx. And luckily I can still access virtual terminals and dual boot with Windows, and on Windows I have a program that can read/write to Ext4 partitions (in addition to just using a live USB) so I’ve managed to extract Xorg.0.log as mentioned by the error when I try to start X.

On a related note, what is the most common paste site around here to use? I have a pastebin and use but I might be missing on one that’s better suited.

If you like, you could pipe the output of a command through eos-sendlog and post the resulted URL on the forum.

Example: inxi -Faxxxz | eos-sendlog

Also, you might want to have a look at:

The cause of the issue is mesa 22.3.0-1. This version does not run with Intel GPUs resp. their drivers. In contrast, with Nvidia GPUs (nouveau) there are no issues.

Install mesa-* 22.2.3-1 and add it to IgnorePkg in “/etc/pacman.conf” for now!

I did this on Friday via ssh.

1 Like

possible to use downgrade tool too:

sudo downgrade mesa
and choose 22.2.3-1 from the list to get downgraded too… it asks also to add it to ignore list.
Only do not forget to recheck if the issue get fixed to re-update to a latest working mesa package later :wink:

you running nvidia on optimus manager, also tried sudo mkinitcpio -P ?

With mesa 22.3.0-5 from staging (!) it is (also) OK again.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.