Cannot boot fresh install system

Hello, I was trying to test out EndeavourOS as a linux distro but cannot get past rebooting after install. Live USB works fine, including multiple monitors and my 2 nvidia GPUS, a gtx1080 and quadro P620.
Have tried all 3 kernel choices, using KDE plasma. It goes through reboot and at the point it does:

Reached target Graphical Interface.
Starting Hostname Service...
Started Hostname Service.

The screen blinks like it is starting the graphical interface, but instantly goes back to this screen, I can switch terminals and login, its how I got my logs, but the system will freeze pretty quickly, managed 1 log per reboot.

Here are some logs:
Install Log
hardware info

This is stumping me because I’m not sure where to start if anyone has any ideas.


One of the issues right off the bat is there are 8 newer UEFI Bios updates. You should look at updating to the latest version. Your current version is 1302 dated 09/02/2019

They were all mostly incremental updates, with main update for windows 11 support, updated anyway to 2004 and made no difference. System still stops at same point.

This only happens on EndeavourOS, I have been able to install and boot into manjaro, ubuntu and pop os in the meantime.

Update: definitely has to do with the nvidia drivers, I can do nouveau drivers and get to the desktop, but if I try to use nvidia drivers I can’t. Tried using nvidia-inst once booted using nouveau drivers and it resulted in me not being able to boot the same.

I assume this thread might shed some light…

I wasn’t saying it was going to fix your Nvidia issue but the UEFI Bios updates are important. They have new Intel Microcode and Improved system stability and memory function etc. It’s good you updated it anyway and now you’ll have to figure out what the issue is with the Nvidia.

Did you try running the installer in test mode? It would be interesting to see what it shows.

nvidia-inst -t

You could post the output here to be looked at.


here is the output of nvidia-inst --prime --32 -t

Also I tried some things from that other guide, set the modules to early load and didn’t make a difference, will try the nvidia-hook from that thread and see if it makes a difference.

[scott@scott-pc ~]$ nvidia-inst --prime --32 -t
2022-05-30 12:50:55: Info: Running: nvidia-inst v1.2-1
2022-05-30 12:50:55: Info: Command line: nvidia-inst --prime --32 -t
2022-05-30 12:50:55: Info: Selected mode: prime
2022-05-30 12:50:57: Info: Patching kernel line with nvidia-drm.modeset=1
2022-05-30 12:50:57: Info: Installing packages: nvidia-prime nvidia-dkms nvidia-utils nvidia-settings lib32-nvidia-utils
    pacman -Syuq --noconfirm --noprogressbar --needed nvidia-prime nvidia-dkms nvidia-utils nvidia-settings lib32-nvidia-utils
    grub-mkconfig -o /boot/grub/grub.cfg

Edit: It didn’t show any errors in test? Have you tried it?

This installer is a beta also. Did you try the other installer before? It also has a test mode. You need to have the package installed first.

nvidia-installer-dkms -t
1 Like

I am about to test it, I only used nvidia-inst manually, I assume nvidia-installer-dkms is used by the OS installation?

In the meantime, pastebin of output from running nvidia-inst before I reboot:

nvidia-installer-dkms -t:

[scott@scott-pc ~]$ nvidia-installer-dkms -t
2022-05-30 13:02:08 [INFO]: EndeavourOS Nvidia Installer v3.4
2022-05-30 13:02:08 [INFO]: All logs will be stored in /tmp/nvidia-installer.log
2022-05-30 13:02:08 [INFO]: Running the installer in testing mode...
2022-05-30 13:02:08 [INFO]: Updating Nvidia graphics cards database...
2022-05-30 13:02:08 [INFO]: nvidia-installer-update-db --tmpdb

Warning from nvidia-installer-update-db:
    The site has database of card ids for the new driver (510.73.05).
    Thus the database will reflect the new driver.
    The driver from pacman has a different version (515.43.04).
    It is recommended to run nvidia-installer-update-db again after having
    the pacman version updated to the version.
2022-05-30 13:02:14 [INFO]: Chose nvidia-dkms out of possible nvidia-dkms and nvidia-dkms.
2022-05-30 13:02:14 [INFO]: Installing nvidia-dkms driver...
2022-05-30 13:02:14 [INFO]: Removing conflicting packages...
2022-05-30 13:02:14 [INFO]: Downloading and installing driver packages, please wait as this may take a few minutes...
2022-05-30 13:02:14 [INFO]: pacman -Sqy --noconfirm --noprogressbar nvidia-dkms libvdpau nvidia-settings lib32-nvidia-utils lib32-libvdpau
2022-05-30 13:02:14 [INFO]: Unpatching /usr/share/applications/nvidia-settings.desktop...
2022-05-30 13:02:14 [INFO]: /usr/bin/sed -i s|Exec=optirun -b none /usr/bin/nvidia-settings -c :8|Exec=/usr/bin/nvidia-settings| /usr/share/applications/nvidia-settings.desktop
2022-05-30 13:02:14 [INFO]: Patching kernel line with nvidia-drm.modeset=1
2022-05-30 13:02:14 [INFO]: nvidia-installer-kernel-para
2022-05-30 13:02:14 [INFO]: Installation finished. Nothing has been modified as testing mode was ON.

Maybe run this first? :thinking:

 It is recommended to run nvidia-installer-update-db again after having
    the pacman version updated to the version.

If it were me i would try the dkms installer after running the update data base first and then also run a pacman update. Then run the nvidia-installer-dkms

You have two different Nvidia graphics cards. What is your goal? To be able to run on either one and be able to switch between them? Or you are just trying to get it to load to a desktop and work? I’m only asking as you showed prime in the other post?

nvidia-inst did not work, swapped back to nouveau, then ran nvidia-installer-dkms, with database update, no luck.

I have 5 monitors, 1 main off the GTX 1080 and 4 off the P620, in other distros an nvidia PRIME setup is only way I have gotten all output, otherwise I get nothing off the P620.

I have tried normal and --prime at this point with no luck. One difference I am seeing is that both installers use the 515 beta driver, other distros have all been the 510 driver.

I am fine troubleshooting getting all monitors to work, after I can at least boot using nvidia drivers if that is an issue, but I cannot even get to that point.

So you are unable to get it to work if you start from scratch with only one Monitor hooked up to the 1080 card and work your way up?

Edit: The Quadro P620 shows the 510.xx drivers as supported.

Correct, I haven’t tested with taking the p620 out of the system, but that would defeat the purpose.

Is there a way to force usage of latest 510 driver not 515 driver for testing?

Edit: 515 drivers show support for both cards, but I know 510 drivers work on other distros

I guess @manuel would be the one to ask that question. I’m not an expert on it.

Did you run this command to see what it comes back with?

[scott@scott-pc ~]$ nvidia-installer-check

Multiple Nvidia card ids detected!

Graphics card (id: 1b80):
  - Is supported by the nvidia-dkms driver.
  - To install a driver for this card, you can use e.g. nvidia-installer-dkms.

Graphics card (id: 1cb6):
  - Is supported by the nvidia-dkms driver.
  - To install a driver for this card, you can use e.g. nvidia-installer-dkms.

So when you actually run the install it is installing the 515.xx drivers?

Yes, I verfied using nvidia-smi. Also remember on boot up with nvidia drivers I have maybe 5 minutes before system does a full freeze and I forced to reset to check things. Currently sitting on the desktop with nouveau drivers.