Can’t install EndeavourOS (SOLVED)

Hi, I’m unable to install EndeavorOS, when I get to the installer, it says it can’t create a new partition table on /dev/mint-vg

I’ve tried the erase disk option and the replace partition option (which deleted my linux mint partition oof), yet I still get the same error. I dunno what to do at this point

I’ve actually had this issue before when I tried (and failed) to install Manjaro on my laptop.

What’s even stranger is that I have another drive with the same amount of storage on it (ST2000LM007-1R8174) (/dev/sda), but it only gives me the option to manually partition.

hi @Jordan welcome to the EnOS Forum :purple_heart: :enos_flag: :enos:

try to delete it manually from the live system in the terminal.


Hi @Jordan and welcome to the good ship :enos: Let’s see if we can help you plant the :enos_flag: as your go-to distro.

If you can get to the terminal


to check the partitions you want to wipe before doing anything

sudo wipefs -a /dev/sdX

You could achieve the same result using gparted, but the above is a single line and it works every time no matter how stubborn the old partition or system is.


Hi, thank you for the tip, but unfortunately I’ve run into a roadblock… when I tried it on dev/sda2 (the partition i need to install on) i come across this error:
probing initialization failed: device or resource busy

How do I fix this?

Did you follow the post by @pycrk ?
Tell me, is this partition you are trying to delete a LVM (Logical volume) or regular partition?

You should be able to unmount it.

1 Like

Hi, after some trial and error removing the LVM off my sda2 drive, I managed to install EndeavorOS. Thanks for your assistance (from both you and @pycrk).

I’m relieved to get everything up and running okay!


Welcome @Jordan :wave: Happy that you got :enos: working :smiley:

it would be nice if you described how you solved the problem and marked it as a solution. that would be very helpful for others with the same problem.


Good to know. Now all you need is to do mark the post that solved your issue :white_check_mark: , so that others can search the solution. That will also close the thread in a few days.

Enjoy :enos: It’s really the only distro I would use after many years of distro hopping. You will find this a really helpful and information packed forum :smiley:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.