Can not reboot at all, nothing works. Please, help

I already asked a similar question before Can not open the terminal from anywhere, can't reboot

But now even the solution with tty provided there doesn’t work. I opened tty, logged in, then tried the command ‘sudo reboot’. This worked before, but not this time!!!

The problem started with the network manager or network adapter. One of them hangs my PC. There is looping animation on the control panel. It won’t connect to network, and also it won’t allow me to reboot from the panel (GDBus error:org.xfce.SessionManager.Error.Failed: Session manager must be in idle state when requesting shutdown)
I can’t open the normal terminal from anywhere, tried 3 different methods to open the normal terminal, nothing works. As was said, the trick with tty doesn’t work either.
When I click on the looping animation PC hangs for 10-15 minutes, then PC unfreezes and the animation begins again.
Is there any way to kill this process that causes the trouble?

I tried also the command Alt+SysRq+e, but couldn’t find SysRq key. The article said to try PrintScreen instead of SysRq, but this has zero effect. It doesn’t work.

I’m totally out of any ideas… Please, help!!!

Edit: I left PC hoping it will go to sleep, but it won’t. However, after around one hour it started to run some processes. It said something like “OOM killer enabled”. But this doesn’t lead to anything.

What happens when you try it?

You have to enable this in advance. If it is isn’t enabled, it won’t work.

1 Like

I consider myself a noob when it comes to Linux but it looks like something is clearly wrong with your system and you have 2 options.

  1. solving the problem
  2. start from scratch

If you choose option 1 then provide good information. for option 2, the easy way out, all you have to do is copy all important information from your home folder and reinstall.

1 Like

[user@user ~]$ sudo reboot
After this the cursor moves to the next line which is totally empty. Nothing happens at all, I have waited for an hour. There appeared 3 lines "audit: type=113… terminal=? res=success’ "

Is there any way to kill network manager? I think this will solve the problem.

9 times out of 10 the problem is situated between the monitor and the chair, I’m talking out of experience here.

Please tell me one thing… is the only option now is to shut down the PC using power button. Then start the PC and enable SysRq, so that when this problem happens again I can use Ctrl+ALt+SysRq+E ?

To eneble sysrq just add kernel.sysrq = 1 to /etc/sysctl.d/99-sysctl.conf

This is not a viable long term solution though, if I were you I would start with a clean slate.


But the problem is not in the system per se. The problem is in the buggy wifi adapter/network manager. Even if I start from clean state and reinstall the system, the problem will not be resolved.

It might be better if you create a new post with the particular problem you have with buggy WiFi adapter. Make sure you provide your full hardware output.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.