Calamares freezes on grub installation

I am using a ACER Aspire ES 15 notebook (ES1-533-P5SY). The notebook has a difficult UEFI implementation. It causes every distribution I tried to crash at the installation of the bootloader.

Then I finally got Ubuntu working using this solution:
https://askubuntu.com/questions/862946/unable-to-install-ubuntu-on-acer-aspire-es1-533
First install Ubuntu without grub and then rename and move the bootloader files in the right directory.

I was thinking of doing it the same way for EOS. But how can I tell calamares not to install grub?
Any other ideas?

Many thanks in advance!

Almost all Acer computers. That’s a well-known fact. Why do you want to install in UEFI mode? Choose CSM, partition with MBR and install normally with Grub!

is secureboot disabled ? in my acer laptop you can select the grub file what it calls, and set to that loads the grub, or simply disable secureboot ?

@breakdown

Maybe this is a solution for you, but its partly in english and german.

Wow, you guys are really quick with your answers. Thanks for your support.

@axt
My bios doesn’t let me choose CSM. There is no other option.

@ringo
Yes, secureboot is already disabled when I do the installation. I saw there is this option to select the grub file in the bios on some Acer models. This options appears when you set a su password. My model doesn’t have this, unfortunately.

@antec1
Yes, I followed this solution when installing Ubuntu and it works for me. The only problem is that I cannot tell the Endeavour installer (calamares) NOT to install grub.

Could you give the Bios version of your Acer ?

BIOS Version: V1.12

ok , thats pity its fail, my laptop is es1-5 but platera numbers behind i dont know because the laptop is downstairs but is a old model in the first place :slight_smile: i instaled it with secureboot… had selected the grubx64 what it calls, but disabled after it… on this point dont know… you could look at the bios version as @FLVAL said.

which videocard does it have ?

No real video card just intel HD Graphics on the N4200 CPU.

as this link related to nvram it seems:

Latest BIOS for ACER Aspire ES 15 notebook ES1-533 is

Date: 2019/04/01
Version: 1.19

https://www.acer.com/ac/en/US/content/support-product/6889?b=1

It could make a difference. The one you are using is from Date: 2017/11/22

Right (sometimes CSM is made possible later). Flashing the last available UEFI ist the first. It’s a basis. I have to stress that again and again.

On Windows rufus ist the best, no, the only thing to take seriously image writing tool. breakdown, use that, choose UEFI/GPT! Not pretty, but at least it will be.

Yes updating the BIOS is a good idea. They only thing is that right now I am running Ubuntu and the Acer BIOS update only works on Windows, which means I need to install Windows first only to install the new BIOS update.

I will look around a bit more for other solutions before I do that. Thanks guys.

You don’t have to reinstall Windows, there is a way to flash throw usb key.
You need Rufus to format your Usb key and make it bootable, your new bios file .bin, a soft to flash throw dos.
You boot on the USB key then the soft start, you just have to select your .bin file and it will flash your bios.

I flash directly motherboard with electronic tool in case you have problem. But if you prefer to be secure make it throw Windows.

I updated to the latest BIOS 1.19. CSM or Legacy mode is still not available. I guess that’s it. I have to live with Ubuntu. :frowning:

You have nowhere access to a Windows computer as a makeshift (w/o malware, of course)?

Again: Use rufus, choose in rufus UEFI/GPT!

Btw., this would also be possible in a Win10 VM, if a USB filter is set for the USB stick. I.e., you wouldn’t have to delete a native system just for that.

This does not need a network, i.e. no Internet, and thus does not receive any threat from it. rufus and the image you copy via a shared folder.

Thanks for the tip. I made a bootable EOS stick with rufus and selected GPT.
Unfortunately I cannot boot this stick “Default boot device missing or boot failed. Insert recovery media and hit any key. Then select boot manager to choose a new boot device or to boot recovery media.”

You say you can’t install grub on the Acer and endeavour doesn’t allow not to install grub. Is it possible to install endeavour and direct the install of grub to an external usb drive instead?