Calamares fails - maybe pacman issue?

Hi to all,
today I wanted to install new Endeavour installation in my machine where I have many different Linux systems in parallel:
1 partition home
1 partition swap
…and many partitions ~70GB where different Linux systems are installed. So I choosed a new partition for my task and started installation via Calamares. Partition is recognized, it is filled with some data (structure looks like a normal linux installation) - but afer some time installation fails. I have pasted the calamares-log here:
Any ideas what cn be the problem?

You could try updating the mirrorlist before starting the install.
Use reflector-simple e.g. from Welcome.

I have the exact same issue, I have tried multiple times with updated mirrors.
Same error
This is online installer KDE and Base system selected.

Yes - nearly same task- GUI is KDE, i additionally selected printig, hp print and accessibility. Log with new mirrors is here: - still failing.

From @df8oe’s log:

WARNING: unable to fetch netinstall package lists.
2022-01-14 - 09:17:52 [6]: … Netinstall reply error: QNetworkReply::ContentNotFoundError
2022-01-14 - 09:17:52 [6]: … Request for url: “” failed with: “Error transferring - server replied: Not Found”

Looks like a trouble with Gitlab’s page. Going to

gets me to a 404-page-not-found page.

1 Like

I see that error in my log aswell, and the error window says:

The package manager could not make changes to the installed system. The command <pre>pacman</pre> returned error code 1.

Or it is a path issue in installer. I cannot find the yaml on Gitlab at all.

1 Like

The path exists here.

It seems to be a path error in calamares. This is the corrected URL:

@manuel: crossed postings…

1 Like

So is there anyway we can update this path somewhere ourselves?

Looks like the path is not correct in calamares.

You could try changing the path in file
in livesession before install.

EDIT: please report if that helps (or not). :sweat_smile:


Yes! It did install now when I corrected the path.

1 Like

What ISO version are you using?

cat /usr/lib/endeavouros-release

I am unsure what the file was, since I just reinstalled my computer. But I grabbed the latest ISO I found on the website 2 days ago (Wed 12. Jan).

And which DE/WM did you select?

Base system + KDE is the only options I picked.

1 Like

I’m now trying the same here.
Interesting that Xfce did install successfully without any change.

EDIT: KDE installed OK. Log:

It is EndeavourOS_Atlantis_neo-21_5.iso / eos-2021.12.17

Fo checking you simply can take a look at /etc/calamares/modules/netinstall.conf if the wrong path is set.

That seems not to be the only bug. Installation now finishes without problems - but when I start the system I am ending in a console login. I can login now. When I try startx I get a graphical screen with two consoles and the possibility to move the “x” of xserver - but no KDE…