C: Drive doesnt get recognized properly by Endeavour OS installer

Ive been trying to dualboot eos on my asus windows laptop.

Its been a struggle and i after going through most of the troubleshooting steps ive run into a wall. Right now i have an empty unallocated Partition of 50gb. My safe boot and fast boot are all off, the drive is not bitlocker encrypted and my bios has been set to ahci. All those steps brought me abit further but now my Drive gets recognized as a 0b. It gets seen by lsblk -f and lsblk -l correctly but the installer cant seem to see it.

these are my full boot logs : https://0x0.st/HR1b.txt
and these are the 2 disk commands: https://0x0.st/HRQl.txt

Any help would be appreciated.

welcome @Bees here :enos:
let`s hope the smart community can help more than me at the telegram chat…

the interesting part on the boot journal:

Feb 27 21:56:37 _hostname_ kernel: nvme nvme0: controller is down; will reset: CSTS=0xffffffff, PCI_STATUS=0xffff
Feb 27 21:56:37 _hostname_ kernel: nvme nvme0: Does your device have a faulty power saving mode enabled?
Feb 27 21:56:37 _hostname_ kernel: nvme nvme0: Try "nvme_core.default_ps_max_latency_us=0 pcie_aspm=off" and report a bug
Feb 27 21:56:37 _hostname_ udisksd[860]: Error probing device: NVMe Identify Controller command error: Interrupted system call (g-bd-nvme-error-quark, 1)
Feb 27 21:56:37 _hostname_ kernel: nvme 0000:04:00.0: Unable to change power state from D3cold to D0, device inaccessible
Feb 27 21:56:37 _hostname_ kernel: nvme nvme0: Disabling device after reset failure: -19
Feb 27 21:56:37 _hostname_ udisksd[860]: Error probing device: NVMe Identify Namespace command error: Input/output error (g-bd-nvme-error-quark, 1)
Feb 27 21:56:37 _hostname_ udisksd[860]: Error performing housekeeping for drive /org/freedesktop/UDisks2/drives/HFM512GDJTNG_8310A_NJ94N244311204M0E: Error updating Health Information: No probed controller info available (udisks-error-quark, 0)

Intel® Rapid-Storage-Technik (Intel® RST) ?

Check the settings in the bios and make sure SATA is set to AHCI not RAID or if it has Intel RST that it is turned off and set to AHCI. You could also try using the following kernel parameters. Not sure if you are using grub or systemd-boot. The kernel parameters are added differently on each.

1 Like

Ive checked the bios and it is set to AHCI. Ive also tried both those booting parameters sadly. Thank you very much for the reply would you have any other ideas?

Secure boot and fast boot is off. What about CSM? Is it also turned off?

Edit: I see there are no Bios updates. You have the latest.

Both boots are off and CSM was not an option i believe in the bios, i can upload the pictures though only 5 at a time

What does it show under nvme configuration?

Edit: Also can i see under sata configuration? Both are under advanced.

Was the SATA drive always on AHCI?

no i changed it, before when it wasnt on AHCI the installer would say there is no available partition to install too. Then after the change he does find a partition though the entire drive appears as 0b and cant be read properly.

It’s probably related to how the fake raid is setup on the this drive why it doesn’t see it. Are you able to see it with gparted booted on the live ISO. If you have the latest ISO it will have KDE partition manager. You can install gparted and launch it and see what it shows.

both gparted and the partition manager are not able to see it properly

What does it show? Nothing?

it shows the drive as a 0b i will post pictures one sec

Okay it doesn’t recognize any partition table.

Edit: I don’t know what else i can suggest. Does the laptop have another nvme slot that you could add another drive?

i dont think so its super tight since its a zenbook duo. Im really devastated i cant get it to work i have been at it for 2 nights now : (
Thank you for the help, i was really excited for linux but i guess it might not be possible to get away from windows

Okay one final question? When you changed the SATA to AHCI did you then boot back into Windows?

yes after messing with the bios i believe i always restarted back into windows first.