Buggy brightness on dedicated graphics

I have a rather interesting bug with my legion 5 laptop. It appears that it also happens on other distros like Ubuntu, Fedora, Pop_os, Nobara and even EndeavourOS.

I also found a thread that has the same issue as mine:

The problem that I have is if the brightness level is at 5-10%, it is considered as 100% for whatever reason.
The brightness driver that controls the…backlight of the laptop is nvidia_0.
I don’t have this problem on hybrid graphics however.

I have tried many grub options, including acpi_osi=Linux, acpi_backlight=vendor/none/native/video, video.use_native_backlight=1 and even turning off amdgpu.backlight.

Is there a way to fix this?
I am currently using Nobara. I don’t think I can bother with another distro reinstall at the moment :turkey: :frowning_face:

Intel? No problems here Legion 5 AMD/RTX3070.

Using amd ryzen 5 5600h and rtx 3050 ti

If no other backlight program helps, you could try xrandr (if you use X).
The command should be something like

xrandr --output "your-output-device" --brightness "preferred-brightness-value"

You just need to find the output device (with xrandr) and read the manual page
man xrandr
for more information.

1 Like

I feel like the problem that I have is a nvidia problem. On hybrid I have 0 issues

From the Arch Wiki:

NVIDIA settings

Users of NVIDIA’s proprietary drivers can change display brightness via the nvidia-settings utility under “X Server Color Correction.” However, note that this has absolutely nothing to do with backlight (intensity), it merely adjusts the color output. (Reducing brightness this way is a power-inefficient last resort when all other options fail; increasing brightness spoils your color output completely, in a way similar to overexposed photos.)

I’m guessing your aim is not to increase the screen’s brightness, but rather to dim it at times…


I have nvidia and I don’t have this problem. I’m running Lenovo Legion 5.

Are you on dedicated mode or hybrid?

Again, when the slider is at 5-10, the brightness is considered to be at 100%. This does not occur on hybrid graphics as that is handled by the amdgpu I think

Sorry if I missed your point. Not on any Nvidia meself. :wink:

I’m using Nvidia card too (a bit older but 530 series driver) and xrandr is the only way that I’ve found to successfully adjust monitor brightness.

But you can normally change your brightness using your hardware buttons/brightness slider and work as expected?

Well, my keyboard does not have such brightness control keys, lol.
So I made a script that can change brightness. I don’t have to use it often, as it was needed mostly because initially the brightness was much too high for my sore eyes.

…do you use a legion 5? :turkey:

No, it is an old (> 10 years) desktop machine that I built using standard components. And later I bought the Nvidia 1030 card that still works with the latest Nvidia driver. Just hoping the Nvidia driver keeps supporting it for a few more years, since the machine itself is working very well.


Is your display named DP-4? Do you use the 120hz screen?

DP-4 yes an no 120 its actually 60.06hz. set by default.

I run a dual monitor setup so HDMI and DP-4 are the video ports in use. Screen brightness on Laptop is controlled by Laptop Keyboard fn+f5/f6 key combination the HDMI is controlled by the TV that is connected to it.

As of April 23rd Nvidia driver Version 530.41.03
NVML Version: 12.530.41.03

This is odd.
I can’t even change my refresh rate by any means too (unless I go wayland but even that doesn’t change anything).

This is certainly an nvidia issue, as if I use nouveau…changing brightness can be possible with no issues.

Again no its not. I say this because if it was then more people would have the same issue. This is not the case. I have nvidia and no issue with screen brightness at all. If the problem is an nvidia issue then I to would have the same issue. I don’t which tells me that the driver is fine however there may be a conflict between the driver and some other hardware/software in your setup.