[Bug?] The entire terminal is one color and color changes don't work

I did a fresh install today , updated and proceeded to remove XFCE and install Gnome. The installation is flawless so far with the exception of one thing. The terminal uses only 1 colors for everything - users, bold text etc. I thought this was a gnome terminal bug but I installed Deepin Terminal and it had the same issue. No matter what theme or coloring I use, wether I enable > use colors from system theme it still stays the same. The only difference is that in Deepin terminal if I change the theme at least the color changes ( still only 1 color for everything) but it doesn’t represent the theme accurately. Screenshots:

Gnome Terminal:

Deepin Terminal:

It’s not the end of the world but still kinda annoying. I googled the issue but I see results from like 2010 and 2012 so I hope someone can help here.

i think endeavouros using Bashrc. you can costumize it :slight_smile:

https://www.tecmint.com/customize-bash-colors-terminal-prompt-linux/

also possible to use https://wiki.archlinux.org/index.php/Zsh#Installation zsh :slight_smile:

also www.dotshare.it is also a lot themes to see and follow.

https://wiki.archlinux.org/index.php/Fish

i gues, endeavour os, configured kinda sober. with zsh example you can use themes, … in linux world is always between two giants, bashrc and zshrc

fish is a add on have also a nice options i gues also themes…

is about how thinks is configured in .bashrc , for zsh users in .zshrc

zsh ist what I could be by default, but you can change to whatever you want

Both bash and zsh give me the same problem. I change the color schemes from the terminal setting and nothing happens. This is bizzare. Always used to work from the graphical settings without having to edit files.

echo $SHELL

image
I’m using bash. Here’s the list that comes up when I list them.

chsh -s /bin/zsh
To change to zsh then

Yes I did it rebooted the system and the bug remains even with zsh . Only the background color and the main color can be changed. Anything else from the pallet doesn’t work.

I would move related configs out of the way, to see if this is related, can check this later, on the road way home at the moment…

Sorry to bother you during your travels. It’s nothing urgent it’s just slightly annoying and so far it’s actually the only bug I have so that’s a good thing. + It most likely has something to do with installing gnome / removing XFCE. Something might have gotten corrupt in the process god knows.

Do you first install gnome and then remove xfce?
//I do not need to drive by my self so I can safely write here :wink:

I did yes. That might have been an issue. Another thing I’m noticing is when I go to a directory let’s say I type cd ~/Downloads it doesn’t show me that I’m there.
image
I am indeed there when I type ls I can see my files but it just doesn’t show it . This might be a deeper bug than originally thought. Also something to note is I’m not 100% sure but I believe when I first booted into gnome it showed me what directory I was in at least… weird

If you are still on zsh but moved configs, you need to reconfigure🤗

And there is a BUG with fonts, upstream, so may related here too… I can look later, if I can reproduce and solve this

Meanwhile I decided to do a clean install while I haven’t settled in yet and remove Xfce BEFORE adding gnome to avoid future headaches. Will keep you posted if bug persists.

Are the servers down or something. I can’t download gnome.


It finds mirrors eventually but searches for minutes for every single package

https://www.archlinux.org/mirrorlist/
May not synced Always good to rank your mirrorlist for Archmirrors

1 Like

Strange earlier today I had 0 errors. Will rank for my country after install though for sure. Thanks again

Update after brand new install with gnome and nothing else on it - bug persists
edit: Was talking about terminal bug

My mirrors were completely “unsynced” somehow yesteday. Somehow. So I made a quick alias called “mirrors” for Reflector, so I can just run “mirrors && yay -Syyu” when updating my system.