Budgie Broken Login Screen

I’ve got a pretty fresh install of EndeavourOS with Budgie as my desktop and I’ve run into an issue logging in. I closed my laptop to log out which normally works fine but now when I open it back up it doesn’t have a password input box. It’s just the wallpaper and a top bar. My mouse is also not working, but strangely it sometimes I can see it flicker very briefly into visibility when I hit keys or use the touchpad. Ctrl+Alt+F1 doesn’t let me type anything or prompt me for a login (only displays “rfkill: input handler enabled”). Ctrl+Alt+F2-6 or F 8-9 give a blank screen with a cursor flashing and I can’t type anything. I have noticed that Budgie uses a different login when first booting than for logging back in, if that’s relevant. I don’t have magic sysreq enabled yet.

I’ve had this issue a few times before and always just powered off the computer, but I corrupted my last system by powering off at the wrong time, so is there anything else I can do? Also, is this a bug in Budgie or EndeavourOS and if so who should I report it to?

Edit: grammar

First thing is to enable Magic Sysreq!

The login screen and the lock screen differ on most setups, so probably not relevant.

Logs will probably lead you to the problem.

1 Like

How can I enable it from where I’m at? Should I power off the computer to be able to login?

Fortunately, someone (:frog:) wrote a really nice guide on that:

If your computer is frozen and you can’t do anything, and you have not enabled the magic SysRq key, you’ll have to hard reset it, there’s no way around that, unfortunately. Keep your fingers crossed.

If you can’t get to a desktop, either boot to a TTY or chroot from an ISO image so that you can enable the magic SysRq key.

4 Likes

I was able to login and enable it on restart. But, it looks like the hard reset broke something; pacman stopped working. Is there any way to keep my system from totally collapsing whenever I hit the power button or is that just a “feature” of linux?

I never had this feature on my Linux :rofl: you must have installed a weird package to enables this.

Joke aside, as said above it’s better to not hard reset. I guess I should also start not doing that too…

I’m starting to wonder if my SSD might be part of the problem, do you know any way to check for hardware faults?

If you’ve enabled the SysReq option, that’s the way - use that to shut the system down gracefully instead of using the power button.

1 Like

I actually just found this on the arch wiki but have no experience with it.

https://wiki.archlinux.org/title/S.M.A.R.T.

1 Like

I’m glad my post about enabling the magic SysRq key helped you, but is it really the solution to the OP? I don’t think it is. If so, please remove the solution mark, as it is just confusing to anyone else having this issue.

1 Like

Using smartctl is covered nicely in the Arch wiki page that @Zircon34 posted above. Try the short test first, then check the results after the specified amount of time has passed; if it says “Completed without errors,” you’re probably OK, but you might still want to run the long test just to be 100% sure.

If you prefer a GUI, install gsmartcontrol then open it. Select your drive:

Then go to the “Self-Tests” tab and execute the short test:

The results will show up in the “Self-Test Log” box immediately upon completion.

3 Likes

Oh right, sorry

Thanks, that seems like a great solution. Unfortunately pacman is broken on my system right now so I’ll have to try it in a live environment or new install tomorrow.

1 Like

How is pacman “broken” on your system? What error do you get?

I already reinstalled, but I think it was something like

repeated many times: [file] is already present
installation failed

And then it quit and didn’t apply any updates or installs, so I guessed some file pacman was using to keep track of what was installed got damaged. I figured it would be too much trouble to try and fix.

This is not windoze… There is no need to reinstall the operating system every time a tiny thing like that breaks, which can be fixed in 5 seconds. :man_facepalming:

Oh well, it does not hurt to reinstall, but it is a waste of time and a missed opportunity to learn something by fixing it… :man_shrugging:

2 Likes

You’re definitely right, but I thought there might be more damage and that a reinstall would make sure the system is stable.

Unfortunately, I’m really starting to think I’ve got bigger issues (probably SSD?) because the installer just failed for the third time in a row. Here’s the install log: termbin.com/d9nd I unfortunately forgot to copy down the logs for the first two, but I know one failed during formatting the drive and the other failed while pacman was installing packages. I think they both also returned error code 1.

Following advice in my other post for what I thought was an unrelated issue I’ve tried gsmartcontrol and smartctl. Gsmartcontrol can’t figure out anything about the drive and smartctl wouldn’t run any tests. I uploaded a photo of what smartctl -a returns.

Any idea what’s the problem with the installer? Is my SSD dying? Have I screwed up the system in some other way?

2022-01-04 - 23:09:21 [6]:     ..  Job description from pretty_name "bootloader" = "Install bootloader." 
2022-01-04 - 23:09:21 [6]: [PYTHON JOB]: "Bootloader: grub (efi)" 
2022-01-04 - 23:09:21 [6]:     ..  Running ("grub-install", "--target=x86_64-efi", "--efi-directory=/boot/efi", "--bootloader-id=endeavouros-2661", "--force") 
2022-01-04 - 23:09:21 [6]:     ..  Target cmd: ("grub-install", "--target=x86_64-efi", "--efi-directory=/boot/efi", "--bootloader-id=endeavouros-2661", "--force") Exit code: 1 output:
 Installing for x86_64-efi platform.
grub-install: error: cannot find a device for /boot/grub (is /dev mounted?).

installer was not able to find ESP partition, reason unknown, but can be faulty drive, or something you have setup wrongly or something you done while installing.

32,000 Media and Data Integrity Errors is a frighteningly large number. I am not sure if filesystem corruption would show in that field, though - in other words, if your filesystem was corrupted after doing a hard reset, that may be the cause of that number; I’m not sure. But the problems that you’re having with installations, combined with that number of integrity errors, certainly suggests that it may be a problem with the drive itself.

Did you notice this section of the wiki?

The -i/--info option prints a variety of information about a device, including whether SMART is available and enabled:

sudo smartctl --info /dev/sda | grep 'SMART support is:'

SMART support is: Available - device has SMART capability. SMART support is: Enabled

If SMART is available but not enabled, you can enable it:

sudo smartctl --smart=on /dev/<device>

With gsmartctl, there should be a tickbox to “Enable SMART” right below the “View detailed information” option.

As I don’t have NVMe drives, I had forgotten that, unfortunately, smartctl (smartmontools) does not fully support NVMe, or at least not all nvme controllers, and doesn’t display all the info that it does with SATA SSDs. It might be able to read information from the individual partitions (/dev/nvme0n1, /dedvnvme0n2), but not from the device itself (nvme0). You might want to install the nvme-cli package. Sorry, but I don’t have any hands-on experience with NVMe drives and SMART monitoring.

Refer to the Installation, Management, and SMART sections in the wiki page below:

https://wiki.archlinux.org/title/Solid_state_drive/NVMe#Installation

1 Like

I did notice that and tried that command, but there was no output. The output of sudo smartctl -i is:

=== START OF INFORMATION SECTION ===
Model Number:                       ADATA SWORDFISH
Serial Number:                      2L042LQ7H1EP
Firmware Version:                   VC0S0285
PCI Vendor/Subsystem ID:            0x10ec
IEEE OUI Identifier:                0x00e04c
Controller ID:                      1
NVMe Version:                       1.3
Number of Namespaces:               1
Namespace 1 Size/Capacity:          500,107,862,016 [500 GB]
Namespace 1 Formatted LBA Size:     512
Namespace 1 IEEE EUI-64:            564330 5330323835
Local Time is:                      Wed Jan  5 23:37:58 2022 UTC

There is no option to enable SMART in my gsmartctl, it really can’t seem to figure out anything about the drive. I tried the nvme-cli package but didn’t find anything new. I also tried running gsmartctl as sudo and it gave some interesting errors which are here: https://pastebin.com/2F1Zr3s3

image

At this point I think it’s an SSD problem, is there any way to verify that to help with a warranty claim?

1 Like