[BUDGIE] Apps freeze when on maximize after update

hi, has anyone experienced apps hanging or becoming unresponsive when windows are maximized? browsers are ok, but gtk apps seem to not work.

2 Likes

hi,

i have the same bug.

I just realized this yesterday. Not with budgie but with gnome 43.

For example the terminator window as well as the evolution email client when maximized do not respond to keyboard entry when coming back from screen lock. I have to minimize/maximize the windows to make it work again.

EDIT:
gnome-terminal also shows this behavior. Interesting is that when I minmize/maximize the app window it is not only working again but it now shows the keys I have pressed while the app was not responding. Looks like the keys are recorded but not actioned. Example: While the gnome-terminal is not responding I blindly type “ls -a”. Nothing happens. Then I minimize / maximize the window and I see that “ls -a” was executed and I see the output.

I don’t seem to be able to reproduce this issue on my end on GNOME43.

Here are the steps I do to reproduce it on my side 100 % of the time:

  1. I am running gnome 43 with X11
  2. I have several windows open (e.g. evolution, firefox, etc.). but i believe that doesnt matter
  3. I open gnome-terminal and maximize that window and keep it in the foreground
  4. i type a few character to make sure that gnome-terminal is responsive
  5. I lock the screen with the keyboard shortcut Meta-L
  6. I unlock the screen
  7. I type something into the gnome-terminal window but it doesn’t show any character I am typing
  8. I minimize/maximize the gnome-terminal and now I see the characters I typed

Thanks for providing the steps.
I followed them all but still no such issue on my end.
Could it be because, I am using GNOME43 on Wayland?

Step 1 was to use X11 so…

:thinking:

Yes, I realize that.
So the issue is not related to GNOME per se but perhaps to Xorg?

It isn’t that straight-forward. It could be an issue with gnome/mutter/etc that only impacts X11

Yes, that’s a reasonable assumption.
On my end, at least, it doesn’t occur on a Wayland session.
I am going to replicate the issue on the Xorg and report back.

I will try to reproduce it with Wayland later today. I can not log out at the moment because my PC is busy.

1 Like

I followed all the steps given by @mbod to replicate the issue in a GNOME-Xorg session.
It just doesn’t happen on my end.
I seem to be encountering this issue neither on Wayland nor on Xorg in Arch-GNOME43.

2 Likes

There are no such problems with me. (Budgie DE)

1 Like

I cannot reproduce it with wayland. I used /etc/gdm/custom.conf to enable/disable wayland and always did a fresh reboot. With wayland the issue does not occur, with X11 it occurs every time.

is there a mutter config i need to tweak? note that i do not have adwaita theme despite installing it

It could well be driver- or hardware-related. Just saying.

It could be virtually anything…

Like a frog on the wall you mean? :frog:

here is a screenshot of an app maximized, not sure if this is a window manager issue

image