Brother_HL-L2395DW_series Printer Not Printing

Hello Endeavor community! This is my first post. Thank you for having me. Love this OS and I plan on staying here while I develop my own Arch. Enough about me for now. I’ve been troubleshooting my printer for a couple hours now and I’m just not getting there. I have fixed the issues that I found and selected the most correct settings I could find but I’m still not getting anywhere.

My printer is wireless. This is what I have tried so far. I’ve installed cups and started the service. I loaded a light GUI for adding my printer. I installed the driver for my printer that I was able to locate in the AUR using paru. I was able to discover and set the Device URI to the appropriate dnssd. Still nothing so far. It sees the printer and lists the printer but doesn’t print. Help troubleshooting would be greatly appreciated.

I got the same problem with my HL-2270DW but was able to work around it. What was the error? Is the print job showing up on print queue?

I did find a command that gave me quite a bit of detail on the issue. But I have since forgotten what the command was or where I found it. Currently in the GUI I’m seeing:

Printer ‘Brother_HL-L2395DW_series’ may not be connected.

I do know that when I saw a detailed output of a printer error it said something about not being able to locate PID

If you need the output of any commands just let me know.

In a Firefox tab, in the URL line, enter


Click on the Administration TAB
Click on “Add Printer” icon
May have to login as root
At this window


choose "Internet Printing Protocaol (ipp)
In the next window, enter the STATIC IP address of the Brother Printer as


At the choose driver window, choose “IPP Everywhere”

Then see if the printer works for you. A static IP address at the Brother printer is essential. Use the LCD screen on the printer to find or set a static IP address for the printer.


I assume

indicates your printer is on an ethernet LAN ?

Where are my manners, Welcome to the EndeavourOS forum. I hope you enjoy your time here.


1 Like

If the above doesn’t work, try stopping firewalld and see if that helps.

sudo systemctl stop firewalld

If so, you will need to open port 1900-UDP on your EnOS computer.

Open up the firewall app by right clicking on the firewall icon, then ‘Edit firewall settings’
First thing is to set the rules to ‘Permanent’. It usually ‘Runtime’ by default.

Then select the ‘upnp-client’ under the Services Tab.

Next, click on ‘Options’ in the top panel, and click ‘Reload Firewalld’

Reboot the computer and check.


1 Like

Walked away from this problem for a bit. Sometimes you just have to breathe. Just a matter of patience and dialing in the system. Thank you for these instructions. I will give them a solid try. Ethernet LAN yes.

1 Like