Broken system after update to Plasma 6

Hi there!

I think that I have messed up my EnOs install very badly…
After a month without updates I finally updated EnOs on my laptop (I know I should update more frequently, but last month was quite hectic, and I always used my main computer - with EnOs -).

Yesterday I updated both Arch and EnOs mirrors and then I proceeded to update the system using yay. It took quite a while because it had to compile electron25. The first update attempt didn’t finish properly due to a strage error while installing electron25: exit status 1. However the second attempt with yay was successful! Following the update, a reboot was (obviously) recomended and so I did. But that’s when things started to go downhill…

After staring at a black screen with an intermittent cursor for about 10 minutes, I rebooted with Magic SysReq.
The system eventually loaded fine (albeit a bit slower than usual). However, upon logging into the Plasma 6 session, I encountered some “scary” issues: the application bar disappeared and pressing the Super key had no effect, and I can’t open System Settings.
The terminal (luckily) is working.
After some online research, I found out that using an LTS kernel might resolve the issue. So, I attempted to boot using the LTS kernel but encountered an initrd failure. So I used the fallback version. After logging in, I tried to recreate the initrd with reinstall-kernels, only to be met with the following error:

dracut: *** Creating image file '/efi/09e89808cce14379ad930bafc504514e/6.6.23-1-lts/initrd' ***

cp: error writing '/efi/09e89808cce14379ad930bafc504514e/6.6.23-1-lts/initrd': No space left on device

dracut: Creation of /efi/09e89808cce14379ad930bafc504514e/6.6.23-1-lts/initrd failed

/etc/kernel/install.d/50-dracut.install failed with exit status 1.

Obviously I have a lot of free space on my device (about 400GB)… Searching online I stumbled upon this forum thread. I tried sudo umount /tmp but unluckily I got this response: umount: /tmp: target is busy.

This is quite unsettling for me as I’ve never encountered such issues before. Has anyone else experienced this problem?

Lastly here are some infos about my system:

  • OS: EndeavourOS Linux x86_64
  • Kernel: 6.6.23-1-lts
  • DE: Plasma 6.0.2
  • WM: kwin
  • Window System Protocol: Wayland
  • CPU: AMD Ryzen 9 3950X (32) @ 3.500GHz
  • GPU: NVIDIA Geforce RTX 2070 Mobile / Max-Q Refresh
  • Memory: 4430Mib / 31988Mib

Side note: my tower PC runs EnOs with Kde Plasma 6 smoothly!

is about the ESP that’s a dedicated partition, and by default 1GB in size (if you are using systemd-boot)
You can check also from TTY Ctrl+alt+F4 if GUI is buggy

log in there and use duf there you have nice overview:
under /efi you can see if ESP is full or not.

1 Like

Hi, thank you for your kind reply!

This is my duf output.

I apologize for asking what might seem like a basic question, but I’m new to this. What steps should I take next?

EDIT: I’m using systemd-boot.

Snaps… okay if you want that you can use… but not 100% recommended on archlinux/based

You can see /efi is almost full… in case it is to much to install LTS kernel there, as you only have 512MB with systemd-boot kernels will be installed there.
So go remove LTS kernel it will not be able to build initramfs images to this small ESP.
sudo pacman -R linux-lts linux-lts-headers
and try rebuilding initramfs after this: sudo reinstall-kernels

And if system is okay again (basically) go read this:

switch to X11 session (if you were using X11 before)
resolve possible missing packages:
eos-packagelist --install "KDE-Desktop"
reboot and check how it goes.

1 Like

Hi! Thank you once again for your response.

I have a question from a beginner’s perspective: when you say “snap,” are you referring to snap packages? If so, I’d be quite surprised because I don’t use snap packages at all. There might be one or two packages on my system from snap, but only because they weren’t available in the Arch repositories or AUR. Could you please help me clarify this?

I will proceed to remove the LTS kernels and switch back to X11!

On another note (another beginner question), will I ever be able to have both LTS and Arch kernels? On my tower PC, I have three kernels (Arch, LTS, and an old LTS for a specific program) and I haven’t encountered any space issues.

Thank you once again, and I apologize for these basic inquiries.

your picture shows paths for /var/lib/snapd in it
that would suggest that you installed snap to use those one or two packages you didn’t find in the aur. So as @joekamprad stated snaps are not really recommended on arch and arch based systems like EndeavourOS.

1 Like

Yeah, you’re correct. Thanks for the clarification! I installed snap, but only a few packages from it. Do you suggest I remove snap? Could it be causing these issues?

Moving on, I managed to uninstall nvidia-lts, linux-lts, and linux-headers-lts. Then I successfully rebuilt initramfs. I made changes to /etc/sddm.conf, but unfortunately, after rebooting, I’m still in a Wayland session… Am I overlooking something?

Lastly, I installed another 24 packages using eos-packagelist --install KDE-Desktop.

at the sddm login screen you can choose your session. X11 should be an option.

1 Like

Thank you, this solved the Wayland problem!

With X11, everything is back to almost normal :smiley:. However, I still can’t install both the LTS kernel and Nvidia-LTS. When I install both linux-lts and linux-headers-lts (from AKM / yay) and then execute sudo reinstall-kernels, everything works fine. But when I try to install nvidia-lts, I get this error:

Apart from this “small” problem, I have encountered some new issues with Plasma 6:

  • tuxedo-control-center starts but doesn’t work.
  • The touchpad isn’t found but partially works (no gestures, no sensitivity adjustment, no tap click, …)
  • Clevo keyboard drivers don’t work anymore.

Should I open a new thread for these problems or can I ask for some advice here?

Once again, thanks to everyone for the support. You really saved me; I thought I had messed up very badly.

hopefully someone who is familiar with nvidia-lts can chime in. I’ve only need to do nvidia-dkms but I don’t use the lts kernel either on my laptop which is what i have nvidia on.

1 Like

it saves last used setting for the session… if you are using autologin you need to logout and set X11 as used session.
and in case you have the dropin too under /etc/sddm.conf.d/kde_settings.conf

I do not know why you have a 512MBESP only… may you where formatting manually, as default on EndeavourOS is 1GB could be also you changed from grub to systemd-boot manually later on?

To be able to install more kernels you need to sizeup the ESP.

1 Like

Hi @joekamprad ! Thanks again for your kind help!
Honestly, I’m not sure why my ESP is only 512MB. Maybe it’s due to Windoze since I installed EnOs as dual boot with Windows 11 (yeah, once upon a time I used Windows daily, please, no judging :smile: ).

Is there any guide I can follow to safely resize the ESP partition?

From what I know, it is a bit complicated… As the ESP is in FAT32 format and before the main system partition. From what I remember at the very moment the only way is to resize the system partition and recreate the esp fat32 partition… that’s a bit tricky of a situation to do indeed.

1 Like

Unfortunately, you just confirmed what I was thinking…
I know that there are some software options that allow for these tricky resizings, but honestly, I don’t know if it’s even worth trying… I think using only one kernel would be the best decision for the moment.

As I was following this guide on how to run EndeavourOS stress-free, I was considering switching from the Arch kernel to LTS (even though I’ve never had any kernel-related issues with Arch kernels). As a newbie who doesn’t need any cutting-edge features, do you recommend sticking with the Arch kernel or switching?

Thanks again!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.