Broadcom-wl doesn't start on boot(live usb)

Hi I have a MacBook Pro, mid-2012 A1278, with a BCM4331, so I need the broadcom proprietary driver. Unfortunately it’s not loaded for me on the live usb and I can’t seem to find a way to enable it via modprobe… could someone help? Thanks!

Welcome @nautica !!
With an Ethernet (RJ45) cable connection, I think it could connect without problems.

of course, but the changelog in the iso says the iso includes the broadcom-wl-dkms driver. Is there any way to enable it?

I know that using the Broadcom BCM43 series chip on my Intel (ex-Windows) laptop, I won’t connect unless I’m running the broadcom-wl-dkms driver with the b43-firmware.

I’ll be honest; I don’t know if that can be used on the Live CD.

Alright, thanks. Any tips for setting it up after install? Been a while since I ran Linux on this thing :stuck_out_tongue:


Well that’s embarassing. None of us have a broadcom hardware to test further, so we thought broadcom-wl-dkms was enough. No idea would require both dkms + firmware.
We have b43-firmware in a testing repo, if you have another machine you can download and transfer through USB drive

After copying to your system install with
sudo pacman -U b43-firmware-

and reboot

If this fixes your connection problem we’ll add to official repo.

I don’t have the OS installed, would this still be possible? I want to use the wifi for the install

I have broadcom using dkms but i always have used ethernet to install first? That’s all i have installed.

The installer is offline, and i doubt installing the firmaware in the iso would allow internet connection without a reboot, which in this case erase your changes to the iso (iso is read only)


I have broadcom using dkms but i always have used ethernet to install first? That’s all i have installed.

Could you test if you have wifi working running the iso?

It requires linux-headers only i think. I don’t think i have the firmware installed.

Gotcha. Installation just finished so I’m gonna reboot into the OS and move the firmware over to the Mac

1 Like

Okay… I will try it.

1 Like

I have a Dell with Broadcom 43142 and there is no way to install an OS with Wi-Fi, unless what @fernandomaroto says works, I have never tried it. For that reason I answered him like this before.

1 Like

So this is worth testing (dkms + firmware). Let’s see tomorrow if we can solve this for good.

1 Like

@fernandomaroto Didn’t work. Broadcom-wl-dkms is installed, but not installed, as in, there’s no kernel headers so it can’t install the driver. The kernel headers need to be included with the ISO for the driver to work.

The system does not take it, and not to mention when installing the Arch scripts, until pacman is implanted in the system or yay, it is impossible.

You are correct on that. I have the broadcom 4360 wireless AC on a desktop using dkms driver.

So i tested the live iso and no wifi you need the linux headers.

Yup. And you need a way to load it on boot without the user having to do it via the terminal. I believe a modprobe config file would be able to take care of that.

Broadcom-wl never worked on my ultrabox, but with broadcom-wl-dkms