Broadcom NIC not bringing up second port

I recently installed endeavour and now have a problem that I did not have in the live environment. My broadcom card is not bringing up both NIC ports. The second port gives me the following message in dmesg when I boot my system and says that the port is not connected.

[ 5.736702] bnx2x: [bnx2x_compare_fw_ver:2379(enp6s0f1)]bnx2x with FW 120d07 was already loaded which mismatches my 150d07 FW. Aborting

Any ideas on how to resolve this issue?

Thanks,

Mitchell

Are you able to post the link for this command.

inxi -Faz | eos-sendlog

Yes, here you go!

https://clbin.com/ZCrI3

Modules are loaded. I see 3 ethernet?

 Device-2: Qualcomm Atheros Killer E2500 Gigabit Ethernet vendor: Gigabyte
    driver: alx v: kernel port: 2000 bus-ID: 05:00.0 chip-ID: 1969:e0b1
    class-ID: 0200
  IF: enp5s0 state: down mac: <filter>
  Device-3: Broadcom NetXtreme II BCM57711 10-Gigabit PCIe driver: bnx2x
    v: kernel port: N/A bus-ID: 06:00.0 chip-ID: 14e4:164f class-ID: 0200
  IF: enp6s0f0 state: up speed: 10000 Mbps duplex: full mac: <filter>
  Device-4: Broadcom NetXtreme II BCM57711 10-Gigabit PCIe driver: bnx2x
    v: kernel port: N/A bus-ID: 06:00.1 chip-ID: 14e4:164f class-ID: 0200
  IF: enp6s0f1 state: down mac: <filter>

Welcome to the forum @mns6070 :partying_face: :enos: :enos_flag:

Correct. It sees enp6s0f1, but due to that firmware issue it looks like it won’t bring the port up. It worked fine in the live iso environment though. Has there been a module or firmware change recently that would have caused this? I tried two different linux firmware bundles and neither one worked.

Thank you! Great to be here.

Did you install the linux-firmware-bnx2x package?

@mns6070
As @skaffen said have you installed the linux-firmware-bnx2x

Edit:

sudo pacman -S linux-firmware-bnx2x

Yes, I tried both the linux-firmware-bnx2x package and the linux-firmware-bnx2x-git package. Both packages are giving me the same result with the error in dmesg. Before I installed linux-firmware-bnx2x package, the card would not work at all, which makes sense. After I added either firmware package for the bnx2x, I only get the one port to work and the other port says it is unplugged even though there is a cable plugged into it and it worked fine in the live ISO. I can try swapping the cables to see if the issue follows my cables, but I highly doubt that would be the issue.

Worst case I can get by with one cable, but I would like my card to work like it used to work.

I am debating if I should try a different OS so I can see if there is something on the card firmware that is broken.

Thanks.

The live ISO would have a different kernel? I’m not sure if the firmware is same either?

There is a new firmware version in testing?

https://archlinux.org/packages/core/any/linux-firmware-bnx2x/

Edit: You can download it from the mirror and try it.

This is the link to the one in testing correct?

https://archlinux.org/packages/testing/any/linux-firmware-bnx2x/

Thank you.

Yes it shows download from mirror on the right or however you get it and you could try it?

Yes, tried it. The issue still remains. Same message in dmesg too.

Well i wonder if it’s a kernel issue or firmware? Have you tried it with any other kernels? lts or even zen? It’s easy to install another kernel using akm. It is a kernel manager. You can install it either with commands or from the welcome app. It allows you to install and remove a kernel easily.

I swapped my twinax cables between the ports and the issue is not following the cable. It is staying with the second port on the card. Dmesg is showing that a firmware mismatch is disabling it. I just don’t know from where.

Let see if I can try a different kernel from akm and see if that solves the issue.

Right now I am on 5.16.8.arch1-1. Switching to 5.16.8.zen1-1.

Same issue in Zen. Going to the lts release 5.15.22-1.