Brightness will not change

So Endevour wont let me change my brightness on my screen, not even the system settings or my keys (F5 and F6) will work, I am running a thinkpad e15 laptop with a Ryzen 5 5500u on radeon graphics Kernel: 6.1.4-arch1-1
Plasma 5.26.5

Have a look at this thread and see if the solution will work for you as well:

I’ve tried this solution and it doesn’t seem to be working for me, setting it to one of the 4 options does nothing

1 Like

I am not a Lenovo employee, but… have you read the manual yet? :joy:
Try using those buttons while holding Shift.
There is a BIOS option to invert this behavior.
IIRC some DE’s extension can change those on-the-fly (GNOME? :thinking: )
Also AUR packages for thinkpads do such things.

Did you update your grub.cfg with "update-grub" or "grub-mkconfig -o /boot/grub/grub.cfg" after changing kernel boot parameters?

I’m pretty sure it’s FN not Shift (at least it was FN on every laptop I had a chance to work on).

1 Like

it keeps saying command not found

Did you install with systemd-boot or grub?

Edit: If the install is with grub you can add a kernel parameter to the default grub command line in



I would recommend acpi_backlight=vendor or acpi_backlight=native but you can try them all and see. Try them separately and update grub and reboot.

Try each one of these separately and see which one works. You have to add it and then update grub with

sudo grub-mkconfig -o /boot/grub/grub.cfg

Then reboot

Edit2: If your install is systemd-boot then the parameter is added here


Then run

sudo reinstall-kernels



OK I am an idiot, I did a fresh install with grub, and did everything you guys said using native settings, and it works now, thank you!