How do i fix the Brightness on an amd laptop

Zenbook laptop with 6800h and i have no DE (i’ve been trying to setup Hyprland tho).
My problem is the brightness buttons do not work. sound works if i hold down fn.

I see something about needing to change something in grub? Brightness will not change - #5 by Stefax2001

but i have no clue how to do that as my knowledge is really basic.

i have /etc/default/grub open in vim and im afraid to mess with the grub file so hope somebody can explain what i need to do?

my laptop has the integrated Radeon 680M. so i shouldnt need to fiddle with any nvidia stuff.

is "grub_cmdline_linux_default=‘nowatchdog nvme_load=YES loglevel=3’ where i add it?

and would this work:

"grub_cmdline_linux_default=‘nowatchdog nvme_load=YES loglevel=3 acpi_backlight=vendor’

this an oled laptop if that matters

You have no DE as in you are just using a TTY? Or do you mean you are using a tiling window manager?

If it’s the latter, just install a brightness control frontend like brightnessctl and map your tiling window manager’s keybindings to the appropriate commands.

If you are concerned that the physical buttons on your keyboard aren’t working, you can check with xev for Xorg and wev for Wayland. E.g; when you xev and start pressing keys, the program will print out a bunch of data on the command line about the keys you just pressed.

In any case, you’re going to have to provide more information on your current setup.

just using a TTY and then starting Hyprland from that.

I believe im on wayland, but have no clue how to use wev

what information do you need?

Try this first. Install brightnessctl

sudo pacman -Syu brightnessctl

Then, inside your Hyprland session, run the following commands

brightnessctl set 50%
brightnessctl set 10%

Does the screen brightness change? If they do, then all you have to do is just add keybindings to execute brightnessctl commands everytime your brightness keys are pressed.

im running into unknown trust when running the -Syu

i tried sudo pacman -Sy endeavouros-keyring and its still giving me sever unknown trust

Update arch linux’s keyring first. brightnessctl is in the arch repo, not endeavouros repo.

sudo pacman -S archlinux-keyring

so did that then Syu. did a reboot.

my hyprland looks different now.

did the brightnessctl and it gives me this

updated device 'amdgpu_b10':
Device 'amdgpu_b10' of class 'backlight':
current brightness: 50 (20%)
max brightness: 255

updated device ‘amdgpu_b10’:
Device ‘amdgpu_b10’ of class ‘backlight’:
current brightness: 100 (39%)
max brightness: 255

does that mean 127.5 is actually 50%?

and i had brightnessctl keybinding before (guess just didnt have the program installed). but now after updating the keyring and syu i think all my custom keybinds are gone?


If you run

brightnessctl set 50%

It will set your current brightness to 50%.

I think an update is unlikely to cause you to lose all your config. User configurations for Hyprland are located in ~/.config/hypr/hyprland.conf

Were you prompted to auto-generate config or something? I can’t imagine the user config file being overwritten during the installation process.

Can you check the contents of ~/.config/hypr/hyprland.conf and see if your custom configurations are still there?

my config is there for all my stuff, hyprland just looks different

i prob copied the line wrong or somethings
bind = ,232, exec, brightnessctl s 1%-
bind = ,233, exec, brightnessctl s +1%

and waybar is broken now. it didnt auto launch so i ran it and it gives me

waybar: error while loading shared libraries: cannot open shared object file: No such file or directory

when i try to reinstall it says waybar and waybar-hyprland are in conflict. running -S waybar-hyprland says target not found

so waybar is working now i let it get rid of the conflict

waybar-hyprland is not in the official repo. It’s in the AUR. If you want to use it, you will have to uninstall waybar first.

You seem to have waybar installed already. Check

pacman -Qs waybar

Which is why I don’t understand how this happened. That shared object file should be present on your system if you’d installed waybar properly with pacman. The shared object file is provided by the fmt package, which is listed as a dependency of waybar.

to be honest i dont remember half of what i’ve done, hadnt touched this system in over a month.

its working now by updating waybar.

trying to figure out how to get everything set up so i can daily drive it

got rofi, need to figure out how to install powermenu
waybar needs some themeing
im on an old hyprland so need to update that

think wallpaper, music player, and notification are what i need next (was looking at Deadd Notification Center last month but got confused by the instructions lol)

There’s already a bunch of boilerplate code written for this.

Deadd certainly looks nice if you’re into that (since you’re using hyprland, I’m assuming you are very into the aesthetics of your desktop environment). I used to use dunst, but I don’t even bother nowadays to tell you the truth. My workflow has become so terminal centric that I don’t even use a notification daemon anymore. Everything I need to know is already displayed on my status bar.

yeah i got the basic power menu installed, but trying to customize. basically i went tty only so i could have the most customizations i could since kde and gnome have so many things attached to them.

do you know any code to help figure out how something is installed?
i installed deadd-notication-center like a month ago and i thought i had removed it then but running deadd-notication-center prints out /usr/bin/deadd-notication-center: line 1: Not: command found
so i guess its still installed? i might have done it via github clone, i dont remember.

i found a config file for it, and wanted to see if that worked otherwise i’d go dunst as deadd was a headache last month.


pacman -Qm

If deadd-notification-center is among the list, then you have installed it from the AUR.

A git clone will not randomly drop binaries into your /usr/bin directory.

Are you sure you didn’t make a typo? I’m pretty sure it’s spelled ‘notification’ not ‘notication’.

sorry i typo’d on here but wrote it right in terminial.

on my laptop pacman -Qm returns deadd-notification-center-bin 2.1.1-1

That means you installed it from the AUR.

That output seems strange. It seems to me like some dependencies are missing. The “Not” seems rather suggestive. Do you have libnotify installed on your system?

Also, can you check whether the executable is a shell-script? What does

file /usr/bin/deadd-notification-center


If it’s a shell-script, post its contents:

cat /usr/bin/deadd-notification-center

i actually uninstalled it and installed deadd-notification-center instead (versus deadd-notification-center-bin) before i read your comment (took awhile to get all the dependencies) instead which seems to work but i ran the two code you told me anyways

file /usr/bin/deadd-notification-center : /usr/bin/deadd-notification-center: ELF 64bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/, for GNU/Linux 4.4.0 BuildID[sha1]=708acc8e0af7a43964c43b995604801d1644987, stripped

cat printed multiple pages. and im not sure if libnotify is installed. notify-send works, so would that mean it is?

i was not getting that error last month and the version i installed now is 2.1.1-0 so maybe DNC-bin version aka 2.1.1-1 is broken?

Those two are the same package. The -bin version is just a precompiled binary version.

The installation of deadd-notification-center took longer not because of dependencies, but because everything has to be compiled from source (you probably saw a bunch of texts being printed on the terminal during the installation).

What about

ls -l /usr/bin/deadd-notification-center

Something weird is going on with that binary.

yes its the same package but the precompile one was on a different version/newer version.

yeah a bunch of Haskell stuff.

ls -l /usr/bin/deadd-notification-center: -rwxr-xr-x 1 root root 109285616 Aug 11 22:59 /usr/bin/deadd-notification-center

The size of the binary seems to be correct and matches the size of the executable on the github repo.

So it’s working again after you switched back to 2.1.1-0 (deadd-notification-center). It’s only dead-notification-center-bin 2.1.1-1 that doesn’t work?