Brightness control not working with HP OMEN 15, Nvidia RTX2070 super max-Q

Hi, Brightness control worked in the setup mode OS (when clicked on the first option to continue with UEFI, didn’t work with the second option of with nvidia drivers). and after installing OS in both modes, the screen brightness didn’t work, I tried adding the kernel parameter acpi_backlight= for vendor, native, video. It didn’t work.

I’m okay with not installing nvidia drivers (as I’m dual booting), can somebody help me getting the same UEFI setup mode backlight configs (working with brightness control for me) for the OS that’ll install.

the backlight folder in the setup is nv_backlight but the one in installed version/second option is nvidia_0. basically need a way where I can have the nv_backlight instead of nvidia_0 in installed system.

hey @pranav welcome at the purple side :enos:

i see archwikin shows your notebook:
or at least similar one ?
As this is a hybrid GPU system having intel igpu and the discrete Nvidia for performance… it is still the default that these systems boot on intel igpu per default when Nvidia driver is installed and DRM modesetting enabled… what will be the case if you use Nvidia mode on the ISO installer…
So yes could be you want to switch nvidia on per default … install a switcher tool e.t.c

To see the hardware in detail show it will also include used drivers:
inxi -Fxxc0z | eos-sendlog
This will generate a cleaned hardware report and pastebin it to give a short URL you can post here.

Hi @joekamprad, yes I have the same HP Omen 15-ek005na. used $ nvidia-inst --n to replace nvidia driver with nouveau. But yes, if the brightness control gets resolved using nvidia drivers would be great! attaching the log:

  Kernel: 6.1.9-arch1-2 arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 wm: xfwm dm: LightDM
    Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: HP product: OMEN Laptop 15-ek0xxx v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 878B v: 17.29 serial: <superuser required> UEFI: AMI
    v: F.11 date: 04/18/2022
  Info: 6-core model: Intel Core i7-10750H bits: 64 type: MT MCP
    arch: Comet Lake rev: 2 cache: L1: 384 KiB L2: 1.5 MiB L3: 12 MiB
  Speed (MHz): avg: 2898 high: 3600 min/max: 800/5000 cores: 1: 3562 2: 2600
    3: 2600 4: 2600 5: 3600 6: 2600 7: 2600 8: 2600 9: 3600 10: 3225 11: 2600
    12: 2600 bogomips: 62431
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: NVIDIA TU104M [GeForce RTX 2070 SUPER Mobile / Max-Q]
    vendor: Hewlett-Packard driver: nouveau v: kernel arch: Turing pcie:
    speed: 2.5 GT/s lanes: 16 ports: active: eDP-1 empty: DP-1,DP-2,HDMI-A-1
    bus-ID: 01:00.0 chip-ID: 10de:1e91 temp: 49.0 C
  Device-2: Luxvisions Innotech HP Wide Vision HD Camera type: USB
    driver: uvcvideo bus-ID: 1-6:2 chip-ID: 30c9:000e
  Display: x11 server: X.Org v: 21.1.7 compositor: xfwm v: 4.18.0 driver: X:
    loaded: modesetting,nouveau alternate: fbdev,nv,vesa dri: nouveau
    gpu: nouveau display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96
  Monitor-1: eDP-1 model: Samsung 0x4145 res: 3840x2160 dpi: 284
    diag: 395mm (15.5")
  API: OpenGL v: 4.3 Mesa 22.3.4 renderer: NV164 direct render: Yes
  Device-1: Intel Comet Lake PCH cAVS vendor: Hewlett-Packard
    driver: sof-audio-pci-intel-cnl bus-ID: 00:1f.3 chip-ID: 8086:06c8
  Device-2: NVIDIA TU104 HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: speed: 2.5 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:10f8
  Sound API: ALSA v: k6.1.9-arch1-2 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.65 running: yes
  Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:06f0
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 3c:00.0 chip-ID: 10ec:8168
  IF: eno1 state: down mac: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-14:3 chip-ID: 8087:0026
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 bus-ID: 00:17.0 chip-ID: 8086:282a
  Local Storage: total: 953.87 GiB used: 5.15 GiB (0.5%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB1T0HBLR-000H1
    size: 953.87 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 45.9 C
  ID-1: / size: 249.95 GiB used: 5.15 GiB (2.1%) fs: ext4 dev: /dev/nvme0n1p7
  ID-2: /boot/efi size: 511.2 MiB used: 316 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p5
  ID-1: swap-1 type: partition size: 4.95 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p6
  System Temperatures: cpu: 61.0 C pch: 54.0 C mobo: N/A gpu: nouveau
    temp: 49.0 C
  Fan Speeds (RPM): cpu: 3098 fan-2: 2695 gpu: nouveau fan: 0
  Processes: 319 Uptime: 1m Memory: 15.47 GiB used: 1.67 GiB (10.8%)
  Init: systemd v: 252 default: graphical Compilers: gcc: 12.2.1 Packages:
  pm: pacman pkgs: 794 Shell: Bash v: 5.1.16 running-in: xfce4-terminal
  inxi: 3.3.24

Have you tried adding /usr/share/X11/xorg.conf.d/10-nvidia.conf


Edit: I would have the other kernel paramaters also. Either acpi_backlight=native or acpi_backlight=vendor

I think you need also nvidia_0

Hi, installed back the nvidia drivers with nvidia-inst can’t see 10-nvidia.conf in /usr/share/X11/xorg.conf.d but there’s a file named 10-nvidia-drm-outputclass.conf with following content

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration"
    ModulePath "/usr/lib/nvidia/xorg"
    ModulePath "/usr/lib/xorg/modules"

Should I add EnableBrightnessControl flag here? or should I create 10-nvidia.conf manually.

Tried with kernel parameters acpi_backlight=native, video and vendor and updated grub but that approach didn’t work.

also here’s the updated graphics section from inxi -Fxxc0z , after installing back nvidia driver

  Device-1: NVIDIA TU104M [GeForce RTX 2070 SUPER Mobile / Max-Q]
    vendor: Hewlett-Packard driver: nvidia v: 525.85.05 arch: Turing pcie:
    speed: 8 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1e91
  Device-2: Luxvisions Innotech HP Wide Vision HD Camera type: USB
    driver: uvcvideo bus-ID: 1-6:2 chip-ID: 30c9:000e
  Display: x11 server: X.Org v: 21.1.7 compositor: xfwm v: 4.18.0
    driver: N/A display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 286
  Monitor-1: DP-2 res: 3840x2160 dpi: 284 diag: 395mm (15.55")
  API: OpenGL v: 4.6.0 NVIDIA 525.85.05 renderer: NVIDIA GeForce RTX 2070
    Super with Max-Q Design/PCIe/SSE2 direct render: Yes
1 Like

I’m not sure but i don’t think it would hurt to try it even if you create the file and if it doesn’t work you can just remove it. You may even try the kernel parameter acpi_backlight=video also. I just try to give some suggestions for trial & error. They may or may not make any difference. :thinking:

1 Like

Do you have your system set on Hybrid or dedicated? I’m not that familiar with the HP Omen laptops. Not sure what uefi settings they have.

I have set my uefi settings set on discrete, yes there was an option for hybrid too.

I was just wondering because i only see output for nvidia. Obviously on Nvidia it just uses more battery power.

1 Like

would setting that to hybrid and using optimus-manager work?

lol ya, but actually I removed battery out of my laptop. Using it kinda like PC plugged in :joy:

1 Like

I don’t really know what is the best option. That may or may not work. I don’t really know for sure. I guess one could try it. Not sure that helps with this issue though.

Maybe this helps?

Try kernel parameter this way as in the wiki above. Make sure you are updating grub if using grub boot. If not these kernel paramaters are set in another location and updating is different also.


yeah I tried this too, I think actually from your reply in this forum to one of the posts.

Maybe i try help where i can. I’m no expert. :wink:

1 Like

Thanks, I think this is some odd case. Will use nouveau for now and update the thread if I come across any fix.

I think reading through the wiki may give you some clues?

1 Like

I couldn’t have predicted this, changed uefi graphics setting from discrete to hybrid, installed optimus-manager and changed to integrated graphics. brightness control is working now! :partying_face:

Well as i say I wouldn’t have known either if it would help or even work but that’s great to hear.