Bluetooth issue ..sad panda

Not sure what caused it, but I am having issues with bluetooth working.

Any ideas?

I noticed the following in the logs

the status of my bluetooth seems like its running

I also noticed the following.


Below is my version info.


1 Like

Post the output of

$ rfkill


Try to power on the bluetooth device via the cli.

$ sudo bluetoothctl

When the terminal prompt changes to [bluetooth]#, run power on

What error messages are shown, if any?


Even after running bluetoothctl with sudo?


What’s the output of

$ lsmod | grep bluetooth


Try to reload the bluetooth kernel modules.

$ modprobe -r btusb
$ modprobe -r btintel
$ modprobe btusb
$ modprobe btintel
1 Like

That did it.

Thank you

1 Like

@Noroc @anthony93

I had this same issue - it resolved itself after I updated the kernel from linux 6.8.2.arch1-1 to linux 6.8.2.arch2-1. (I’m assuming a 2nd edition of the 6.8.2 kernel was needed to specifically address this issue.)



P.S. I see from the version info that linux 6.8.2.arch2-1 was running… perhaps the issue was with a related dependency/dependent or some other update. But in any case, the first link I posted here could be informative (Bug Report: Intel AX200 Bluetooth does not work with 6.8.2 and util-linux 2.40 (#40) · Issues · Arch Linux / Packaging / Packages / linux · GitLab)

P.P.S. This has been a known issue, and was previously mentioned within the EOS forum:

Thanks for the links.

Oddly enough the issue came back.

I tried the previous fix and it did not work.

but you gave me the idea to try the following to reinstall the kernal

sudo pacman -Syu linux

I rebooted my pc afterwords and bluetooth came back.

Not sure whats going on.

1 Like

I have a similar problem with Bluetooth since the update to 6.8.2.arch1-1:

My Bluetooth works as expected, when booting from a cold boot. Only when performing a restart, Bluetooth does behave as described by the OP. The outputs of my system even show the exact same information as the screenshots in the OP (when Bluetooth is in its broken state after a restart).

Additionally, when Bluetooth isn’t working after a restart, I get some sort of blocker on the next shutdown/restart:

Only after completely powering off my system, Bluetooth works again.

I’ve tried a few solutions I found online (including the ones in this thread), but I haven’t been lucky so far. Also, there’s been no change in behavior after the update to 6.8.2.arch2-1. My guess is that my Bluetooth adapter (also Intel AX200) has some sort of problem with power management, but maybe someone knows more about this issue.

I would appreciate any further help.

1 Like

This update brought me the bug (also Intel AX200): no bluetooth but also no wifi (hard blocked)! After trying diverse things, I have read in couple of places to disconnect the battery (laptop) for a minute or two. It has worked for me. Discussing on arch matrix chat room, someone told me to check the Fn + Fsomething combo, that can act as a kill switch, which is indeed the case on my computer. Can be worth toggling it before getting the screwdriver ready.

I get the same errors when trying to shut down my pc.

I have to manually hold the power button to turn it off.

The Bluetooth issue keeps coming back, I can only assume we just have to wait for a update.

Are you dual booting with Windows?

Yes, I rarely use it though.

I have had it for some time with no issue.

Do you think that maybe a windows update might have created this situation?

Yes. And I have fast boot disabled.

I just checked mine as well, it was already disabled.