Bluetooth Doesn't Connect on Fresh Gnome Install

Greetings lovely community,

After a few weeks, I finally installed EndeavourOS for the first time. Super easy to get up and running, so thanks to all the devs for all their hard work. Now to my first issue! Hopefully it is a rather simple one that I just messed up on or missed. Now I am aware that bluetooth is not enabled by default, but I followed the instructions here: https://discovery.endeavouros.com/bluetooth/bluetooth/2021/03/

Currently using Gnome 40 with the kernel-lts

sudo pacman -S --needed bluez bluez-utils pulseaudio-bluetooth

I did that command, and then ran these commands (I wasn’t sure which one so I ran them all):

sudo systemctl start bluetooth
sudo systemctl enable bluetooth
sudo systemctl enable --now bluetooth

I also saw on another post to install alsa-tools as well so I did that, (not sure if that was necessary btw) and after all this I did a reboot. However, when I login and turn my bluetooth UE Boom speaker on (which works under Ubuntu, PopOS, & Solus btw) I am able to pair the speaker in the Gnome Bluetooth settings, however the second it pairs, it immediately disconnects right after. So I’m currently at a loss of what I might have done wrong. Any help would greatly be appreciated, I definitely need bluetooth to work, so if this can get fixed I’d be beyond grateful! If you need anymore info or spec or terminal outputs from me just let me know I’m here all day.

I know below is a lot of info, but I hope it helps speed things up by giving you guys as much relevant information as I can from the get-go.

Here’s my output for systemctl status bluetooth

[scott@endeavourOS ~]$ systemctl status bluetooth
● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
     Active: active (running) since Mon 2021-06-28 12:59:53 CDT; 34min ago
       Docs: man:bluetoothd(8)
   Main PID: 367 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 19038)
     Memory: 2.8M
        CPU: 503ms
     CGroup: /system.slice/bluetooth.service
             └─367 /usr/lib/bluetooth/bluetoothd

Jun 28 13:05:19 endeavourOS bluetoothd[367]: src/service.c:btd_service_connect() a2dp-source profile connect failed for C0:28:8D:44:77:7A: Device or resource busy
Jun 28 13:05:22 endeavourOS bluetoothd[367]: profiles/audio/avdtp.c:avdtp_connect_cb() connect to C0:28:8D:44:77:7A: Device or resource busy (16)
Jun 28 13:05:31 endeavourOS bluetoothd[367]: profiles/audio/avdtp.c:avdtp_connect_cb() connect to C0:28:8D:44:77:7A: Device or resource busy (16)
Jun 28 13:05:31 endeavourOS bluetoothd[367]: src/service.c:btd_service_connect() a2dp-source profile connect failed for C0:28:8D:44:77:7A: Device or resource busy
Jun 28 13:05:34 endeavourOS bluetoothd[367]: profiles/audio/avdtp.c:avdtp_parse_rej() SET_CONFIGURATION request rejected: Configuration not supported (41)
Jun 28 13:05:34 endeavourOS bluetoothd[367]: src/service.c:btd_service_connect() a2dp-source profile connect failed for C0:28:8D:44:77:7A: Device or resource busy
Jun 28 13:06:24 endeavourOS bluetoothd[367]: profiles/audio/avdtp.c:avdtp_connect_cb() connect to C0:28:8D:44:77:7A: Device or resource busy (16)
Jun 28 13:06:24 endeavourOS bluetoothd[367]: src/service.c:btd_service_connect() a2dp-source profile connect failed for C0:28:8D:44:77:7A: Device or resource busy
Jun 28 13:06:27 endeavourOS bluetoothd[367]: profiles/audio/avdtp.c:avdtp_parse_rej() SET_CONFIGURATION request rejected: Configuration not supported (41)
Jun 28 13:06:27 endeavourOS bluetoothd[367]: src/service.c:btd_service_connect() a2dp-source profile connect failed for C0:28:8D:44:77:7A: Device or resource busy

My output for the rfkill command is as follows in case this relates:

[scott@endeavourOS ~]$ rfkill
ID TYPE      DEVICE              SOFT      HARD
 0 bluetooth hci0           unblocked unblocked
 1 wlan      acer-wireless  unblocked unblocked
 2 bluetooth acer-bluetooth unblocked unblocked
 3 wlan      phy0           unblocked unblocked

Here’s my ‘inxi -Fxxxza --no-host’

[scott@endeavourOS ~]$ inxi -Fxxxza --no-host
System:
  Kernel: 5.10.46-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-linux-lts 
  root=UUID=7a865f99-81c3-40ea-bc52-7f226e47e7db rw quiet loglevel=3 
  nowatchdog 
  Desktop: GNOME 40.2 tk: GTK 3.24.29 wm: gnome-shell dm: GDM 40.0 
  Distro: EndeavourOS base: Arch Linux 
Machine:
  Type: Laptop System: Acer product: Aspire E5-576G v: V1.32 serial: <filter> 
  Mobo: KBL model: Ironman_SK v: V1.32 serial: <filter> UEFI: Insyde v: 1.32 
  date: 10/24/2017 
Battery:
  ID-1: BAT1 charge: 18.8 Wh (100.0%) condition: 18.8/62.2 Wh (30.2%) 
  volts: 12.6 min: 11.1 model: PANASONIC AS16B5J type: Li-ion 
  serial: <filter> status: Full 
CPU:
  Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: A (10) 
  microcode: EA cache: L2: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 28800 
  Speed: 801 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 801 2: 814 
  3: 807 4: 830 5: 858 6: 887 7: 801 8: 844 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Acer Incorporated ALI driver: i915 
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300 
  Device-2: NVIDIA GP108M [GeForce MX150] vendor: Acer Incorporated ALI 
  driver: nvidia v: 465.31 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:1d10 class-ID: 0302 
  Device-3: Chicony HD WebCam type: USB driver: uvcvideo bus-ID: 1-7:4 
  chip-ID: 04f2:b571 class-ID: 0e02 
  Display: x11 server: X.org 1.20.11 compositor: gnome-shell driver: 
  loaded: modesetting resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.1.3 
  direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3 
  chip-ID: 8086:9d71 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.46-1-lts running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.30 running: no 
Network:
  Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi 
  v: kernel port: 4000 bus-ID: 03:00.0 chip-ID: 8086:24fb class-ID: 0280 
  IF: wlan0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000 
  bus-ID: 04:00.1 chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp4s0f1 state: down mac: <filter> 
Bluetooth:
  Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8 
  bus-ID: 1-5:3 chip-ID: 8087:0aa7 class-ID: e001 
  Report: This feature requires one of these tools: hciconfig/bt-adapter 
Drives:
  Local Storage: total: 2.05 TiB used: 501.05 GiB (23.8%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: SK Hynix model: HFS256G39TND-N210A 
  size: 238.47 GiB block-size: physical: 4096 B logical: 512 B 
  speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 1P10 scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Seagate model: BUP Slim 
  size: 1.82 TiB block-size: physical: 4096 B logical: 512 B serial: <filter> 
  rev: 1707 scheme: GPT 
Partition:
  ID-1: / raw-size: 237.97 GiB size: 233.17 GiB (97.99%) 
  used: 105.18 GiB (45.1%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) 
  used: 296 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2 
  file: /swapfile 
Sensors:
  System Temperatures: cpu: 56.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 260 Uptime: 30m wakeups: 1 Memory: 15.51 GiB 
  used: 3.22 GiB (20.8%) Init: systemd v: 248 tool: systemctl Compilers: 
  gcc: 11.1.0 Packages: 1046 pacman: 1039 lib: 270 flatpak: 7 Shell: Bash 
  v: 5.1.8 running-in: tilix inxi: 3.3.03

Not saying this is an issue with GNOME, most likely it isn’t, but I’d just like to mention how on KDE Plasma, I have no issues with Bluetooth… :wink:

3 Likes

Seems like you aren’t the only one to experience issues with that card … though the OP in this thread over in Manjaro-land seemed to point the finger at Windows dual boot? …

Although I don’t know how much it helps you but couple of suggestions I got while searching for other bluetooth error:

  1. Downgrade bluez version, remove /var/lib/bluetooth folder and check
  2. Try connecting using bluetoothctl instead of UI buttons, sometimes I too can’t connect properly using tray icon or UI setup
  3. Try bluez-git instead of bluez
  4. make sure the Bluetooth speaker is in pairing mode and remove it from list and repair it in bluetoothctl: Can't connect my bluetooth headphones - #6 by joekamprad

Ah man, I spent all night trying to mess around with it and couldn’t get bluetooth to connect to my UE Boom speaker or my Samsung Buds+ earbuds. I hate to say it so soon already, but if I can’t get bluetooth to work that’s sadly a deal breaker for me in a distro that I need to work. I understand not enabling bluetooth for the devs reasons, but it’s crucial for me. I think maybe I just got too in over my head perhaps with wanting to try a rolling arch based release, I’m a simple guy not a coder or anything. So much of what I researched and looked up last night about bluetooth on random arch wikis and forums was just mind numbing and I didn’t get any closer to even figuring this problem out sadly. It’s no one’s fault, but last night was frustrating.

ok, let’s still try if you would like to.

As far as I see, your setup worked just fine. You only have connection issues now, which may be either device related or bluez version related

Have you tried the 4 points above? especially the bluetoothctl based connection

Tried bluez-git and even blueman-get (separately) and still couldn’t figure it out. Felt like beating me head into a wall because I have no experience trying to deal with an issue like that. I’m used to if it’s already been solved, I just paste a few commands and call it a day. Anything outside of that and my brain just goes, uhhhhhh. I appreciate your replies though, I’m just clueless I don’t think it’s gonna work and the bluetooth device works fine still on other distros, just tested it on PopOS again to make sure.

I also had so many problems with bluetooth, so i downgrade bluez and bluez-utils to version 5.50-4 on Lts kernel. It is working fine so far.

Do you have pulseaudio-bt-auto-enable-a2dp installed?

Edit:

https://wiki.archlinux.org/title/bluetooth#Using_your_computer.27s_speakers_as_a_bluetooth_headset

I had to go visit my family this month and they have the worst wifi speeds sadly (aka less than 1MBps), but hopefully when I get back home in a week or so I can check this out and update you guys cuz I haven’t gotten it to work yet.

Probably not gonna be the answer anyone was expecting, but basically I did a clean install again. And this time I somehow (lucky?) got bluetooth to work with my speakers and my headphones! All I did was what was referenced here: https://discovery.endeavouros.com/bluetooth/bluetooth/2021/03/ but the only steps I did to get it to work were as follows:

sudo pacman -S --needed bluez bluez-utils pulseaudio-bluetooth
sudo systemctl enable --now bluetooth

And that was it and now it works without any issues! Was only one of two issues I was having and luckily today I was able to randomly and luckily fix both of them so looks like I’m gonna be on endeavourOS until Nvidia drivers break me hehe. Thanks everyone :slight_smile:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.