Blank Screen right after new update

Hi all,
Could someone please help if possible? Right after my latest update, ‘’‘pacman -Syu’’’ the next time I restarted my computer I just see a blank screen right after the grub. I was able to fix this by downgrading the kernel, but this then broke my nvidia-dkms and optimus-manager ability. I was wondering if anyone knew the solution to a bad Graphics driver? here is the inxi -b:

  Host: test Kernel: 5.12.2-arch1-1 x86_64 bits: 64 Desktop: Cinnamon 4.8.6
  Distro: EndeavourOS
  Type: Kvm System: QEMU product: Standard PC (i440FX + PIIX, 1996)
  v: pc-i440fx-6.0 serial: <superuser required>
  Mobo: N/A model: N/A serial: N/A BIOS: SeaBIOS v: ArchLinux 1.14.0-1
  date: 04/01/2014
  Info: Quad Core Intel Core i7-10510U [MT MCP] speed: 2304 MHz
  Device-1: Red Hat QXL paravirtual graphic card driver: qxl v: kernel
  Display: x11 server: 1.20.11 driver: loaded: modesetting
  unloaded: fbdev,vesa resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel 82371AB/EB/MB PIIX4 ACPI type: network bridge
  driver: piix4_smbus
  Device-2: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
  driver: 8139cp
  Local Storage: total: 98.42 GiB used: 5.75 GiB (5.8%)
  Processes: 231 Uptime: N/A Memory: 3.81 GiB used: 842.7 MiB (21.6%)
  Shell: Bash inxi: 3.3.03 

Is there any way to manually fix my Graphics Driver without having to downgrade my kernel? The reason I used a virtual box was because I only see a blank screen if I update my main system. Thanks any help would be appreciated!

Also when I open endeavour on the virtual box it says that I am not using hardware acceleration or something as a notice. Sorry if this is a bother any help would be appreciated.

Hello @alterlinux1234
Do you have the optional enhancements set up for nvidia?

I have a HP probook 450 G7. I also have an intel i7 with Nvidia GeForce MX250… I do not think I have any optional enhancements… Thanks. I have read through the site you sent me but I am not sure how to force early load KMS. Should I just copy the site’s instructions? I’m afraid that my screen will go blank again if I reboot…

Because you have Optimus I’m not sure this is what you need. You said you downgraded the kernel but now another kernel came out 5.12.2. If you broke the optimus set up you’ll have to try to fix that. Not sure what happened to break it?

yeah I downgraded the Kernel to 231…and then I tried to figure out what was wrong by installing the OS on a virtual box. So that I can at least see my screen. When I upgrade the Kernel I get a blank screen right after the grub menu. My real OS does not have Optimus, and I had to use an older ISO to even have a non blank screen…if that makes sense…I have an i3, with no NVIDIA and it works fine, but my main computer doesn’t. Do you think it’s the display driver?

Also I think you are right about it being some type of problem with the Intel, and NVIDIA integrated Graphics driver? because my i3 has no problems with endeavour.

I3 is probably only using the intel driver. You kind have lost me with the whole thing. Cinnamon is installed on it or I3? You say you broke optimus but you don’t have it installed? Now you are on virtual?

Sorry, I was typing off the top of my head and wasn’t being clear enough. When I first had this problem I had Optimus-manager-qt and Optimus-manager installed and it was working fine but after the new update I just got a blank screen. So I reinstalled an older OS and downgraded the linux kernel. When I did that the nvidia-dkms did not work anymore so I just got rid of all Nvidia related stuff on my OS. Then I tried messing around on a virtual box to see what was the problem, and the Graphics driver was some paravirtual driver from Red Hat. and the i3 was not the window manager but the Intel CPU. I have an older laptop with Intel i3 cpu and no Nvidia GPU on it. So right now I am using an older kernel which is 5.11.16

Is this on another laptop? I’m still confused? What is the state of the laptop that you want to work?

I’m using the laptop that I want to work right now. It’s the HP probook G7 450. But the kernel is downgraded and i am using a different OS. When I try and reinstall Endeavour OS I just get a blank screen right after I install it and reboot. I was wondering if there was a way I could use Nvidia and use the updated Kernel, perhaps by changing the display driver somehow. Sorry I am really new at using Linux.

The laptop that has the Intel i3 core with no Nvidia is working fine, but I am trying to work the HP probook with an i7 core and Nvidia GeForce MX250…I can use it right now but I can’t use Nvidia and can’t update the kernel without the blank screen after the grub menu.

If it’s a hybrid laptop so you’ll have to install the nvidia drivers and the optimus manger in order to switch to nvidia. It depends on the desktop you have installed.

I see. Should I just not update the kernel also? My computer seems to work if I do not update the kernel, but then nvidia-dkms and the nvidia drivers in general can’t install.

I was thinking to wait until another kernel update comes then try that.

When I try and install Endeavour OS again it goes right to a blank screen after I install and reboot. Right after the grub menu it’s a black screen. Also, the desktop i have is Cinnamon. It seems that when I update the kernel, there is no graphics driver after that. Is there a way I can fix the graphics driver?

Sorry i just fixed another Nvidia install which is now working. Yours is more difficult because it is hybrid graphics. It has Intel and Nvidia so you have to use optimus manager or some other method to switch to nvidia. You say nvidia doesn’t install. I don’t buy that. It may not work but that’s another issue. I’m sure it installs. You can test that easily.

What i would do is run this test first. It will show whether the install is going to work.

nvidia-installer-dkms -t

If there are no errors then install it

sudo nvidia-installer-dkms

Then you’ll have to install Optimus manager.

yay -S optimus-manager

yay -S optimus-manager-qt


Then check systemctl status optimus-manager

To start and enable it run (if it is not running):

sudo systemctl enable --now optimus-manager

Hopefully it works and gives you the tray icon to switch.


Run from terminal:

optimus-manager --switch nvidia
to switch to the Nvidia GPU
optimus-manager --switch integrated
to switch to the integrated GPU and power the Nvidia GPU off
optimus-manager --switch hybrid
to switch to the iGPU but leave the Nvidia GPU available for on-demand offloading, similar to how Optimus works on Windows.

Edit: You still may have to do all the enhancements for nvidia in order for it to work.

1 Like

Hey sorry I responded late, I appreciate the help, and for some reason sudo nvidia-installer-dkms -t is not working. It says command not found when I try and type that in the terminal. Is there an open source Graphics driver that I can install and force the computer to use like a graphics driver equivalent of sof-firmware? I have a feeling that the graphics driver is what makes my screen go blank after the kernel update…Does that make sense?

You need to install nvidia-installer probably?

Edit: You can use nouveau which is the open-source driver for nvidia.

Edit2: Nouveau should automatically work if you uninstall all nvidia

Okay, I’ll try that now. Thanks for the help @ricklinux. How do I force my computer to use the nouveau driver? Rather than the intel driver?

I just tried to install nvidia-dkms and nvidia and this error popped up: ‘’’==> Unable to install module broadcom-wl/ for kernel 5.12.2-arch1-1: Missing kernel headers.
==> Unable to install module nvidia/465.27 for kernel 5.12.2-arch1-1: Missing kernel headers.
(4/4) Updating linux initcpios…
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: ‘default’
→ -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
/etc/mkinitcpio.conf: line 73: unexpected EOF while looking for matching "' /etc/mkinitcpio.conf: line 78: syntax error: unexpected end of file ==> ERROR: Failed to read configuration /etc/mkinitcpio.conf’
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: ‘fallback’
→ -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
/etc/mkinitcpio.conf: line 73: unexpected EOF while looking for matching "' /etc/mkinitcpio.conf: line 78: syntax error: unexpected end of file ==> ERROR: Failed to read configuration /etc/mkinitcpio.conf’
error: command failed to execute correctly

This means that I couldn’t install it right?

See if you can get the system working first.