Black wallpaper / screen


For the record, I’m a massive Linux noob and have no idea where to start when it comes to debugging this problem, it all started when my pc crashes while playing games (minecraft) and after restarting I got this black screen and every so often I reboot and it goes away and then it comes back usually after another reboot, it’s almost like there’s a black application in-front but I can’t terminate it, for the record I know it’s just not a black wallpaper as I cannot see my desktop files / shortcuts.

What I have tried

after abit of research i see alot of people talking about the nvida drivers so I read the guide and had support for dkms and proceeded to install it, but obliviously the infamous black screen / wallpaper is still remains.

additional information

I’m using KDE / Plasma
I have nvidia 1050ti
and Intel i5-7400

any help is welcome, It’s not really an urgent issue as I can still use my pc fine but would love to sort this out :smiley:

through random scrolling I actually found a related posting on this forum and there temp solution worked which means it is for sure related

First, it is a good idea to make a backup of all of your personal data.

Then you could try reinstalling packages

  • linux
  • linux-headers
  • all packages related to nvidia (use command pacman -Qs nvidia to see which)

So something like:

sudo pacman -S linux linux-headers $(pacman -Qs nvidia)

If reinstalling packages doesn’t help, then reinstalling EndeavourOS might be needed, unless someone has a better idea.

hardware health tests…( hd, graphics card )

KDE/Plasma have lots of issues with MultiScreen Support.

If you want and have the time, look into your logs (journalctl, xorg) for relevant log messages, that might provide a helpful clue.

I suppose this specific issue is related to dual-gpu (Intel-Nvidia) setup (I have one too :cry: ).
If you can afford it, you may reset/delete all local/user plasma-related configuration files (you’ll need to reconfigure from start, so it’s ugly…).

I suggest you follow the linked similar topic workaround, creating keyboard shortcut keys for “Restart Plasma” and “Restart kWin”. The 1st one will most probably be your temporary/permanent solution.

1 Like

Hey all I really appreciate all your advice you gave me unfortunately @petsam was the only (semi/temp) that I could work out, however in a weird twist of fate my friend convinced me to go over to i3(-gaps) and so far I’ve loved my experience with it so far and hence my issues with kde/plasma has been well… eliminated. but again really appreciate you all putting in the time to help me :smiley:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.