Wallpaper on main monitor disappears and unable to right click

On a fresh install of EndeavourOS using KDE.

I have this issue that can randomly happen. Sometimes, when I boot up my PC for the day or if I restart the system, the wallpaper on my main monitor will disappear and the right-click context menu doesn’t appear as well. My secondary monitor, which is setup vertically, is fine.

I usually can fix this by entering this into the terminal:
kquitapp5 plasmashell && kstart5 plasmashell

Another workaround that I found on stackoverflow was to run Ksysguard, right-click on Kwin_x11. select ‘Send Signal’ then click on Interrupt(INT). Then I restart the computer and everything returns to normal.

What’s bothering me though is that this sort of happens frequenlty like once or twice a day. I’m wondering if there’s something else I’m missing on or if you guys have any suggestions. Any logs or other information I need to provide?


When plasmashell hangs like that it can be difficult to find the problem sometimes. I’d start by checking the journalctl and dmesg outputs and see if there’s a consistent process that causes it every time.

You could also quickly create a new user and see if it happens with a brand new profile. If it’s stable with a new user profile you’ll know it’s a $HOME config file issue or not.

1 Like

Thanks for the insight. I tried it on a new user and it hasn’t happened so far. Although, this time the issue isn’t showing up again on my main account. Maybe something from the Atlantis update fixed it when it came out?

Anyway, thanks for the feedback.