Black screen with underscore after updating

Hi! I recently updated my laptop by running sudo pacman -Syu. From there on I obviously did a reboot. However, when rebooting, all I saw was a black screen with an underscore in the top left corner (not blinking). I tried accessing TTY, but nothing seemed to work.

My laptop: https://www.lenovo.com/no/no/laptops/thinkpad/t-series/t440

Any ideas?

See if you can use the following how-to for getting to TTY:

Try updating the system again from there in case something went wrong with the updating process.
Check the status of your display manager.

Read through the instructions in the following link in order to provide some info to the forum.

https://discovery.endeavouros.com/forum-log-tool-options/how-to-include-systemlogs-in-your-post/2021/03/

:bouquet: Welcome to EnOS’ forum and good luck!

The guide to getting into TTY worked flawlessly.

I tried updating the system once again by running pacman -Syu, but it stayed the same.

Here’s some more info:
https://clbin.com/Yck0W - journalctl -b -1
https://clbin.com/lLWJT - sudo dmesg -rl warn,err,crit
https://clbin.com/bia0f - inxi -Fxxc0z --no-host

1 Like

Try the lts kernel. ‘Sudo pacman -S linux-lts linux-lts-headers’

Didn’t seem to work, anything else I can try?

Did you update grub? And select the lts kernel?

Which commands would that be again?

Does this laptop have the optional Nvidia graphics?

Edit: Sorry, I didn’t notice the logs at first.

I think he means did you update grub? After installing the lts kernel?

Edit:
sudo pacman -S linux-lts linux-lts-headers
sudo grub-mkconfig -o /boot/grub/grub.cfg

I tried to run sudo grub-mkconfig -o /boot/grub/grub.cfg, but it says I don’t have no space left. What should I do?

https://clbin.com/ue0R1

Is this a dual boot scenario with Windows?

Edit: I don’t understand the ouput from your link? Where is that from?

sudo fidisk -l | eos-sendlog

Edit: I see that / is all used 100%

Filesystem Size Used Avail Use% Mounted on
dev 5.8G 0 5.8G 0% /dev
run 5.8G 9.4M 5.8G 1% /run
/dev/sda3 26G 26G 0 100% /
tmpfs 5.8G 0 5.8G 0% /dev/shm

The output is from df -H. Do you want the output of sudo grub-mkconfig -o /boot/grub/grub.cfg?

How can I give space from /dev/sda4 to /dev/sda3?

Can we see the command link a gave you.

Edit: Maybe that command won’t work for you?

Lots of snaps.

There’s very few ways to do this, all of which aren’t safe to do. If you’re that full, i would recommend saving everything of importance before doing anything, and then whatever you try, just realized it’s very likely you’ll be reinstalling soon.

Edit. Not a VM, nevermind.

You could begin with doing some cleaning up of your package cache. If you haven’t done this yet sometimes it will take up several GBs. Perhaps, for now, that would be enough to get your system back up and running.

Get into TTY, log in and do some of the stuff described here:

https://wiki.archlinux.org/title/Pacman#Cleaning_the_package_cache

After that, run:

sudo pacman -Syu

sudo mkinitcpio -P

sudo grub-mkconfig -o /boot/grub/grub.cfg

reboot

2 Likes

Still in the end even if able to update and boot into the system root is too small? :thinking:

Yes, this is a short term solution. But if the system get fixed, then there might be a way to expand the root partition.

1 Like

Yes it might be possible? I know on Windows you can do it with the right software. On linux I don’t know without trying. :thinking:

It is possible to use Gparted (or other disk partitioning tools) to do it from a live usb.
What needs to be done depends on the disk layout.

This worked perfectly along with the other steps! My computer is working properly now :slight_smile:

Thanks to everyone who helped me. Have a great day!

1 Like