Black screen during boot, including live boot from USB, but randomly

So, I switched from Nvidia to AMD, specifically a 6900XT. I’ve been on EndeavourOS for almost a year, but a new issue has come up after this system upgrade.

Whenever I would boot, two out of every three times, I would get the BIOS splash, get the “Starting Linux Kernal Verson…” screen, and then a No Display Detected right after. Sometimes. After restarting and forcefully restarting right after the starting linux screen, it would proceed to the black screen with an underscore and display my GDM login page. This also happens randomly when resuming from sleep.

So, I figured maybe it’s because I switched graphics cards or because I need a BIOS update. So I figured a new install and a BIOS upgrade might fix the issue. I dual boot with Windows 10 and Windows does not ever encounter this issue. Stress testing the hardware also shows that it doesn’t encounter any faults, this seems to be specifically with linux installs.

I wiped my Linux drive and Windows now boots automatically and I created the live boot USB for the install. The USB boot does the same thing.

I get the “running early hook, starting version 249.7-2-arch” screen and about every 2 out of 3 restarts, black “no display detected”. I’ve tried other monitors etc etc but I’m just not getting these issues on Windows at all and no matter how I change my hardware config, the issue keeps happening. But then it works and boots just fine.

I was using systemd-boot with my previous install before wiping it, but with the USB device using Grub and still having this issue, it must be something unrelated. Perhaps it’s something with when the AMD driver is loaded?

Any help would be great… just let me know what information you need from me. I’ve struggled with finding logs to display what sort of errors could be happening. Also, when the screen doesn’t display, switching to other TTYs does not work, either. Nothing. I have to reboot.

EDIT: Also, pretty relevant, my partner is having the exact same issue, exact same hardware and AMD switchover, but he is running PopOS. I know this isn’t specifically EndeavourOS.

Why are you running such an outdated system? systemd is currently at 250.4-2…

That’s just the live USB boot. My actual install was on the latest 250. something or other.

1 Like

I guess it could be related to the GPU and version of kernel and/or MESA. If you’re not already fully up-to-date then that’s worth trying (kernel and MESA are at 5.17.1 and 22.0 respectively).

Either that or it actually is a hardware issue and something doesn’t like the Linux boot process.

I’ve seen others post about adding Grub specific lines to run the AMD drivers, so I’ll probably try that shortly. I just got the OS installed fresh.

  1. Opened file " /etc/default/grub " (without quotes)
  2. Added " quiet splash radeon.modeset=0 " (without quotes)
    to line starting with " GRUB_CMDLINE_LINUX_DEFAULT= " (without quotes)
  3. Did sudo update-grub , followed by
  4. sudo reboot

That disables kernel modesetting? :thinking:

Well, I can tell you that it did not help. :wink:

So does it boots to black screen all the time or sometimes? Are able to get to a desktop or not?

Did you try this kernel parameter?

Just sometimes. It’s immediately after the "Starting Linux Kernal Version 250…) screen. If it doesn’t display the black screen with an underscore, my monitor just displays a “No display detected” pop up, the computer winds down, and just sits. I have to restart. But it’s random, almost every other start. Sometimes, I have to restart it three or four times to get it to successfully get to the GDM login screen.

Ty the kernel parameter in the post above.

I have not tried the kernel param. Where specifically should that go?

In the grub command line same as you posted where you added the radeon.modeset=0

Edit: I may be wrong here as this is related to multiple monitors on the 6900XT?

1 Like

I have all but one monitor unplugged until I can figure this out. This line didn’t work, though.

Okay just remove it then. I’ll think some more?

This brought me into a different TTY on a successful start, though.

Hmm? So what do you have hooked up? One monitor?

Yes, just one.

I’ve seen people post about modifying the mkinitcpio.conf, MODULES= to include their graphics driver so that it loads early. Could this be a potential solution? I’m not sure what to put there to try.

I was going to mention that. Try adding amdgpu to the /etc/mkinitcpio.conf file under MODULES= and save the file and then run:

sudo mkinitcpio -P