Black screen after login

I’m running EndeavourOS with Sway. It boots up and goes all the way to the login screen. However, after I login, the screen goes completely black. When I try Super+Shift+E to exit Sway, nothing happens. Any ideas on how I could fix this?

1 Like

Some more information?

NVIDA Graphics?

Perhaps try switching to another tty CTRL+ALT+F1/F3 etc then launch sway by using the command “sway”


and… currently, lightdm is causing an issue on sway… so try switching it to something other can help :wink:

Sweet, that worked!

Here’s the output of the two commands:

inxi -Fxxc0z --no-host | eos-sendlog
journalctl -b -0 | eos-sendlog


Okay! How do I switch from lightdm to something else?

1 Like

According to the Arch wiki, GDM or SDDM would do. I already have SDDM (because I have KDE Plasma). I’ve added Sway just now and, on logging in, the Sway session is available & functional.

To activate SDDM after installing it, see dalto’s advice here.

sudo systemctl enable sddm -f

GDM ,sddm ok might think light option :innocent:


And more on ly in this video by Ermanno @ ~33 min and ~37:50 into the video.

What I did was disable lightdm via systemctl and start sway from tty just typing “sway” at command prompt.


I’ve gone DM-free as well. This post suggests that getting a black screen maybe due to a “timing related thing” (race condition?) and that older (spinning drives) maybe less affected.

1 Like

Awesome, that worked, thanks so much!

Switching to another TTY, i.e. Ctrl + Alt + F2, and manually launching Sway via sway --unsupported-gpu works for me. I then log-out, I go back to Ctrl + Alt + F1, and I am landed in SDDM’s login screen, I type my password and Sway launches then.

How do we render all this unnecessary?

I still experience this issue. Relevant, I think, is also : Machine does not wake from suspend/hibernation - #28 by NikosAlexandris.