Black Screen... 6 days after installation

I installed EOS KDE onto my Laptop on 8 July 2021. I used the Live Installer, & chose the Nouveau video driver, not the NVidia one. Since then i have been using the laptop very frequently & for long sessions; EOS has been behaving very well… until last night.

Though i can use it in Wayland, i much prefer X11 [Plasma still has too many faults for my use-case in W]. Yesterday afternoon i concluded another successful X11 session, then Suspended it to RAM [a common event for me, previously unproblematic]. Last night i wanted to use it again, so Resumed… to a black screen. :open_mouth:

Ever since then, across numerous reboots & attempts to troubleshoot it, for reasons i’ve still not yet discovered, it no longer works in X11 [= always now black screen], albeit still works “fine” in Wayland [within the constraints of W].

Whilst [iirc] i had not performed any package updates or installations during yesterday’s “normal” X11 session, several times today i have ensured that my EOS is fully up to date [including reboots when directed].

Laptop’s neofetch:

                     ./o.                  ephemeron@xpsl501x 
                   ./sssso-                ---------------- 
                 `:osssssss+-              Uptime: 52 secs 
               `:+sssssssssso/.            --------------- 
             `-/ossssssssssssso/.          OS: EndeavourOS Linux x86_64 
           `-/+sssssssssssssssso+:`        Kernel: 5.12.15-zen1-1-zen 
         `-:/+sssssssssssssssssso+/.       Packages: 1715 (pacman) 
       `.://osssssssssssssssssssso++-      Shell: bash 5.1.8 
      .://+ssssssssssssssssssssssso++:     Resolution: 1366x768 
    .:///ossssssssssssssssssssssssso++:    DE: Plasma 5.22.3 
  `:////ssssssssssssssssssssssssssso+++.   WM Theme: plastik 
`-////+ssssssssssssssssssssssssssso++++-   Theme: Breath2 [Plasma], Default [GTK2/3] 
 `..-+oosssssssssssssssssssssssso+++++/`   Icons: oxygen [Plasma], oxygen [GTK2/3] 
   ./++++++++++++++++++++++++++++++/:.     Font: Ubuntu Condensed 0 8 [Plasma], Ubuntu Condensed, 8 [GTK2/3] 
  `:::::::::::::::::::::::::------``       CPU: Intel i5 M 460 (4) @ 2.534GHz 
                                           GPU: NVIDIA GeForce GT 420M 
                                           GPU: Intel Core Processor 
                                           Memory: 1015MiB / 7686MiB 
                                           Locale: en_AU.UTF-8 

ephemeron@xpsl501x[~] 17:14:39 Thu Jul 15 $> 

Extract ex inxi [in X11, obtained by connecting to laptop with AnyDesk from my other pc]:

ephemeron@xpsl501x[~] 19:55:31 Thu Jul 15 $> inxi_
System:    Kernel: 5.12.15-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-linux-zen 
           root=UUID=f24c8e9b-ae25-4387-b996-cbba514c0524 rw loglevel=3 nowatchdog 
           Desktop: KDE Plasma 5.22.3 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
           Distro: EndeavourOS base: Arch Linux 
Machine:   Type: Portable System: Dell product: XPS L501X v: A08 serial: <filter> 
           Mobo: Dell model: 00CKNG v: A08 serial: <filter> BIOS: Dell v: A08 date: 07/26/2011 
CPU:       Info: Dual Core model: Intel Core i5 M 460 bits: 64 type: MT MCP arch: Nehalem 
           family: 6 model-id: 25 (37) stepping: 5 microcode: 7 cache: L2: 3 MiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20215 
           Speed: 1603 MHz min/max: 1199/2534 MHz boost: enabled Core speeds (MHz): 1: 1603 
           2: 1962 3: 1500 4: 1396 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds 
           status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 
           mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, 
           STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Core Processor Integrated Graphics vendor: Dell driver: i915 
           v: kernel bus-ID: 00:02.0 chip-ID: 8086:0046 class-ID: 0300 
           Device-2: NVIDIA GF108M [GeForce GT 420M] vendor: Dell driver: nouveau v: kernel 
           bus-ID: 02:00.0 chip-ID: 10de:0df1 class-ID: 0300 
           Device-3: Quanta Laptop_Integrated_Webcam_2HDM type: USB driver: uvcvideo 
           bus-ID: 1-1.4:4 chip-ID: 0408:2fb1 class-ID: 0e02 
           Display: x11 server: X.Org 1.20.12 compositor: kwin_x11 driver: 
           loaded: intel,nouveau unloaded: fbdev,modesetting,vesa alternate: nv display-ID: :0 
           screens: 1 
           Screen-1: 0 s-res: 1024x768 s-dpi: 96 s-size: 270x203mm (10.6x8.0") 
           s-diag: 338mm (13.3") 
           Monitor-1: VGA-1-2 res: 1024x768 hz: 60 
           OpenGL: renderer: Mesa DRI Intel HD Graphics (ILK) v: 2.1 Mesa 21.1.4 
           direct render: Yes 

I read all these from, but atm have not attempted to deploy any of them [tbh, i simply don’t understand if any are applicable to my Laptop or not]:

  5. …see next post…

Fwiw, i’ve also searched the EOS Forum, & read these [but haven’t directly tried using them as once again, i’m uncertain if they’re relevant]:

  1. …see next post…
  2. …see next post…
  3. …see next post…
  4. …see next post…

I read & applied this [but it made EOS even worse]:
h-t-t-p-s:// :

ephemeron@xpsl501x[~] 17:39:50 Thu Jul 15 $> nvidia-installer-check
Your graphics card (id: 0df1) is supported by the nvidia-390xx-dkms driver.
To install a driver for this card:
  * Use the --force option with nvidia-installer-dkms.
  * Then, BEFORE rebooting, install nvidia-390xx-dkms from the AUR.
    For example:
      yay -S nvidia-390xx-dkms

ephemeron@xpsl501x[~] 17:40:17 Thu Jul 15 $> 
ephemeron@xpsl501x[~] 17:50:50 Thu Jul 15 $> sudo nvidia-installer-dkms -f
[sudo] password for ephemeron: 
INFO:root:/tmp/nvidia-installer_r.log not found. That's ok.
INFO:root:EndeavourOS Nvidia Installer v3.3.8
2021-07-15 17:51:17 [INFO]: EndeavourOS Nvidia Installer v3.3.8
INFO:root:All logs will be stored in /tmp/nvidia-installer_r.log
2021-07-15 17:51:17 [INFO]: All logs will be stored in /tmp/nvidia-installer_r.log
INFO:root:Updating Nvidia graphics cards database...
2021-07-15 17:51:17 [INFO]: Updating Nvidia graphics cards database...
WARNING:root:Your graphics card is not in our database. Forcing nvidia-dkms driver installation anyways...
2021-07-15 17:51:22 [WARNING]: Your graphics card is not in our database. Forcing nvidia-dkms driver installation anyways...
WARNING:root:For an older card this command may be needed before reboot: yay -S nvidia-390xx-dkms
2021-07-15 17:51:22 [WARNING]: For an older card this command may be needed before reboot: yay -S nvidia-390xx-dkms
INFO:root:Installing nvidia-dkms driver...
2021-07-15 17:51:22 [INFO]: Installing nvidia-dkms driver...
INFO:root:Removing conflicting packages...
2021-07-15 17:51:22 [INFO]: Removing conflicting packages...
INFO:root:Downloading and installing driver packages, please wait as this may take a few minutes...
2021-07-15 17:51:22 [INFO]: Downloading and installing driver packages, please wait as this may take a few minutes...
INFO:root:Unpatching /usr/share/applications/nvidia-settings.desktop...
2021-07-15 18:02:27 [INFO]: Unpatching /usr/share/applications/nvidia-settings.desktop...
INFO:root:Creating /etc/X11/xorg.conf.d/20-nvidia.conf file...
2021-07-15 18:02:27 [INFO]: Creating /etc/X11/xorg.conf.d/20-nvidia.conf file...
INFO:root:Installation finished. You need to reboot now!
2021-07-15 18:02:27 [INFO]: Installation finished. You need to reboot now!
ephemeron@xpsl501x[~] 18:02:27 Thu Jul 15 $> paru -S nvidia-390xx-dkms
[sudo] password for ephemeron: 
resolving dependencies...
looking for conflicting packages...
:: nvidia-390xx-utils and nvidia-utils are in conflict. Remove nvidia-utils? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nvidia-utils breaks dependency 'nvidia-utils=465.31' required by nvidia-dkms
ephemeron@xpsl501x[~] 18:04:03 Thu Jul 15 $> paru -S nvidia-390xx-dkms
resolving dependencies...
looking for conflicting packages...
:: nvidia-390xx-utils and nvidia-utils are in conflict. Remove nvidia-utils? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: nvidia-390xx-utils and nvidia-utils are in conflict
ephemeron@xpsl501x[~] 18:05:13 Thu Jul 15 $> 
ephemeron@xpsl501x[~] 18:08:59 Thu Jul 15 $> nvidia-installer-dkms -t
2021-07-15 18:09:04 [INFO]: EndeavourOS Nvidia Installer v3.3.8
2021-07-15 18:09:04 [INFO]: All logs will be stored in /tmp/nvidia-installer.log
2021-07-15 18:09:04 [INFO]: Running the installer in testing mode...
2021-07-15 18:09:04 [INFO]: Updating Nvidia graphics cards database...
2021-07-15 18:09:04 [INFO]: nvidia-installer-update-db --tmpdb
2021-07-15 18:09:09 [ERROR]: Couldn't find a driver suitable for your graphics card.
2021-07-15 18:09:09 [ERROR]: If you have an older nvidia card, you may use the --force option to install nvidia-dkms and follow further instructions.
ephemeron@xpsl501x[~] 18:09:09 Thu Jul 15 $> 

After doing all the above, i could no longer even reboot successfully [iirc, EOS would not get past TLP]. I rolled back to an earlier Timeshift snapshot to return to the status prior to these failed dkms commands [ie, once again can now still login to Wayland, but X11 still only gives black screen].

Currently installed [&, afaik, unchanged since my EOS installation]:


When Laptop is logged into X11, Plasma System Settings no longer even recognises it as a laptop display [prior to two days ago, this setting still correctly showed the active laptop screen as present & enabled]. Note; i can only see this UI atm & screencapture it by connecting to laptop with AnyDesk from my other pc:


When in Wayland, this setting continues to show the active laptop screen as present & enabled:


I also have tried editing my grub file to insert nomodeset [did not help], modeset [did not help], then back to original. I did update grub after each edit.

Wrt “4. h-t-t-p-s://” mentioned earlier, after trying & writing-up all the steps above, i re-read #4 then tried its sudo dkms autoinstall, but don’t know how to interpret the underwhelming response:

ephemeron@xpsl501x[~] 20:54:41 Thu Jul 15 $> sudo dkms autoinstall
[sudo] password for ephemeron: 
ephemeron@xpsl501x[~] 20:54:59 Thu Jul 15 $> 

I am now thoroughly confused, & unsure which things to next try. :confused: Guidance would be appreciated please. :crossed_fingers:

Sigh, caught again by the limit of 5 links for noobs.


Fwiw, i’ve also searched the EOS Forum, & read these [but haven’t directly tried using them as once again, i’m uncertain if they’re relevant]:

  1. Black screen on reboot
  2. Black screen when configuring NVidia Driver
  3. New install goes to black screen after GRUB menu
  4. [FAQ] Computer doesn’t boot, boots to a black screen, or stops at a message

Well your nvidia (390xx) driver is not installed

Apparently yes, but as i showed above, i was unable to do so due to conflicting dependencies.

Pls remember… given i did the Timeshift rollback, it’s theoretically now back to only Nouveau [& as my summarised history above showed, it all used to work just fine that way, until last night].

The original problem may be related to some of the Plasma updates.

One thing to try is to use only the Intel graphics driver:

  • make sure you have the USB installer available (to chroot if needed)
  • uninstall all nvidia and nouveau drivers
  • blacklist nouveau
  • reboot

Note that some (usually newer) machines don’t work well with xf86-video-intel, so if that happens, consider uninstalling xf86-video-intel as well.

Have you tried to uninstall them? From what I understood nvidia-dkms is a new driver and nvidia-390xx-dkms is an older driver that supports your graphic card. Just uninstall nvidia-dkms and related stuff and use only 390xx with the correct dependencies

1 Like

Unless you have an absolutely new hardware, make sure you try the LTS kernel. Zen especially can break things from time to time.

Thanks to all “repliers” since I last posted. I’ve only belatedly seen these kind responses, & so not yet had time to attempt the suggestions. However, I should add some additional info I forgot to include in my OP [which now no longer lets me edit it; ah yes, the joys of reverting to the lowest level user in The Discourse Games].


→ during all my initial troubleshooting, I tried with all three installed kernels [& also with each of their recovery modes]; Zen, LTS & ordinary. None made any difference at all, ie, still X11 black screen post-SDDM [yet all the time, continuously successful Wayland logins].

Afaik that already happened via the Timeshift snapshot rollback i described.

I can’t believe this never occurred to me before [but it didn’t]. Once I was blocked from installing it per earlier post, it simply never crossed my mind that the dependency-conflict should logically vanish if I simply did that explicit nvidia-dkms removal. Oh dear… Seems like my TS rollback was rash & silly.

I’m certainly unable to definitively eliminate this possibility, but it would still surprise me, given the timing. Per my thread title, I had six great days & nights of EOS Plasma X11 “niceness”, including various updates, reboots, Suspends & Resumes. Per my OP,

, so atm I remain quite puzzled at this problem “coming out of nowhere” → which of course is a stupid statement; all problems have root-causes, I simply have not been skilful enough to unearth it here.

This thread now contains some apparently worthwhile suggestions for me to try to recover the Laptop’s EOS X11 function, & I’m grateful for the help. That said, I now find myself very unsure it’s actually worth any more of my time & effort…


My stunning Plasma Wayland discoveries

I’ve managed to get my browsers [chromium-based and also furry*] & Thunderbird running in full dedicated W mode, not just Xwayland, + also some other important apps like KeePassXC, via researching the requisite command-line launcher prefixes. As such, finally Clipboard and Selection are both reliable & functional across all these, + with native Plasma apps like Konsole, Kate & Dolphin. Phew.

Most recently today I found some great news re screen-capture in W; whilst shutter remains DOA in W, & ksnip neither minimises to SystemTray nor captures rectangular targets in W, & spectacle does capture rectangular targets in W but cannot minimise to SystemTray, & flameshot is a steaming mess of W dysfunction, joyfully flameshot-git works brilliantly in W… ticks all the boxes… so another major historical W roadblock for me has now fallen away.

It’s true that so far in my testing, Selection copy/paste still does not work in W for CherryTree & LibreOffice, which tbh is annoying … but life-circumstances are now such for me that i no longer need to use these two apps “every day”, thus this is maybe only a pita rather than full-blown PITA.

Another ongoing failure in W is that Latte-Dock, KSmoothDock & Cairo-Dock either fail to run at all, or run so badly that I need to stop them. In all my earlier Plasma W tests / evaluations of the past year or two, this alone was a major turn-off for me [notwithstanding there were so very many other app & plasmashell problems too]. However, I have worked-around this via a bit of lateral thinking; I have added the Folder View widget to my Plasma Panel, & configured it to access my dedicated custom app desktop launcher files … tbh I’d still prefer my good old dock/s, but atm this workaround is serving me well.

* As a bit of a joke, arguably the worst “fault” in my W sessions, Laptop & Tower, is that inexplicably the gorgeous turquoise & purple Firefox Nightly icon renders merely as the standard orange Firefox icon in the Plasma Panel Task Manager in Wayland. Oh well.

This recent mysterious X11 problem has been a major eyeopener for me… since I last tested Plasma Wayland, progress has been nothing short of remarkable. Not only has Wayland been the welcome recent saviour for my Laptop’s EOS, it is now actually so advanced, with so many of the chronic bugs solved, that finally I rate it suitable for my full-time use… in Plasma of both my PCs.

So, as I said, given the remarkable improvement in Plasma Wayland, & despite the puzzle of “spontaneous X11 evaporation” remaining unsolved, atm I feel very far from convinced that I feel like bothering to try much more with it. This is a major but nice surprise to me.

2021-07-15 18:09:09 [ERROR]: Couldn't find a driver suitable for your graphics card.
2021-07-15 18:09:09 [ERROR]: If you have an older nvidia card, you may use the --force option to install nvidia-dkms and follow further instructions.

The 390.xx drivers will & do install.

1 Like

Thanks. Indeed, doing this has now solved the problem [X11 black screen is no more].

This is great, but raises two obvious-to-wonder albeit impossible-to-know questions:

  1. What caused the sudden calamity those four nights back?
  2. How did Laptop’s EOS X11 manage to run fine for 6 days post-installation, sans-nvidia-390xx-dkms?
1 Like

Probably it was using nouveau drivers which broke after some update?

1 Like

It was definitely using Nouveau, per my OP. To satisfy myself again of this, today before installing nvidia-390xx-dkms i checked the pacman logs to confirm [again] that this NV package had never been installed before, in the short life of EOS on this SSD. Thus, logically somehow Nouveau broke four nights ago … but as i have earlier posted, i’d not done any updates prior to the failure. It’s just peculiar.

1 Like

Did you reboot? Certain things only “update” on a reboot, graphics drivers probably fall into that category.

Either way. Glad it’s working.

1 Like

I agree with @Dev0ut that it would have been using the open source Nouveau drivers as shown in your hardware output.


Device-2: NVIDIA GF108M [GeForce GT 420M] vendor: Dell driver: nouveau v: kernel 
           bus-ID: 02:00.0 chip-ID: 10de:0df1 class-ID: 0300 

I don’t understand the meaning behind your post, sorry. I already know this fact… my OP made this explicitly clear:

Furthermore, my recent post revalidated it:

With respect, my question right from the beginning of this thread was not something like “I wonder what video driver I originally installed?”. It was [paraphrasing] “why did my Nouveau driver work great for 6 days, then suddenly go kaput?”.

The fact that I have now recently had to install this nvidia-390xx-dkms driver to dispel the darkness, ha, represents a change from my original installation specs, not a return to it. Logically I should not have needed to take this recent action, ie, had the Nouveau not spontaneously lunched itself five nights ago without me updating anything. I accept, however, that life is full of unsolved mysteries, & this is likely just one more.

Thanks everyone in this thread for helping me.

Devout said probably it was using Nouveau drivers which broke after some update. I just reiterated that yes that is the case because your hardware output showed that.

No disrespect intended. I had already posted that the 390.xx drivers can & will be installed which you have done. I don’t know the reason why the black screen happened other than the possibility that an updated borked X11.

Sorry i didn’t mean to offend you if i did. That wasn’t my intention.

1 Like