Bios Screen/Boot menu not showing up

In the past i had some issues with booting EndevourOS after an update (same as in this thread).

After Updating the motherboard Bios (ASRock B450M Pro4) and disabling CSM everything works fine, exept that there is no Bios Boot Screen/Boot Menu. The System boots directly into EndevourOS, and the monitor stays black until LightDM shows up. I use systemd-boot.


See what value you have for timeout in /efi/loader/loader.conf.

You may need to change/set it in order for the systemd-boot menu to show up, if I have understood your issue correctly.

Thank you, will try that.

The strange thing is that there is really no boot screen nor boot messages at all. the monitor stays off the hole boot process. Even if i switch it on, only blank screen till LightDM shows up.

Look into /etc/kernel/cmdline.

If quiet is among kernel boot parameters, remove it and run sudo reinstall-kernels afterward.

So you mean the BIOS menu (before systemd-boot) does not show up?
Can you see it if you press some function key e.g. F2 a few times right after turning the machine on?

Yes. Monitor stays off till LightDM comes up.

tried that, but with no luck :frowning:

There may be other function keys, depending on your machine.

Yes, tried all off them ( i think :slight_smile: ). Will test it later again.

I guess you made sure to update the correct mb bios?

I don’t have Asrock mb so I don’t know how they manage mb updates.

loader.conf says timeout 5

default 27edbaa2252649f3951cd0bdaddb5bd3*
timeout 5
console-mode auto
reboot-for-bitlocker 1

no ‘quiet’ boot parameter

nvidia-drm.modeset=1 nvme_load=YES nowatchdog rw root=UUID=f148c514-2051-4d0e-a386-e89c69ab0215 resume=UUID=3460a484-2057-4100-8a55-8725d7f80ad3

Yes. Flashed Ver. 5.70
Not the newest one, but the other 2 are in Beta.

1 Like

What does efbootmgr show?

Edit: Maybe you could clear the entries and let it recreate on next boot.

BootCurrent: 0004
Timeout: 1 seconds
BootOrder: 0004,0005
Boot0004* Linux Boot Manager	HD(1,GPT,399910f3-6b11-4e94-8934-f03607257e59,0x1000,0x1f4000)/\EFI\SYSTEMD\SYSTEMD-BOOTX64.EFI
Boot0005* UEFI OS	HD(1,GPT,399910f3-6b11-4e94-8934-f03607257e59,0x1000,0x1f4000)/\EFI\BOOT\BOOTX64.EFI0000424f

I thought maybe it might be full of entries but looks like not.

There is a Restart to UEFI Tool from ASRock, but only for Windows :slight_smile:

I remember that i turned on fast boot in the Bios. That will be the cause :grimacing:


found this for linux:

systemctl reboot --firmware-setup

will try that later.

After reboot system stays black for 10-20 sec. and than boots direct to EndeavourOS Login.
No UEFI at all :frowning:

If it were me i would clear the CMOS on the motherboard and try.

Sorry for the late reply. After clearing CMOS i could enter UEFI Settings. Fast boot is off, but after i disabled CSM (without disabling CSM System doesn’t boot) the boot behavior is the same. No Boot screen :frowning:

That makes sense. CSM is for legacy BIOS and EOS (if I remember correctly) defaults to UEFI, so if your motherboard supports it, CSM should be disabled. That board is certainly new enough to not require legacy BIOS mode.

Edit: If you’ve never updated ASRock BIOS before, doing so resets all BIOS settings to stock after the update. This includes fastboot, secureboot, and AHCI settings.

I have an ASRock in one of my home servers (albeit an Intel based board) and when I updated the BIOS I had to disable secureboot afterward.

Is TPM disabled? There are some known issues with having TPM enabled on Linux.

ASRock also states that CMOS should not be cleared after updating BIOS until the system has been fully rebooted and then shutdown.

Another option for entering UEFI on ASRock motherboards is using Del key. I find on my ASRock board I must select Del multiple times in a row for it to recognize and I must begin doing so immediately upon reboot or it is not recognized.

Do you have auto login enabled for EOS?

Edit 2: Which kernel do you have installed? Do you have both installed? When I boot my ASRock board, it gives me the option to select which kernel I want to use (I have both installed), but it also gives me an option to enter UEFI settings as well.

Edit 3:

I should have asked sooner. What do you refer to by “boot screen”? And what do you need it for?

My apologies, I did not mean to flag your reply. I accidentally clicked instead of quoting you. :man_facepalming:t2:

With no boot screen i mean no ASRock Logo and no choice to select a kernel. No boot messages at all.
The monitor istays black until LightDM shows up.

1 Like

Ok, if you’re confident fastboot is disabled, have you checked your kernel boot parameters?

If it is set to "quiet" then the boot logo would not be displayed. I don’t recall if this exists in the ASRock UEFI settings, but many motherboard manufacturers have an option in settings where logo display during boot can be disabled. So there are two additional things for you to check.