BCM43143 usb wifi card issues

Hello! I’m not sure if this is a bug, but when I went to try to install endeavour os, I realized that my WiFi card was not working. I knew that the card was a Broadcom card supported by the included brcmfmac driver so I decided to try running modprobe brcmfmac and then it worked. Shouldn’t that module be loaded upon booting the live system instead of having me load it manually?

1 Like

It’s probably loading the broadcom-wl but if you have it working then shouldn’t be a problem correcting that after install.

1 Like

I actually can’t get it to load on reboot. If I check lsmod b43, wl and bcrmfmac are all not loaded. So it seems I have modprobe bcrmfmac every reboot?

I would try blacklisting broadcom-wl?

1 Like

I tried adding blacklist wl to /etc/modprobe.d/blacklist.conf and it didn’t do anything :confused:

I take it you rebooted to ascertain that?

Did you try blacklisting both the b43 and the broadcom-wl?

Edit: Try this and see.

I added

blacklist wl
blacklist b43

To /etc/modprobe.d/blacklist.conf then rebooted

No WiFi yet

Take out the broadcom-wl and leave the b43 blacklisted

Unfortunately that did not fix it. Do you think it’s a kernel issue not recognizing the card for some reason? It’s worked on other distros but none of them have been kernel 5.8.

This is one of those chips that are not fully supported. Why don’t you try installing the broadcom-wl-dkms version and see if it works.

It works on every other distro. It also works if I run modprobe brcmfmac the issue is the module doesn’t load by itself…
In fact it’s the official raspberry pi dongle so I’d hope it’d be supported.

Okay… it may require the b43-firmware. This chip BCM43143 uses the brcmfmac which should automatically load from the kernel but it always seems to be a problem.

Here is the info. So read through it and you may have to try the firmware.


Thanks. It does work when I modprobe brcmfmac though so maybe I’ll have to resort to a udev rule… I don’t understand what’s causing the issue though.

The 5.8.2 kernel is there right now.

If I plug in the WiFi card, it doesn’t work
If I run modprobe brcmfmac it works
If I unplug it and plug it in it still works
If I reboot, it doesn’t work until I run modprobe brcmfmac again

I’m confused because loading and unloading modules like that should be handled by the kernel.

So this is a usb wifi?

With the usb wifi plugged in can you post the following.

lspci -vnn -d 14e4:

and also


First command does nothing

I think you are looking for 0a5c:bd1e Broadcom Corp. BCM43143 802.11bgn (1x1) Wireless Adapter

14e4 from what I remember is the BCM4360 wifi card which uses wl

I tried adding it to the systemd modules load service and I got module brcmfmac is deny-listed is it possible it is blacklisted somewhere by default?