Bang & Olufsen speakers no sound

Hello, I have had an issue with no audio from my speakers for awhile now (on all tested linux distros). I solve it by simply utilizing a bluetooth speaker but would like to finally tackle and hopefully solve this issue for my own edification. I have an older HP all-in-one with internal Bang & Olufsen speakers. When I got this thing it had Win10 on it, the sound worked perfectly. When I got it home I put Debian 8 on it (it was years ago). I noticed there was no sound. I played around with it for sometime trying to figure out the issue without luck. I had searched several forums and SO and simply came to the conclusion that there was simply no fix for this issue and started using a bluetooth speaker. I recently switched to Endeavor to give Arch a spin. Perhaps someone more knowledgeable than myself can assist me in this journey.

Thanks!

inxi -Fxxxz --no-host

System:
  Kernel: 5.15.32-1-lts arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    Console: pty pts/2 wm: kwin_x11 DM: SDDM Distro: EndeavourOS
    base: Arch Linux
Machine:
  Type: Desktop Mobo: HP model: 2B3E v: 1.05 serial: <filter> UEFI: AMI
    v: A0.10 date: 03/29/2016
CPU:
  Info: quad core model: Intel Core i5-6400T bits: 64 type: MCP
    smt: <unsupported> arch: Skylake-S rev: 3 cache: L1: 256 KiB L2: 1024 KiB
    L3: 6 MiB
  Speed (MHz): avg: 2692 high: 2719 min/max: 800/2800 volts: 0.9 V
    ext-clock: 100 MHz cores: 1: 2666 2: 2667 3: 2719 4: 2716 bogomips: 17599
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel HD Graphics 530 vendor: Hewlett-Packard driver: i915
    v: kernel ports: active: HDMI-A-1,eDP-1 empty: none bus-ID: 00:02.0
    chip-ID: 8086:1912 class-ID: 0300
  Device-2: Realtek HP High Definition 1MP Webcam type: USB
    driver: uvcvideo bus-ID: 1-10:5 chip-ID: 0bda:57ce class-ID: 0e02
    serial: <filter>
  Display: server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
    loaded: intel unloaded: modesetting alternate: fbdev,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.88x11.22")
    s-diag: 1052mm (41.43")
  Monitor-1: HDMI-A-1 mapped: HDMI1 pos: right model: HP 24w
    serial: <filter> res: 1920x1080 hz: 60 dpi: 92
    size: 530x300mm (20.87x11.81") diag: 604mm (23.8") modes: max: 1920x1080
    min: 720x400
  Monitor-2: eDP-1 mapped: eDP1 pos: primary,left model: HP All-in-One
    serial: <filter> res: 1920x1080 hz: 60 dpi: 81
    size: 600x340mm (23.62x13.39") diag: 685mm (27") modes: 1920x1080
  OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 22.0.0
    direct render: Yes
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
    chip-ID: 8086:a170 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.32-1-lts running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.49 running: yes
Network:
  Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel pcie:
    speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:095a class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: speed: 2.5 GT/s
    lanes: 1 port: e000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  IF-ID-1: virbr0 state: up speed: 10 Mbps duplex: unknown mac: <filter>
  IF-ID-2: vnet1 state: unknown speed: 10 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-3:3 chip-ID: 8087:0a2a class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
Drives:
  Local Storage: total: 931.51 GiB used: 162.3 GiB (17.4%)
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630
    size: 931.51 GiB speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
    rev: A3T0 scheme: GPT
Partition:
  ID-1: / size: 915.53 GiB used: 162.3 GiB (17.7%) fs: ext4 dev: /dev/sda2
  ID-2: /boot/efi size: 299.4 MiB used: 296 KiB (0.1%) fs: vfat
    dev: /dev/sda1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 217 Uptime: 14h 12m wakeups: 0 Memory: 11.56 GiB
  used: 7.58 GiB (65.5%) Init: systemd v: 250 Compilers: gcc: 11.2.0
  clang: 13.0.1 Packages: pacman: 1129 Shell: Bash (sudo) v: 5.1.16
  running-in: konsole inxi: 3.3.14

Link to above: https://clbin.com/BLdzk

Hello @N1nj4
What is the exact model of your system? It’s a desktop? All in one? Envy?

It is an HP Envy all in one desktop.

I wonder if it’s the same issue as the Envy laptop? I wouldn’t be surprised. If that’s that’s the case and I have no way of knowing.

Maybe you can post some info here.

aplay -l
lspci -nnk | grep -A2 Audio

Edit: Have you checked alsa to make sure it’s not muted? On the laptops the pinouts are incorrect and have to be reassigned.

alsamixer

My employer gave me an hp envy laptop with windoze 10 as the work computer (or as I like to call it, dy, since that’s how I see the letters on the lid).

Good Lord, that thing SUCKS! I’ve never seen such a piece of utter :poop: pretending to be a computer…

Anyway, no point ranting about it. But I am much more productive on my 2013 hp ProBook running Arch.

I’m sorry…i cant read that! :rofl:

1 Like

It’s for the best! :slight_smile:

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
lspci -nnk | grep -A2 Audio
00:1f.3 Audio device [0403]: Intel Corporation 100 Series/C230 Series Chipset Family HD Audio Controller [8086:a170] (rev 31)
        DeviceName: Onboard Audio
        Subsystem: Hewlett-Packard Company Device [103c:2b3e]
        Kernel driver in use: snd_hda_intel

I have checked alsamixer, unfortunately it is not muted. This was one of the first things I try when booting Endeavour (as I have with every linux distro I have used on this thing :frowning:)

I only see audio on the HDMI.

What does this show?

cat /proc/asound/cards
cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xdf320000 irq 131

Could it possible be an issue with having dual monitors? I use the all-in-one (of course) and a secondary HP monitor that has no audio.

Well it’s in there. I’m not sure if it’s the same issue as the Envy laptop. You have to install alsa-tools and use hdajackretask to change the pin outs. Not sure?

What does it show for the audio playback device on KDE if you click on the speaker icon. then on the hamburger menu, configure audio devices, and what does it show for playback devices under port and profile?

Edit: Should look like this.





Probably included more than I should but perhaps one of them will help? :stuck_out_tongue:

Have you tried the different outputs and settings. Not including headphones.

I have yes, I had even tried messing with the pin outs via hdajackretask but the only codec is Intel Skylake HDMI. I’ll keep on diggin, one day perhaps I can get it :smiley:

P.S thanks for the help!

Going through all the set ups for audio related issues is the worst.

Oh yes. My nightmare for the past few years :smiley: I have not posted the issue to a forum due to there being so many about this type of issue with HPs. This thing is about to be donated once I can get a new machine for my home office and hopefully I won’t have to worry about it (this particular issue) ever again :crossed_fingers:

Which pinouts did you reassign. Everything points to that but it’s only listed for Envy laptops.

Edit:

optional: 0x0d -> Override -> Not connected
0x0f -> Override -> Internal Speaker
0x10 -> Override -> Internal Speaker (LFE)