Baloo eating resources, won't stop, purge, or anything

Hi everyone,

After today’s update, baloo is once again acting up, taking up all CPU resources.

I tried balooctl disable, balooctl suspend, balooctl purge and the status says it isn’t running but top shows it running.

I can’t work on my computer as it slowed down to a crawl. Search file is turned off.

Why is baloo such a pain to deal with? I’m thinking of ditching Plasma for another DE.

I added this to ~/.config/baloofilerc and it fixed everything permanently.

first run=false
only basic indexing=true

The problem with baloo is when you mess with it, you force it to index more.

balooctl purge basically tells baloo to start over and re-index everything.


Try disabling it by unchecking Enable File Search in System settings under Search > File search .

Also balooctl monitor can be used to check what it is indexing.

Thanks, already done. This reboot worked but I can’t find the config file. Dolphin takes too long to search. Wow, what a pain!

On it now. Do you know where the file is? I turned off the indexing so Dolphin is long in the search :slight_smile:

It sounds like there are no baloofilerc files. I see `~/.config/baloofile

I don’t understand why Baloo is such a problem for many people. Quite apart from the sense, if it has come to rest again after the initial indexing, I no longer notice anything about it. Well, I could also disable it, but it does not bother me in any way. And that, although I have my data on a slow 6 TB HDD with only 5400 rpm. System is on SSD though.

You’re lucky, it’s not my case. 95% it behaves well. After today’s update, it locked 97% of CPU and RAM for over an hour. It’s ridiculous especially when so many people have such recurring problems with it.

Perhaps the config file was removed when you disabled it?

Ah, crap, yes. I will reenable it and add your:

first run=false
only basic indexing=true

I need to find where it hides first. If I start with baloo again, I can kiss my computer goodbye for an hour or so. Or I could let it run all night long.

Thanks Dalto

If you deleted the index, you probably don’t want to set first run=false

The initial index will take some time but it might not be as bad as before because it is only indexing file names, not the entire contents of the file.

1 Like

I guess I’ll re-enable it and let it run its course. Thanks again for your paience.

The important thing is to make sure you have only basic indexing=true as that is what keeps it from indexing contents

1 Like

Will do it now. That damn thing has been running 34 hours straight and still locks up my resources. What a piece of ^$#*&@%!!

Can you tell me where~/.config/baloofilerc is? I turned on show hidden file and still can’t see it. Thanks

Enable hidden files and look in your home folder.

1 Like

~ is your home directory. So there should be a .config in your home directory.

Umm…if you didn’t make the change in baloofilerc, there is no reason to let it run. 34 hours isn’t really a long time if you have a lot of files. It has to read and index every word of every file.

That is why you make that change in baloofilerc, so it only indexes file names.

1 Like

Thanks, I can find it now. Cheers!

1 Like

After you make that change to the file, you should suspend and purge. After making sure it is really stopped(which may take a few minutes) then start it again. Now it should be go much faster since it is only indexing file names. You should be able to see this with balooctl monitor

1 Like

Thanks. I’m letting run its course, however long it does. Then I’ll look for the config file. can’t find it now for some reason. After that, I’ll follow your instructions.

I really appreciate your help. I went on the wikis but didn’t find the answer.

OK but after you change the config file you are going to delete the index you are creating…