Auto mount drives without password kde?

Just swapped from manjaro, over there It allowed me to automount my drives on boot without a password, here it asks me for one everytime, anyway to stop it?


Hi & welcome to the forum!

I don’t know if KDE provides an option to do this, but if not, you can accomplish this by creating an entry in fstab & if your drives require a password you can store credentials in a file somewhere and include it in your fstab entry.

In KDE it is easy (but well hidden, as always :sweat_smile:):

  1. Settings → Removable storage → Removable devices

  2. Enable:
    :ballot_box_with_check: Enable automatic mounting of removable media
    :ballot_box_with_check: Automatically mount all removable media at login
    :ballot_box_with_check: Automatically mount all removable media when attached

  3. Apply

  4. Reboot

P.S. Welcome! :partying_face:


For automounting non removable media at boot time just edit /etc/fstab and set the proper permissions as always.


New to mounting on linux, im using kde partition manger, it wants a mount path, does it matter what I set it to?

You can create a new mount point for a non removable drive. For example I have my music files stored on a drive mounted at /tunes, whereas my movies are just stored at /mnt which already existed.

The Arch Wiki should get you sorted! :grin:

1 Like

Thanks, just mounted it as /windows for now. Still a tad confused about how something mounted at dev/nvme can also be mounted at /windows. Or why my other two internal drives are mounted at /run/media. Linux directories are a bit confusing.

I’m not sure about the dev/nvme thing but /run/media is usually used for external drives. If you want to mount internal drives they should be mounted under /mnt or better still under their own mount points. After defining those mount points you need to update your fstab as previously mentioned.

How do I setup this in xfce?

New to Linux :slight_smile:

Currently, I have a second drive which I formatted using Gparted and every boot I need to enter the password to access the files which is annoying.

Also, what command to use for setting up proper permission to read and write.

Thanks in advance.

Turns out that was a mistake, threw arch into a menu unable to boot, had to remove it from my fstab with nano to get back in, wonder what I did wrong.

Please create a new thread with the specifics of your issue to get proper attention and relevant assistance.

With your drives plugged in, please run the following command and post the output. Copy the output as text, paste it into your reply, highlight it and click </> to format:

lsblk -fs

Also would be good to know what you added to /etc/fstab which didn’t work.

If you just want to mount your partitions on-demand in the file manager (and not automatically mounted at boot via fstab) please have a look at the following and try to see if that will resolve your issue:

Sounds good. Will try that.


1 Like

Your device isn’t mounted at /dev/nvme*. That is the device file.


December 14th, Endeavour Atlantis. This doesn’t work anymore. It was my first try, since like OP, coming from Manjaro and using that as solution worked.
On Endeavour still asks for a root password for each partition/device (so in my case /home and then my storage drive).

1 Like

Hi Keybreak, it looks like something may have broken with this. I’ve got 4 internal drives and none of them will auto mount with those options selected. Even if they are selected manually in that settings option they still require a password no matter what.

I’m running the latest EndevourOS with KDE btw.

Hi! :upside_down_face:

Sorry, i’m not sure why, for me still works… :man_shrugging:

Hi, no worries. I’ve clearly done something to my system then lol.

I’m coming a bit late but there’s a great tutorial that was made on this forum :

It’s pretty straightforward and easy to do.