Audio stuttering with Pipewire

Sometimes audio stutters and is choppy when multiple audio sources are playing. For example I could be playing a game like OpenSpades and I open cmus (music player) and then the OpenSpades audio stutters, when I pause cmus or close it it’s fixed. But reopening cmus makes it happen again.
This doesn’t happen everytime I have both open but it happens frequently and everyday.
I don’t think this was always a problem and I do know that there has been pipewire updates and some packages have been replaced so I don’t know how to fix it.
FYI I have never configured pipewire or anything, it’s as it was like a fresh install of Endeavour

I am also using the Zen kernel and this is a problem regardless of output, headphones or no headphones.

Do you have this problem with the normal Kernel or the LTS Kernel?

I haven’t tested it on those kernels as I’ve been using the zen kernel for a while and it’s only been an issue in the last few days.

It is a recommended practice to have LTS kernel as a backup in these sorts of cases as these issues generally get resolved in a few day. Then you can go back to Zen Kernel.

Also do you have snapshots of your system when it was working fine? You can go back to check if the updates are the problem here.

1 Like

I have the LTS kernel on my system as well as frequent Timeshift snapshots yeah.
I can’t seem to find anyone else with this issue or at this time so I don’t know if it’s just me

After the updates my audio was going tick tick tick tick when playing a video. I rebooted again and it sorted itself out on plasma.

Hm, rebooting hasn’t fixed it for me sadly.
Sometimes when it happens I’ll get this error in cmus
cmus: Error: an error occured while initializing MPRIS: Invalid argument. MPRIS will be disabled. cmus: Press <enter> to continue.

MPRIS is a plugin for MPV. Do you have that installed?

MPRIS seems to be separate. That’s just a plugin allowing MPRIS support for mpv.
When I edit /usr/share/pipewire/pipewire.conf and save, when I reboot it goes back to the default settings and my changes are no longer saved.


I’m having the issue right now and here’s a screenshot of pw-top as its happening

I was just asking if you had it installed because obviously somewhere in the process it’s trying to initialize it?

Right now I’m not getting any error for MPRIS so I’m not sure. I think I can disable it in cmus so I’ll see if that fixes anything

The audio stuttering still continues with MPRIS disabled.
This also only seems to be a problem with Audacious/CMUS, Playing a video (with audio) in Brave while playing a game doesn’t cause stuttering

I haven’t tried any audio on an audio player? Are you playing mp3 or something?

.flac, .m4a and .opus

Could you try downloading Audacious and trying it with an audio file?

I could but i’ll need to get an audio file from somewhere?

Edit: Okay Audacious is installed.

You can just use youtube-dl and get an audio file like that
yt -x -f bestaudio/best' -o ~/Downloads/audio-file (ENTER LINK HERE)

Have a link for me?

Edit: It will be quicker!