Asus notebook reboots 1 minute after returning from deep sleep

I have EndeavourOS installed on my Asus TUF Dash F15 and it’s been working mostly flawlessly except for the fact that, when the computer is suspended, it still consumes a lot of battery. After closing the lid, I have about 8 hours or so before the battery runs out. So I tried changing the sleep mode from s2idle (default) to deep, and it worked a lot better. After about 8 hours I saw like a 10% battery drain (still a lot in my opinion, but considerably better). The only problem is that, after returning from deep sleep, I have about 55 seconds before the screen goes black and the computer reboots without any warnings. I’m not an expert in Linux systems, so let me know what information I can give in order to help debug this. Thanks in advance!

  1. Is your BIOS up to date?
  2. Some people mention configure disk in bios from raid to ahci , other mention disconnect from network before sleep
  3. You are on latest kernel?

Googling this will probbaly give you more options, as there are many threads about it - both high drain in s2idle, and rebots after coming from deep sleep.

You can still post output from inxi -Fz

Also - do you dual boot with Win? If yes, Disable Fast Startup and disable hibernation → arch wiki

It would be worth reviewing the information in the Arch Wiki about Asus laptops.

I’m not sure it will help with your suspend power draw, but you might consider installing the Asus tools, giving you additional control over your laptops GPU, fans, battery, etc. See ASUS Linux:

Thanks for the reply!

  1. My BIOS is up to date.
  2. Disconnecting network before sleep didn’t work. I will try changing the disk configuration and post if I find any differences.
  3. The kernel is up to date. I’m using the latest linux-g14 kernel (6.9.2-arch1-1.1-g14) that comes from the g14 repo using pacman, but this also happens with the main kernel (6.9.2.arch1-1).

I did some googling but none of the answers I found solved the problem, even the solutions that I found in the arch wiki.

The following is the output from inxi -Fz:

╰─$ inxi -Fz
  Kernel: 6.9.2-arch1-1.1-g14 arch: x86_64 bits: 64
  Desktop: KDE Plasma v: 6.0.5 Distro: EndeavourOS
  Type: Laptop System: ASUSTeK product: ASUS TUF Dash F15 FX517ZC_FX517ZC
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: FX517ZC v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: FX517ZC.317 date: 05/03/2023
  ID-1: BAT1 charge: 38.9 Wh (58.9%) condition: 66.0/75.8 Wh (87.0%)
    volts: 14.8 min: 15.9
  Info: 10-core (6-mt/4-st) model: 12th Gen Intel Core i7-12650H bits: 64
    type: MST AMCP cache: L2: 9.5 MiB
  Speed (MHz): avg: 823 min/max: 400/4600:4700:3500 cores: 1: 400 2: 400
    3: 400 4: 400 5: 400 6: 3715 7: 400 8: 400 9: 400 10: 400 11: 2653 12: 1123
    13: 400 14: 400 15: 882 16: 400
  Device-1: Intel Alder Lake-P GT1 [UHD Graphics] driver: i915 v: kernel
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Mobile] driver: nvidia v: 550.78
  Device-3: Sonix USB2.0 HD UVC WebCam driver: uvcvideo type: USB
  Display: wayland server: v: with: Xwayland v: 24.1.0
    compositor: kwin_wayland driver: X: loaded: modesetting,nvidia dri: iris
    gpu: i915,nvidia resolution: 1707x960
  API: EGL v: 1.5 drivers: iris,nvidia,swrast
    platforms: gbm,wayland,x11,surfaceless,device
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.1.0-arch1.1
    renderer: Mesa Intel Graphics (ADL GT2)
  API: Vulkan v: 1.3.279 drivers: nvidia surfaces: xcb,xlib,wayland
  Device-1: Intel Alder Lake PCH-P High Definition Audio driver: snd_hda_intel
  Device-2: NVIDIA driver: snd_hda_intel
  Device-3: ASUSTek C-Media Audio driver: hid-generic,snd-usb-audio,usbhid
    type: USB
  API: ALSA v: k6.9.2-arch1-1.1-g14 status: kernel-api
  Server-1: PipeWire v: 1.0.7 status: active
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi
  IF: wlan0 state: up mac: <filter>
  Device-2: Intel Ethernet I219-LM driver: e1000e
  IF: eno2 state: down mac: <filter>
  IF-ID-1: docker0 state: down mac: <filter>
  Device-1: Intel AX201 Bluetooth driver: btusb type: USB
  Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: N/A
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
  Local Storage: total: 1.82 TiB used: 445.78 GiB (23.9%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WD Green SN350 2TB
    size: 1.82 TiB
  ID-1: / size: 872.78 GiB used: 445.75 GiB (51.1%) fs: ext4
    dev: /dev/nvme0n1p7
  ID-2: /boot/efi size: 256 MiB used: 27.8 MiB (10.8%) fs: vfat
    dev: /dev/nvme0n1p1
  Alert: No swap data was found.
  System Temperatures: cpu: 37.0 C mobo: N/A
  Fan Speeds (rpm): cpu: 2700
  Memory: total: 64 GiB note: est. available: 62.43 GiB used: 3.51 GiB (5.6%)
  Processes: 339 Uptime: 3m Shell: Zsh inxi: 3.3.34

Finally, I do have Windows installed, but I never use it. Fast boot and hibernation are disabled.

Thanks for the reply!

I am using the linux-g14 kernel recommended for Asus laptops as well as the Asus tools. None of them have really helped with the power draw unfortunately.

1 Like

probably not a solution but I got a similar problem with some of the new laptops at work, seems that started being an issue around 2022. No solution for me except I sold that laptop as that sleep issue was a no go. Hope there is a solution you can find for the Asus.

my conclusion

edit: is it possible you enabled hibernate mode? why it reboots…

I’ve checked your post, but I was unable to find a suitable solution. The battery is still drained quite considerably during s2idle.

No, I can hibernate correctly, the problem is just when trying to suspend using mem_sleep=deep.

One thing I’ve noticed recently is that, after returning from deep sleep, during that 55 second window before the system reboots, even though everything seems to be working normally, I’ve noticed some things that don’t work. For example, the Fn+ commands (volume control, brightness control, external screen). The only one that seems to work is mute/unmute sound. I don’t know if this could have any significance.

Edit: Failing keys are just the screen-related ones.
Edit 2: Actually, all the Fn+ commands fail except mute/unmute sound.

While searching for a solution, I found this post:

I disabled Intel VMD Controller from the BIOS and the battery drain in s2idle improved significantly (around 10% overnight). It’s still not great, but at least I should be able to close the lid after work and still have battery left when I arrive at work the next day.

One minor issue I did find with this is that, for some reason, after sleeping for about one hour, the keyboard would be really slow after resume (had to wait around 0.5s between each key). Meaning, after I press each key, it would appear immediately on the screen, but if I didn’t wait a moment before pressing a second key, that second key wouldn’t appear. The only solution I found was to create a new udev rule:


ACTION=="add", SUBSYSTEM=="input", ATTRS{phys}=="isa0060/serio0/input0", TEST=="power/control", ATTR{power/control}="on"

This causes the keyboard to never be powered off, thus avoiding any power issues.

Have you also tested with setting HibernateMode to shutdown?

I haven’t, I can try, but would that make any difference? Hibernation works fine, I think the issue may be in some of the differences between suspend to idle and deep sleep.


It may not make a difference, I spent about a month troubleshooting a similar sleep issue on my Surface last year. From what I remember, I had to configure the lid close function to hibernate while setting hibernate mode to shutdown. This was the only way to not drain battery while it wasn’t in use. Sleep hooks for systemd were also configured.

This rule for not powering Keyboard off, is a nice solution. But what I would try to avoid that, is some rule to powercycle keyboard or load/unload driver once computer comes back from sleep.

Just risky, cause you may end up with frozen keyboard. I would do it anyway :smiley: