Arch Gnome/KDE on Yoga Slim 7 AMD Ryzen: Issues and Solutions

During the processes of setting up Arch on my new Yoga Slim 7 AMD Ryzen 7 4800U laptop, I encountered a few issuesHere I summarize them and my current solutions. Hope it can help others.

Sleep problem

This is so far the biggest issue. It’s caused by the default sleep mode (Modern Standby) for the laptop. The option to change the sleep mode is locked in the current BIOS. So you need to find a way to unlock it.

Below is a method from reddit post:

Once unlocked, you can reboot your system and change the sleep mode to S3 in BIOS.

Another way that might work if you can’t unlock the BIOS:

Add mem_sleep_default=deep to grub boot options:

GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet mem_sleep_default=deep"

Backlight warning

If you type systemctl --failed in terminal, you can see warning message as below:

● systemd-backlight@backlight:acpi_video0.service loaded failed failed Load/Save Screen Backlight Brightness of backlight:acpi_video0

On Manjaro you may see 2 lines of warning messages.

● systemd-backlight@backlight:acpi_video0.service loaded failed failed Load/Save Screen Backlight Brightness of backlight:acpi_video0
● systemd-backlight@backlight:amdgpu_bl0.service  loaded failed failed Load/Save Screen Backlight Brightness of backlight:amdgpu_bl0 

They have no harm and you can just mask them:

sudo systemctl mask systemd-backlight@backlight:acpi_video0.service
sudo systemctl mask systemd-backlight@backlight:amdgpu_bl0.service

Gnome black screen on boot

After updating to the latest system software, Arch Gnome (same to Manjaro) will always boot into black screen. I have a temporary workaround:

Type Ctrl + Alt + F2 to switch to tty2, then type Ctrl + Alt + F1 to switch back. The login screen will display normally.

This happens on both Kernel 5.7 and 5.8. I haven’t found reason and solution yet. Maybe someone can help.

KDE doesn’t have this problem.

Edit:

Add MODULES=(amdgpu radeon) to /etc/mkinitcpio.conf can fix the blank boot screen issue.

Howdy

The IR camera works great under Windows 10, but cannot work properly under Linux. Howdy can be installed without issue, but I can’t find a way to turn on the red-light part of the IR camera, only the white-light part works.

Edit:

I’ve managed to get the IR camera working properly under Arch and Manjaro. So now all the hardware works great.

7 Likes

Add MODULES=(amdgpu radeon) to /etc/mkinitcpio.conf can fix the blank boot screen issue.

1 Like

Just an FYI, you might want to post this in the correct forum. It’s fine and maybe a mod will be able to move it, but you might get more responses here.

I actually don’t know which forum is the suitable one. Maybe a mod can help. :pray:t2:

1 Like

Thanks for posting and sharing your experience! I’ll be following your posts since I will be getting one of these machines as well sometime soon.

I have moved your post in the hardware and kernel category :wink:

2 Likes

Thanks!!

Thanks @bob418 for the information on the Yoga Slim 7. I’m considering this laptop, just like to check how it has been working for you so far, everything OK or have you found any issues? I have read some comments about coil while, have you experienced that problem?

Have you got the IR camera working, maybe some improvements with Kernel 5.9?

This laptop is best Window 10 laptop I’ve used. But I still prefer Linux especially Manjaro/EndeavourOS/Arch distros. Right now I’m running Manjaro KDE with Kernel 5.8 as main system. It has great performance. I also have a partition with Cinnamon and Kernel 5.9, but its performance is kind of sluggish. I’m not sure if Cinnamon or Kernel 5.9 causes problem. Kernel 5.9 also breaks bluetooth. I think I’ll wait a while to use it for my main KDE setup.

1 Like

I don’t know why Cinnamon would be sluggish. I run Cinnamon and i do not find that at all. Cinnamon is one of my favorite desktops. The reason is because it rarely has issues with updates. I also run Xfce and KDE. I run all three on the same system but all are on separate drives. This is a desktop with Ryzen 7.

Screenshot from 2020-10-22 01-49-43

I don’t know. maybe it’s due to VirtualBox which might not be optimized with Kernel 5.9.

Now I can confirm its due to VirtualBox (6.1.14). After updating to VirtualBox 6.1.16, the performance with Kernel 5.9 on my laptop is back to normal.

1 Like

I just got the same laptop and have installed EnOS KDE as dual boot with Windows, most things seem to be working out of the box… Concerning unlocking the bios as described in the Reddit post above, is there an equivalent application as “RWEveryhing” for Linux?

I don’t see much risk with the tool. Anyway after changing BIOS, I reformatted my 2 SSD drives and installed Win10 and 3 Linux distros. A few days ago I applied the new version of BIOS, and my BIOS change is not affected.

I did the hack with RWEverything and everything looks OK, BIOS is unlocked, S3 is enabled and sleep also works as far as I can see (led next to power button is flashing slowly). “dmesg” reports “supports S0 S3 S4 S5”.

But, I run into another issue, the touchpad does not work after resume from sleep, as discussed in detail on the Manjaro forum:

@bob418 Have you seen this problem as well? I haven’t tried the workaround described in the forum post, but it would be interesting to understand what is the root cause of the problem… But troubleshooting this a bit beyond my current knowledge of the inner workings of Linux :thinking:

I don’t know the root cause. But you can add a shortcut to toggle touchpad. I use Meta (Windows) + F9 for that purpose.