Anyone successfully got a brother printer working?

I tried to follow the instructions here:
https://wiki.archlinux.org/index.php/Packaging_Brother_printer_drivers

made a pacman installable package by following the instructions for the .deb. ( both lpr and cups wrapper ).
Unfortunately my CUPS still can’t see my printer.

I have used 2 different models of brother laser printers with Arch, both running impeccably.
It seems to me you went the convoluted way about it. Aur packs specific drivers for brother printers, no need to fuss around with .deb packages.

Check the Arch wiki to identify the driver you need.
https://wiki.archlinux.org/index.php/CUPS/Printer-specific_problems#Brother

You could find this question, similar to yours, helpful:

I’ve already read that arch wiki page and unfortunately mine isn’t covered by any existing drivers ( MFC-T800W ).

I’ve tried adding through ipp and through the drivers as stated above and they all result in the same error:

How old is your printer? I ask because I had to add a 32 bit library to the system for the printer driver to work (DCP-7060D) Don’t know if that’s relevant here, if it is lib32-glibc might help. And drivers for pretty near anything they ever made are available on the Brother support site.

I’ve got the drivers off the brother website ( or I wouldn’t have been able to follow the instructions to make my own packages ).

Hello @dodgypast
The open printing site lists it as a paperweight.

https://www.openprinting.org/printers/manufacturer/Brother/

But, you can still try. Did you use Arch program debtap to convert the .deb package to Arch?
Both the .deb files are here and the installer package which is ZIP/RAR

Yup, followed the process of downloading the .deb files and converting them by writing a PKGBUILD and running makepkg on them both, and installing them with pacman -U.

I manually found the .ppd file and used that as part of the install process but I still get the error shown in the picture.

Did you specifically try the debtap package that automatically converts .deb packages to Arch?

Edit: It’s in the AUR if you want to try it.

https://aur.archlinux.org/packages/debtap

How would that be different to what I’ve done following this?
https://wiki.archlinux.org/index.php/Packaging_Brother_printer_drivers

Don’t know if it’s any different or not. Just passing it along. :neutral_face:

I got it working… first I needed to find the .ppd file:

brother_mfct800w_printer_en.ppd

That was needed by cups.

Then my shot in the dark was to take cupswrappermfct800w from the cups wrapper package, rename it as brother_lpdwrapper_mfct800w and put it in /usr/lib/cups/filter.

Finally after playing around with different connection methods ipp://192.168.1.135/ipp/print worked.

I am one happy bunny.

1 Like

How did you find the .ppd file?

/usr/share/.ppd

Ah yes it was there but CUPS didn’t recognize it.

Edit: Just curious as i have a brother printer but mine has a driver in the AUR so i didn’t have to go through this.

/pkg/brother-mfc-t800wcups/opt/brother/Printers/mfct800w/cupswrapper
cupswrappermfct800w

Is in the same location.

I’ve no idea how I’d create an AUR package of this, but hopefully people might find this with google if they have similar issues.

1 Like

You may not want to play with this now as you got your printer working, but maybe in the future this may come in handy.

I went to the Brother Web Site and found the Advanced User’s Guide for your printer.
The guide said it was for the following Brother Printers:
DCP-T300 DCP-T500W DCP-T700W & MFC-T800W
So we now assume that the drivers for these 4 printers are very similar.

Next, hop on over to the Arch AUR. A quick search found the following packages
brother-dcpt300 brother-dcpt500w & brother-dcpt700w.
From the brother-dcpt700W AUR page, did a “Download snapshot” and unzipped the file.
Which yields the following files:
brother-dcpt700w.install fix_lp.patch LICENSE PKGBUILD .SRCINFO

Now it was a matter of editing all the files, except LICENSE, and substituting all references of DCP-T700 to MFC-T800W info. Then getting md5sum for the new files. I ensured that pkg lib32-glibc was installed and ran makepkg.
Voila, it compiled no problem.

So now, you can download the revised “snapshot” from my web site:

After downloading, from your favorite file manager, in your home directory, make a folder named Brother or whatever pleases you. Copy the downloaded tar package into this folder.
Go to this folder and double click on the tar.xz file and hopefully file roller will offer to extract the files into the Brother folder. You should see
brother-mfct800w.install fix_lp.patch LICENSE PKGBUILD .SRCINFO
With a text editor, list the individual files and look them over real close.
After inspecting them, if you feel they are safe and nothing fishy going on, and you decide to trust me, you can compile it.

In a terminal cd into the Brother folder and do the following:
$ pacman -Q lib32-glibc
If lib32-glibc is not listed, install it with sudo pacman -S lib32-glibc
Still in the Brother folder, as user (not sudo or root) do the following:
$ makepkg PGKBUILD (this will compile the pacman package, but NOT install it).
After the compile finishes, you should find a file named
brother-mfct800w-3.0.2-1-x86_64.pkg.tar.xz
You don’t have to install it now since the printer is working, but you can put the .pkg.tar.xz file on a USB thumb drive or someplace safe for next time you want to install the printer on an Arch based distribution. Since the last update on the drivers (3.0.2) was in 2015, it is safe to say no further driver development will be performed for this printer. So you can erase all the files in the Brother folder, except the brother-mfct800w-3.0.2-1-x86_64.pkg.tar.xz file.
To install it, from a terminal window in the folder that contains the pkg.tar.xz file
ensure that lib32-glibc is installed.
ensure that cups and cups-pdf are installed and org.cups.cupsd.service is enabled in systemd
$ sudo pacman -U brother-mfct800w-3.0.2-1-x86_64.pkg.tar.xz
from a browser go to localhost:631 and install the drivers. Use ipp as you mentioned and chose this driver
Brother MFC-T800W for CUPS en

for the scanner
$ yay -S brscan4
If the printer is connected on the ethernet LAN, and not a USB port on the computer. Then after yay -S brscan4 enter
# brsaneconfig4 -a name=“Brother” model=“MFC-T800W” ip=“192.168.XXX.XXX”

The above is what I had to do to get my Brother DCP-L2550DW installed properly. Have used the resulting .pkg.tar.xz file numerous times since.

Pudge

5 Likes

Why not simply use the Brother install tool from Brother’s website?
I have done this several times on Arch and Manjaro.
And it’s an old aio,

https://support.brother.com/g/b/downloadlist.aspx?c=th&lang=en&prod=mfct800w_all&os=127&flang=English

1 Like

I didn’t know about dpkg… just playing with it now.

That script I have used in the past, and it always worked using debian distros. I’ve always had to install using that script. Now though all my current Ubuntu distros recognize my Brother printer and set it up automatically. I don’t have to do anything now.

Yes, so did I, with Debian, MX-linux and Arch based distro’s.