Any Linux distro underperforms with Intel graphics card - it lags when using web browsers

pacman -Qs libva

look there is something installed…


look if libva-intel-driver is installed . intel-media-driver is since broadwell , but i think you have those to install , and reboot … dan do the vainfo again

    Video Acceleration (VA) API for Linux
local/libva-utils 2.6.0-1
    Intel VA-API Media Applications and Scripts for libva

This is what is installed.

sudo pacman -S --needed libva-intel-driver intel-media-driver

I ran this to install the two packages.

After I rebooted into Linux-LTS kernel, I ran vainfo and I got this result.

vainfo: VA-API version: 1.6 (libva 2.6.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Kaby Lake - 2.4.0
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            :	VAEntrypointVLD
      VAProfileMPEG2Simple            :	VAEntrypointEncSlice
      VAProfileMPEG2Main              :	VAEntrypointVLD
      VAProfileMPEG2Main              :	VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline:	VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:	VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline:	VAEntrypointEncSliceLP
      VAProfileH264Main               :	VAEntrypointVLD
      VAProfileH264Main               :	VAEntrypointEncSlice
      VAProfileH264Main               :	VAEntrypointEncSliceLP
      VAProfileH264High               :	VAEntrypointVLD
      VAProfileH264High               :	VAEntrypointEncSlice
      VAProfileH264High               :	VAEntrypointEncSliceLP
      VAProfileH264MultiviewHigh      :	VAEntrypointVLD
      VAProfileH264MultiviewHigh      :	VAEntrypointEncSlice
      VAProfileH264StereoHigh         :	VAEntrypointVLD
      VAProfileH264StereoHigh         :	VAEntrypointEncSlice
      VAProfileVC1Simple              :	VAEntrypointVLD
      VAProfileVC1Main                :	VAEntrypointVLD
      VAProfileVC1Advanced            :	VAEntrypointVLD
      VAProfileNone                   :	VAEntrypointVideoProc
      VAProfileJPEGBaseline           :	VAEntrypointVLD
      VAProfileJPEGBaseline           :	VAEntrypointEncPicture
      VAProfileVP8Version0_3          :	VAEntrypointVLD
      VAProfileVP8Version0_3          :	VAEntrypointEncSlice
      VAProfileHEVCMain               :	VAEntrypointVLD
      VAProfileHEVCMain               :	VAEntrypointEncSlice
      VAProfileHEVCMain10             :	VAEntrypointVLD
      VAProfileHEVCMain10             :	VAEntrypointEncSlice
      VAProfileVP9Profile0            :	VAEntrypointVLD
      VAProfileVP9Profile0            :	VAEntrypointEncSlice
      VAProfileVP9Profile2            :	VAEntrypointVLD

This fine :+1: it runs

1 Like

Thanks for your help :slight_smile:

What are they anyways?

Can help if you u play a video with mpv as example with hardware acceleration

1 Like

Hey man. So I did do a benchmark test with the CPU and graphics card between EndeavourOS and Windows 10. For the CPU test I used geekbenchmark. While on EndeavourOS the test did better than Windows 10 for both single core and multicore tests, however for the graphics card test I used phoronix and I specifically used unigine-heaven and managed to score a slightly higher score on Windows than EndeavourOS.

Windows 10


I am still noticing more lag when using any web browser when scrolling or anything really compared to Windows 10, particularly with this website (this site is where I got the information as to what test I should do for phoronix)
I feel like something is not optimised with my laptop’s hardware when running EndeavourOS. Is there something I can do to fix this?

keep in mind linux is not windows and windows not linux.

There is stil some gap in performance like gaming its because more games support windows and its hardware driver suport more the os. even intel is a opensource driver… on that part intel graphics is on linux kinda flat… nvidia drivers probably improves a bit with there nonfree but would not be exactly on there windows counterpart for the nvidia card… as nvidia nonfree vs nouveau is also difference. just keep that inmind… persue the pefect scheme can cause also some pain, libva just improves ‘things’ but is not that improves a lot… intel is stil a opensource driver… intel deliver documentation and some patch but performance whise is a different then intel own driver …

thats my view :slight_smile:

you can peek always on if you want tosee what missed.

I am surprised Intel drivers are bad on Linux. I thought if Intel made the drivers they should try and get it to work very well on both Linux and Windows.

Yes that is true.

install the xf86-video-intel package. (Often not recommended, see note below.)

I could give this is a try to see if it somehow works.

Make sure you do not have nomodeset or vga= as a kernel parameter, since Intel requires kernel mode-setting.

How do I check for this?

Is there anything else I can do? Because it is laggy enough to the point where I can’t use it as a daily driver and if I can’t find a solution to this laggy problem then I might not be able to use EndeavourOS.

best is someone can feedback this, i dont have intel. try to disable composition in wm look if performance wise change a bit. on somepoint it tells to remove i dont know whats right or wrong painfully.

there is a gui for mesa as example

but you have to know to configure properly can be misleading from me… im sure there is enough intel users stil here…

1 Like

Ok I will try some of the solutions you have provided, hopefully it helps.

  • adriconf (Advanced DRI Configurator) — GUI tool to configure Mesa drivers by setting options and writing them to the standard drirc file. || adriconf

  • DRIconf — Configuration applet for the Direct Rendering Infrastructure. It allows customizing performance and visual quality settings of OpenGL drivers on a per-driver, per-screen and/or per-application level. || driconfAUR

I installed both of these softwares, I can’t seem to find how to disable composition in wm

using kde or xfce ?

I am using KDE.

KDE performs very smoothly. I noticed in live mode (since by default we boot into xfce) it was still laggy here and there when scrolling in web browsers.

i think in Display in settings you see options like composition you can disable it or enable it.

Also you can choose which renderer , like opengl or xrender. xrender (software render) is can come faster but on on other option mayby missing i dont know…standard is AUTO that can be a issue mayby i dont know… om Vega auto option is not so fine…

I don’t think it was there.

However when I searched for this in the start menu, I found OpenGL settings

Is it through here I would disable this?

the options could be more under , but something as screen/display … but will be a option which render , standard would be auto …hard to tell i dont use Kde.

I just found it. Let me try and see if it lags less.

Using xrenderer seems less laggy but it causes screen tearing and it still severely lags on this website

I also tried OpenGL3.1 and that seemed like the same as OpenGL2.0

ok i let a rest mayby i found something otherwise i get to busy in short time lol

1 Like

Thanks mate for your help anyways :slight_smile: