Any and all 3D apps that run thru WINE lag

For example, Roblox just stutters ALL THE TIME when under windoze it runs fine.

Same with Ultimate Doom Builder, but its 3D mode is downright unusable.
Which is a shame since UDB has some nice features like making doors that usually work.

inxi -Fxza

  Kernel: 5.19.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=91691606-aa74-48ac-9cb5-34b6d123b103 rw rootflags=subvol=@
    sysrq_always_enabled=1 loglevel=3 nowatchdog nvme_load=YES
  Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1
    dm: SDDM Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: HP product: HP Laptop 15-bs0xx v: Type1ProductConfigId
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 832C v: 25.56 serial: <superuser required> UEFI: Insyde
    v: F.68 date: 07/22/2021
  ID-1: BAT1 charge: 23.4 Wh (100.0%) condition: 23.4/31.1 Wh (75.4%)
    volts: 12.5 min: 11.1 model: COMPAL PABAS0241231 type: Li-ion
    serial: <filter> status: full
  Device-1: hidpp_battery_0 model: Logitech K350 serial: <filter> charge: 70%
    (should be ignored) rechargeable: yes status: discharging
  Device-2: hidpp_battery_1 model: Logitech Marathon Mouse/Performance Plus
    M705 serial: <filter> charge: 10% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: Intel Pentium N3710 bits: 64 type: MCP arch: Airmont
    built: 2015-17 process: Intel 14nm family: 6 model-id: 0x4C (76)
    stepping: 4 microcode: 0x411
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 224 KiB
    desc: d-4x24 KiB; i-4x32 KiB L2: 2 MiB desc: 2x1024 KiB
  Speed (MHz): avg: 2062 high: 2563 min/max: 480/2560 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 2562 2: 2563 3: 2131
    4: 994 bogomips: 12800
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass status: Not affected
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx
    Integrated Graphics vendor: Hewlett-Packard driver: i915 v: kernel
    arch: Gen-8 process: Intel 14nm built: 2014-15 ports: active: eDP-1
    empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:22b1
    class-ID: 0300
  Device-2: Chicony HP Webcam type: USB driver: uvcvideo bus-ID: 1-5.2:5
    chip-ID: 04f2:b5db class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: intel unloaded: modesetting alternate: fbdev,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: eDP-1 mapped: eDP1 model: AU Optronics 0x10ec built: 2016
    res: 1366x768 hz: 60 dpi: 102 gamma: 1.2 size: 340x190mm (13.39x7.48")
    diag: 394mm (15.5") ratio: 16:9 modes: 1366x768
  OpenGL: renderer: Mesa Intel HD Graphics 405 (BSW) v: 4.6 Mesa 22.1.6
    direct render: Yes
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series
    High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel
    v: kernel bus-ID: 00:1b.0 chip-ID: 8086:2284 class-ID: 0403
  Sound Server-1: ALSA v: k5.19.3-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
  Device-1: Realtek RTL8188EE Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtl8188ee v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:8179
    class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 1000 bus-ID: 03:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Local Storage: total: 465.76 GiB used: 335.93 GiB (72.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500LT012-1DG142
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: YAM1
    scheme: GPT
  ID-1: / raw-size: 60 GiB size: 60 GiB (100.00%) used: 38.57 GiB (64.3%)
    fs: btrfs dev: /dev/sda5 maj-min: 8:5
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 153 MiB
    (59.8%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 60 GiB size: 60 GiB (100.00%) used: 38.57 GiB
    (64.3%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
  ID-4: /var/log raw-size: 60 GiB size: 60 GiB (100.00%) used: 38.57 GiB
    (64.3%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
  Alert: No swap data was found.
  System Temperatures: cpu: 54.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 206 Uptime: 4h 47m wakeups: 66 Memory: 3.74 GiB used: 1.86 GiB
  (49.7%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 Packages: pacman: 1297 lib: 324 Shell: Zsh v: 5.9
  default: Bash v: 5.1.16 running-in: yakuake inxi: 3.3.20

If things don’t work correctly under WINE then using Windows is a reasonable workaround…

Have you tried switching to the modesetting driver to see if that helps?

sudo pacman -R xf86-video-intel

Then reboot.



The only reasonable workaround is to mess with configs and wine prefixes, sometimes for hours upon hours, until you either get it working or convince yourself that you don’t really need it and give up. There is no third option! :rofl:


Grapejuice (you are using it, right?) allows you to change render backends. Try using Vulkan, switch to OpenGL if you are not satisfied and if that fails too use DX11 with DXVK enabled. One of these should work.

For other games, make sure you install DXVK to your prefix.

Yes I use Grapejuice.

My crappy iGPU doesn’t support Vulkan, Garuda had this weird lavapipe thing.

See this, I messed around with renderers and got almost nothing.

It sorta helps. But I still get stuttering in Ultimate Doom Builder when i’ve only made 1 room, with NO custom textures, and it stutters when I move or turn. It sucks, considering that the slade3 map editor isn’t nearly as good. (when it works normally ofc)



Yeah tbh I don’t want to reboot every time I want to play Roblox or make a Doom map then inevitably rage quit.

VMs aren’t an option bc my PC is a real potato.

I am not a wine expert so someone might have other ideas but I would say that wine is an emulation layer and your PC specs are borderline so it might be too much to ask.

That being said, does it work for you on any other distros or are they all the same performance-wise?

On garuda it kinda still sucked. any other distro I can’t say anything as none touched my HDD.

I thought WINE was

Not an

And you all know I’m not going back to Debian/Ubuntu and apt, you know. It makes me shudder…

I wasn’t suggesting you switch. I was just thinking that if it worked well on another distro, we should be able to make it work here too.

On the other hand, if that is the max performance you can get on any distro, it probably won’t be any different here.

TBH I do have openSUSE tumbleweed in my ventoy.

Maybe that ought to work?

But this baffles me, Windwoes handles these not at all demanding apps fine, is WINE slowing it down that much? if it did reports of Linux gaming faster than windwoes would be impossible.

So, this wasn’t due to Latte dock?


True, but now the problem reappeared and I don’t have latte dock. Even then in my less-than-3-hours dualboot of both I think I still had slight lag IIRC.

Oh and disabling the compositor does nothing.

Your iGPU supports Vulkan. Search “n3710” (your processor model) in that page and you will see you have HD Graphics 405 with support for Vulkan 1.1, exclusively on Linux.
If you didn’t have Vulkan support I would agree with jonathon but we have a choice here.

Install necessary packages for Vulkan;

sudo pacman -R vulkan-swrast
sudo pacman -S --needed mesa lib32-mesa vulkan-intel lib32-vulkan-intel vulkan-icd-loader lib32-vulkan-icd-loader vulkan-tools

Then check Vulkan is working, you are supposed to see a spinning cube:


Now try different renderers again on Roblox and install DXVK to your other games’ prefixes.

1st command, pacman complained that didn’t exist.
2nd command worked.
vkcube also worked with no visible stuttering.

Installed Bottles, installed DXVK for the bottle, ran Ultimate Doom Builder, and absolutely nothing has changed about the performance. Still have to test roblox.

On that Garuda thread my system was also getting hot, which means that some how Linux isn’t cooling my system properly. Maybe another DE?

Roblox wasn’t ideal, but it was playable. Around 20fps in untitled tag game, and EVERYTHING that wasn’t the physics line was at most orange. The physics line was green :slight_smile: I guess my PC is good at roblox physics lol.

In UNOfficial, it lagged a bit at times but since it’s a turn based game it’s no biggie.

Ultimate Doom Builder 3D mode is still downright unusuable.

When I tried downloading some windows only source ports, I noticed a dxvk log file in the directory, this should mean DXVK is working, correct?

btw this is when I installed DXVK thru winetricks to WINEPREFIX.